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Overview

Agisoft Metashape is a stand-a one software product that performs photogrammetric processing of digital
images (aeria and close-range photography, satellite imagery) and generates 3D spatial data to be used
in GIS applications, cultural heritage documentation, and visua effects production as well as for indirect
measurements of objects of various scales. The technology also allows to work with laser scans and to
combine datafrom LiDAR and camerain the same project.

The software alows to process images from RGB, therma or multispectral cameras, including multi-
camera systems, as well as structured terrestrial laser scans and unstructured aerial laser scans into
the spatial information in the form of point clouds, textured polygonal models, georeferenced true
orthomosaicsand DSMS/DTMs. Further post-processing enablesto eliminate shadowsand texture artifacts
from the models, cal cul ate vegetation indices and extract information for farming equipment action maps,
automatically classify point clouds, etc. Metashape is capable of processing of 50 000+ photos across
aloca cluster, thanks to distributed processing functionality. Alternatively, the project can be sent to
the cloud to minimize hardware investment, with al the processing options being still available. Wisely
implemented digital photogrammetry technique enforced with computer vision methods results in smart
automated processing system that, on the one hand, can be managed by a new-comer in the field of
photogrammetry, yet, on the other hand, has alot to offer to a speciaist who can benefit from advanced
features like stereoscopic mode and have complete control over the results accuracy, with detailed report
being generated at the end of processing.

How it works

Typical tasks for a photogrammetry processing project in Metashape are to build a 3D surface and an
orthomosaic. Data processing procedure with Agisoft Metashape consists of three main steps.

1. The first step is called alignment. It includes aeria triangulation (AT) and bundle block adjustment
(BBA). At this stage Metashape searches for feature points on the images and matches them across
images into tie points. The program aso finds the position of the camera for each image and
refines camera calibration parameters (estimates interior (10) and exterior (EO) camera orientation
parameters).

The results of these procedures are visualized in the form of atie point cloud and a set of camera
positions. The tie point cloud represents the results of image alignment and will not be directly used
in further processing (except for the tie point cloud based surface reconstruction method, which is
suitable only for quick estimates, e.g., of completeness of adata set). But thetie point cloud is necessary
for the determination of depth maps (based on the common tie points camera pairs for the depth
maps calculation are selected). However it can be exported for further usage in external programs. For
instance, atie point cloud model can be used in a 3D editor as a reference. On the contrary, the set of
camerapositionsisrequired for further 3D surface reconstruction by Metashape. If the project includes
LiDAR data, the scans can also be aligned relatively to each other and/or together with theimagery data.

2. The second step is generation of a surface in 3D (mesh) and/or 2.5D (DEM). Polygonal model (mesh)
can be textured for photorealistic digital representation of the object/scene and exported in numerous
formats compatible with post-processing software, both for CAD and 3D-modeling workflows.

For city-scale projectsto provide for fast model visualization response and allow for smooth navigation
across the whole scene, Metashape enables to generate tiled models. Such hierarchical representation
preserves original resolution of the images applied to the model as a texture and is compatible with
stand-alone and web-based viewers.3D or tiled model can be based on combination of photogrammetric
depth maps and LiDAR data.
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Photogrammetric point cloud can be built by Metashape based on the estimated camera positions and
images themselves (dense matching). Generated photogrammetric point cloud can be merged with
LiDAR data or automatically divided into several semantic classes following the project tasks.

If the digital elevation model (DEM) is generated based on the point cloud data, it can include either
both terrain and all the objects above the ground, like trees, buildings and other man-made structures
(digital surface model, DSM), or only show the landscape of theterritory (digital terrain model, DTM).

3. The third step is creating of orthomosaic, which can be georeferenced and used as a base layer for
varioustypes of maps and further post processing analysis and vectorization. Orthomosaic is generated
by projecting the images according to their EO/I O data on a surface of the user's choice: DEM or mesh.

For multispectral imagery projects, orthomosaic can represent NDVI and other vegetation indices
information. Reflectance calibration feature of Metashape allows to correctly interpret radiometric
imagery data, providing that radiometric panel has been used in the project and/or sun sensor
information is available in the images meta data.

About the manual

Basically, the sequence of actions described above covers most of the data processing needs. All these
operations are carried out automatically according to the parameters set by user. Instructions on how to
get through these operations and descriptions of the parameters controlling each step are given in the
corresponding sections of the Chapter 3, General workflow chapter of the manual.

In some cases, however, additional actions may be required to get the desired results. In some capturing
scenarios masking of certain regions of the photos may be required to exclude them from the cal cul ations.
Application of masksin Metashape processing workflow aswell as editing options avail able are described
in Chapter 6, Editing. Camera calibration issues are discussed in Chapter 4, Referencing, that also
describes functionality to optimize cameraalignment results and provides guidance on model referencing.
A referenced model, be it amesh or a DEM serves as a ground for measurements. Area, volume, profile
measurement procedures are tackled in Chapter 5, Measurements, which also includes information on
vegetation indices cal culations. While Chapter 7, Automation describes opportunitiesto save up on manual
intervention to the processing workflow, Local network processing presents guidelines on how to organize
distributed processing of the imagery data on severa nodes.

It can take up quite along time to reconstruct a 3D model. Metashape allows to export obtained results
and save intermediate datain aform of project files at any stage of the process. If you are not familiar with
the concept of projects, its brief description is given at the end of the Chapter 3, General workflow.

In the manual you can aso find instructions on the Metashape installation and activation procedures and
basic rules for taking "good" photographs, i.e. pictures that provide most necessary information for 3D
reconstruction. For theinformation refer to Chapter 1, Installation and Activation and Chapter 2, Capturing
scenarios.

Vi



Chapter 1. Installation and Activation

System requirements

Minimal configuration

e Windows 7 SP 1 or later (64 bit), Windows Server 2008 R2 or later (64 bit), macOS High Sierra or
later, Debian/Ubuntu with GLIBC 2.19+ (64 bit)

* Intel Core 2 Duo processor or equivalent

+ 8GB of RAM

Recommended configuration

» Windows 7 SP 1 or later (64 bit), Windows Server 2008 R2 or later (64 bit), macOS Mojave or later,
Debian/Ubuntu with GLIBC 2.19+ (64 hit)

* Intel Corei7 or AMD Ryzen 7 processor
» Discrete NVIDIA or AMD GPU (4+ GB VRAM)
* 32GB of RAM

The number of photos that can be processed by Metashape depends on the available RAM and
reconstruction parameters used. Assuming that a single photo resolution is of the order of 10 MPix, 4 GB
RAM is sufficient to make a model based on 30 to 50 photos. 16 GB RAM will allow to process up to
300-500 photographs.

GPU recommendations

Metashape supports accelerated image matching; depth maps reconstruction; depth maps based mesh,
DEM and tiled model generation; texture blending; photoconsistent mesh refinement operation due to the
graphics hardware (GPU) exploiting.

NVIDIA
GeForce GTX 7xx series and later, Quadro M4000 and later with CUDA support.

AMD
Radeon R9 series and |ater, Radeon Pro WX 7100 and later with OpenCL 1.2 support.

Metashape is likely to be able to utilize processing power of any CUDA enabled device with compute
capability 3.0 and higher or OpenCL 1.2 and higher enabled device with SPIR support for stages specified
above, provided that CUDA/OpenCL drivers for the device are properly installed. However, because of
the large number of various combinations of video chips, driver versions and operating systems, Agisoft
is unable to test and guarantee M etashape's compatibility with every device and on every platform.

The processing performance of the GPU device is mainly related to the number of CUDA cores for
NVIDIA video chipsand the number of shader processor unitsfor AMD and Intel video chips. Additionally
depth maps based mesh, DEM and tiled model reconstruction as well as photoconsistent mesh refinement
operations and texture blending would benefit from larger amount of VRAM available.
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Thetable below lists currently supported devices (on Windows platform only). Agisoft will pay particular
attention to possible problems with Metashape running on these devices.

Table 1.1. Supported Desktop GPUs on Windows platform

NVIDIA AMD

GeForce RTX 3080 Radeon RX 6800
GeForce RTX 2080 Ti Radeon VI
TeslaV100 Radeon RX 5700 XT
TedaM60 Radeon RX Vega 64
Quadro P6000 Radeon RX Vega 56
Quadro M6000 Radeon Pro WX 7100
GeForce TITAN X Radeon RX 580
GeForce GTX 1080 Ti FirePro W9100
GeForce GTX TITAN X Radeon R9 390x
GeForce GTX 980 Ti Radeon R9 290x

GeForce GTX TITAN
GeForce GTX 780 Ti

M etashape supports texture blending on GPU using V ulkan technology on Linux and Windows OS. GPU
accelerated texture blending is currently supported for frame and fisheye type cameras on NVIDIA cards
since GeForce GTX 8XX / Quadro M4000 and driver versions from 435.xx and on AMD cards since
Radeon R9 29x series / FirePro W9100 and 17.1.x drivers. Some older GPUs and older driver versions
could also support texture blending using VVulkan, however, it is hot guaranteed.

Although Metashape is supposed to be able to utilize other compatible GPU models and being run under
all supported operating systems, Agisoft does not guaranteethat it will work correctly. However, al GPU-
based processing issues should be reported to Agisoft support team for more detailed investigation.

4 Note

e Use CPU enable flag to allow calculations both on CPU and GPU for GPU-supported tasks.
However if at least one powerful discrete GPU is used it is recommended to disable CPU flag
for stable and rapid processing.

» Using GPU acceleration with mobile or integrated graphics video chips is not recommended
because of the low performance of such GPUs.

* CUDA supported devices for some older macOS versions may require to install CUDA drivers
from official web-site first: http://www.nvidia.com/object/mac-driver-archive.html.

Due to lack of CUDA support on certain macOS versions Metashape will automatically switch
to OpenCL implementation for GPU-based processing on NVIDIA graphic devices.

Installation procedure

Installing Metashape on Microsoft Windows

To install Metashape on Microsoft Windows simply run the downloaded msi file and follow the
instructions.



http://www.nvidia.com/object/mac-driver-archive.html
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Installing Metashape on macOS

Open the downloaded dmg image and drag M etashape application bundle to the desired location on your
hard drive (for example, to Applications folder. Do not run Metashape directly from the dmg image to
avoid issues on license activation step.

Installing Metashape on Debian/Ubuntu

Unpack the downloaded archive with a program distribution kit to the desired location on your hard drive.
Also, install the package: sudo apt install libxch-xinerama0. Start Metashape by running metashape.sh
script from the program folder.

30-day trial and demo mode

Once Metashape is downl oaded and installed on your computer you can run it either in the Demo mode or
in the full function mode. On every start until alicense key sequenceis entered it will show on activation
diaog offering three options: (1) activate Metashape using a valid license code, (2) start a free 30-day
trial, (3) continue using Metashape in Demo mode. Starting a 30-day trial period allows to evaluate the
functionality of the program and explore the software in full-function mode, including save and export
features. Trial license is intended to be used for evaluation purposes only and any commercial use of a
trial license is prohibited.

If you are not ready yet to start the trial period, you can opt for the Demo mode. The employment of
Metashape in the Demo mode is not time limited. Several functions, however, are not available in the
Demo mode. These functions are the following:

» savethe project;

* build tiled model;

* build orthomosaic;

* build digital elevation model (DEM);

* DEM and orthomosaic related features (such as vegetation index calculation, DEM-based
measurements);

» some Python APl commands;

« al export features, including exporting reconstruction results (you can only view a 3D model on the
screen);

* using network and cloud processing features.

To use Metashape in the full function mode for various projects you have to purchase a license. On
purchasing you will get a license code to be entered into the activation dialog of Metashape. Once the
license code is entered you will get full access to all functions of the program and the activation dialog
will no longer appear upon program start, unless the license is deactivated.

Activation procedure

Metashape node-locked license activation

The Node-locked license for Metashape allows to activate the software on one machine at atime. Node-
locked licensefiles are unique for each computer, and aretied to the system hardware. If you areto replace
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major system components or re-install operational system, the license should be deactivated first and then
the same key could be used to activate the license on the renewed system.

4 Note

e The node-locked license activation on Windows OS and macOS may require administrator
privileges. During the activation process additiona confirmation dialog will appear to apply the
elevated privileges.

» To deactivate the license select Activate Product command from Help menu and use Deactivate
button or argument --deactivate in the command line (terminal) to Metashape executable.

» When Metashape software is being uninstalled on Windows OS the license deactivation attempt
will be automatically performed, however, it is recommended to deactivate the license manually
before uninstalling the application.

M etashape software requires alicense key (adigital code) to be activated. First of all, make sure that you
haveavalid license key at hand. The number of activation/deactivation operationsisnot effectively limited
for manual license transfer scenarios. But we recommend technical possibility to transfer a node-locked
license to a new computer not to be exploited in automated scenarios involving activation/deactivation of
the node-locked license on regular basis.

[{ Note

» Excessive usage of activation/deactivation mechanism may result in the situation when user gets
blocked in the activation system.

» For scenarios which involve virtual machines and frequent license activation/deactivation
operations it is recommended to consider floating license option, in which case the license is
automatically returned to the license server when the Metashape is stopped.

The standard activation procedure, which allows to activate the product in the means of seconds, requires
the machine to be connected to the Internet. If it isyour case, please follow the online activation procedure
as described below. In case the system cannot be connected to the Internet, please opt for the offline
activation procedure, which is also described in this section of the manual.

Online Activation Procedure - To activate M etashape on a machine with Internet
connection

1. Launch Metashape software, previoudly installed on your machine, and go to Help menu for Activate
Product... command.

2. InActivation dialog insert license key according to the suggested 5 digit blocks structure. Please note
that license codes never include zero digit - only letter "O".

3. If the license code has been input correctly, then the OK button will become active. Click on it to
complete the activation procedure. If the button is still grayed out, please make sure that the used
license key is meant for the product to be activated. For example, a license key for the Standard
Edition will not allow to activate the Professional Edition, the OK button will remain inactive.

Offline Activation Procedure - To activate Metashape on a machine with NO
I nter net connection

1.  Open https://activate.agisoft.convactivate-offline from a computer with Internet access and generate
the activation parameters file (*.actparam) using the valid license key that needs to be activated.
Transfer the activation parameters file to the computer where the license should be activated.
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2. Launch Metashape software, previously installed on your machine, and go to Help menu for Activate
product... command.

3. Choose Activate offline command in the AgisoftMetashape Professional Activation dialog window.
4. Browse the activation parameter file (*.actparam) obtained on the first step using the corresponding
button and generate the activation request file (*.actreq) by pressing "Save Activation Request..."

button.

5. Transfer (*.actreq) file, that has been acquired on the previous step, to the computer with Internet
access and generate activation response file (* .actresp).

6. Transfer the response file (*.actresp) back to the offline computer where the license should be
activated.

7. Backinthe AgisoftMetashape Professional Activationdiaog pressinstall License... button and select
the response file (*.actresp) to complete the license activation procedure.

If youwould liketo activate/deactivate M etashape software in headless mode, please seethelist of relevant
commands bel ow:

» metashape --activate license_key

» metashape --deactivate

» metashape --activate-offline parameters.actparam request.actreq

» metashape --deactivate-offline request.actreq

» metashape --install-license response.actresp

Run "metashape --help" to see the complete list of the commands available.

Offline activation assumes (*.actparam) and (* .actresp) files generated via Agisoft web-site, as described
above.

Floating licenses

M etashape software can be used under floating license conditions. A floating license allows to install the
software on an unlimited number of machines, which are connected to a server network. However, at any
one time, Metashape can only run on the maximum number of computers for which licenses have been
purchased. Since Metashape can be installed on more systems than the number of licenses purchased, this
enables the licensee to efficiently share the product across the organization.

M etashape floating licenses are borrowable. A borrowed license can be used on a machine disconnected
from the license server network for a certain period (up to 30 days).

Floating license activation procedure consists of the following steps:

Floating license activation procedure (online)

1. Download Agisoft License Server archive using the link corresponding to the OS used on the
computer that isintended to be used as a license server. The links to Agisoft License Server archive
to be downloaded are provided upon floating license purchase.
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2. Run Agisoft License Server utility from the unpacked archive on the computer that isintended to be
used as a Floating License Server in the network in the following format: agisoft-fls --host server-
ip:port (for example: agisoft-fls --host 192.168.10.200:5842).

3.  Open web-interface of the Agisoft License Server Administration panel in the Internet browser
using the address http://server-ip: 5842 (for example: http://192.168.10.200:5842). Create login and
password for the user account and click Login button.

4. Click Licenses button to open Licenses page.

5. Click Activate button on the Licenses page.

6. Set thefollowing values for the parameters in the Activate online table: Activation key and Count.
Click Activate button.

7. On the Licenses page there will then be a list of activated licenses (one line for each activation:
Product + Count)

4 Note

» Use another computer with Internet access for offline activation.

Floating license activation procedur e (offline)

1

Open https://activate.agisoft.convactivate-offline on the computer with Internet access and use the
valid license key to generate the activation parametersfile (* .actparam). Transfer the parametersfile
to the computer where the floating license server will be configured.

Download Agisoft License Server archive using the link corresponding to the OS used on the
computer that is intended to be used as a license server. The links to Agisoft License Server archive
to be downloaded are provided upon the floating license purchase.

Run Agisoft License Server from the unpacked archive on the computer that is intended to be used
as aFloating License Server in the network in the following format: agisoft-fls --host server-ip:port
(for example: agisoft-fls --host 192.168.10.200:5842. The default port is 5842).

Open web-interface on the Agisoft License Server in the Internet browser http://server-ip: 5842 (for
example: http://192.168.10.200:5842). Create login and password for the new user account and click
Login button.

Click Licenses button to open Licenses page.

Select the following parameters. Activation parametersin (*.actparam) format and Count. Click
Save Activation Request button. Transfer the request file to a computer with Internet access, open
https: //activate.agi soft.com/activate-offline and generate the activation response file (*.actresp) and
transfer the response file to the server computer.

Select the response file (*.actresp) obtained on the previous step in the Activation response section
of the license server web-interface. Press Install License button to complete the license activation
procedure.

£ Note

* Onthe Licenses page there will then be alist of activated licenses (one line for each activation:
Product + Count)
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To borrow afloating license

1

Connect the machine you would like to borrow the license for to the server machine and make sure
that there is a spare floating license in the server pool (displayed on Usage page of the license server
web-interface).

Run Metashape software on the machine. Select Activate Product... command from Help menu.

Click Borrow License button in the MetashapeActivation dialog. Set the number of days you would
like to borrow the license for and click OK button. The number of days should not exceed 30.

Now the machine can be disconnected from the server network, with Metashape being kept activated
onit.

To return the borrowed license connect the computer to the license server network, start Metashape,
select Activate Product... command from the Help menu and click Return License button in Activate
dialog window. Otherwise the license will be automatically returned to the server pool after the
borrowing period is over.

Floating license deactivation procedur e (online)

1. Open web-interface on the in the Internet browser http://server-ip:5842 (for example:
http://192.168.10.200:5842).

2. Click Licenses button.

3. Click Deactivate button on the Licenses page.

4. Specify the Product - metashape-pro in the Deactivate online section. And click Deactivate button.

4  Note

« Please note that during deactivation, ALL licenses for the selected product will be deactivated.

Floating license deactivation procedur e (offline)

1. Open web-interface on the in the Internet browser http://server-ip:5842.

2. Click Licenses button.

3. Click Deactivate button.

4. Select the product to deactivate and press Save Deactivation Request button in Deactivate offline
using another computer with Internet access section in order to save the request file (*.actreq).

5. Transfer thereguest fileto acomputer with Internet access, open https://activate.agisoft.convactivate-
offline and complete the license deactivation procedure there.

6. Click Browse button and choose (*.actreq) file and click Deactivate button.

4 Note

» Pleasenotethat after use of Save Deactivation Request button, all floating licensesfor the selected
product will be removed from the server. This action can't be undone.




Installation and Activation

Totransfer the Agisoft License Server

1. Deactivate Agisoft License Server in web-interface as described above. Please note that during
deactivation, ALL licenses for the selected product will be deactivated.

2. Activate Agisoft License Server on anew server. Use activation procedure described above (offline
or online procedure).




Chapter 2. Capturing scenarios

Photographs suitable for 3D model reconstruction in Metashape can be taken by any digital camera (both
metric and non-metric), aslong as specific capturing guidelines arefollowed. This section explainsgeneral
principles of taking and selecting pictures that provide the most appropriate datafor 3D model generation.

IMPORTANT! Make sure to study the following rules and read the list of restrictions before getting out
for shooting photographs.

Equipment

Use adigital camerawith reasonably high resolution (5 MPix or more). It is aso recommended to take
photo in the max possible allowed resolution.

The best choice is 50 mm focal length (35 mm film equivalent) lenses. It is recommended to use focal
length from 20 to 80 mm interval in 35mm equivalent.

Avoid ultra-wide angle and fisheye lenses. The distortion of the lenses used to capture the photos should
be well simulated with the camera model used in the software. Generally, Brown's distortion model
implemented in Metashape workswell for frame cameras. However, since fisheye and ultra-wide angle
lenses are poorly simulated by the mentioned distortion model, it is crucia to choose the proper camera
type in the Camera Calibration dialog prior to processing such data - the software will switch to the
appropriate distortion model.

Fixed lenses are preferred. If zoom lenses are used - focal length should be set either to maximal or to
minimal value during the entire shooting session for more stable results, for intermediate focal lengths
separate camera calibration groups should be used.

1SO should be set to the lowest value, otherwise high 1SO values will induce additional noise to images.

Aperture value should be high enough to result in sufficient focal depth: it isimportant to capture sharp,
not blurred photos.

Shutter speed should not be too slow, otherwise blur can occur due to slight movements.

Using RAW datalosslessly converted to the TIFF filesis preferred, since JPG compression may induce
unwanted noise to the images.

Object/scene requirements

Avoid untextured, shiny, highly reflective or transparent objects. If shiny objects cannot be avoided
wait for a cloudy day to capture them. Direct sunlight leads to patches on most of the surfaces; the light
patches which have moved across the target object during the shooting process will create difficulties
for reconstruction algorithms.

Consider using lighting when shooting underwater or a constant source of light that will increase the
visible distance and quality of the obtained images.

It is recommended to plan the shooting session in such away that unwanted foregrounds, backgrounds,
aswell as moving objects are avoided on the images.

Avoid absolutely flat objects or scenes. The object of interest should take up the maximum proportion
of the image possible. In some cases, the portrait camera orientation option should be considered.




Capturing scenarios

Capturing scenarios

The shooting scenario depends on the object of the survey (this is a forest area, a detached building, a
monument, etc.).

Aerial photography

In case of aeria photography the overlap requirement can be put in the following figures: 60% of side
overlap + 80% of forward overlap. When making a survey over aforest, it is recommended to increase
the overlap value to 80% and 90% respectively. To achieve better overlap, we can recommend cross-
to-cross routes.

Itisimportant plan aflight with a proper elevation model considered.

Do not perform an aerial survey of forest areas lower than 300 meters above the ground. Tree crowns
are moved by the wind hence the results of capturing at low altitude may be problematic for processing
in Metashape, as the software may fail to find common points on the images.

Do not perform an aerial survey of mountain areas |lower than 100 meters above the ground.

Itisnot recommended to perform an aerial survey of the sameareafor thewholeday. Lighting conditions
change during the day. Having the photos of the same territory with different lighting (for example
long shadows from the same structures pointing in completely different directions and having different
shapes) may result in Metashape failing to find common points on the overlapping photos.

In case of aerial photography and demand to fulfill georeferencing task, even spread of ground control
points (GCPs) (at least 10 across the area to be reconstructed) is required to achieve results of highest
quality, both in terms of the geometrical precision and georeferencing accuracy. Y et, AgisoftMetashape
is able to complete the reconstruction and georeferencing tasks without GCPs, too.

Underwater survey

Underwater surveying projects are considerably harder compared to the regular indoor/outdoor image
acquisition procedure due to the very hard environment conditions (viewing distanceislimited, controlled
light environment isalmost not applicable, difficult to place and fix even afew control pointsin scene, may
be hard to repeat the operation). Thereforeit isagood ideato plan the survey carefully before performing
actua shooting session. Taking more images than needed is always better than having insufficient image
overlap or incompl ete dataset.

The optimal cameraroutes are "snake" and "spiral" routes. If possible wait for the calm weather and bright
light - it will allow to increase the visible distance.

Close-range objects scanning

Number of photos: more than required is better than not enough.

Number of "blind-zones" should be minimized since Metashape is able to reconstruct only geometry
visible from at least two cameras.

Each photo should effectively use the frame size: object of interest should take up the maximum area.
In some cases portrait camera orientation should be used.

Do not try to placefull object in theimage frame, if some partsare missing it isnot aproblem providing
that these parts appear on other images.
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« If any measurements are planned on the reconstructed model, do not forget to locate at | east two markers
with a known distance between them on the object. Alternatively, a ruler can be placed within the
shooting area.

The following figures represent advice on appropriate capturing scenarios:
Facade (Incorrect) Facade (Correct)
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Image preprocessing

» Metashape operates with the original images. So do not crop or geometrically transform, i.e. resize
or rotate, the images. Processing the photos which were manually cropped or geometrically warped is
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likely to fail or to produce highly inaccurate results. Photometric modifications (such as brightness or
contrast adjustment) do not affect reconstruction results, providing that no hard filters are applied that
could remove minor details on the images (e.g. Gaussian blur filter).

Restrictions

In some cases it might be very difficult or even impossible to build a correct 3D model from a set of
pictures. A short list of typical reasons for photographs unsuitability is given below.

Modifications of photographs

M etashape can process only unmodified photos as they were taken by a digital photo camera. Processing
the photos which were manually cropped or geometrically warped is likely to fail or to produce highly
inaccurate results. Photometric modifications do not affect reconstruction results.

Lack of EXIF data

Metashape calculates initial values of sensor pixel size and focal length parameters based on the EXIF
data. The better initial approximation of the parameter valuesis, the more accurate autocalibration of the
camera can be performed. Therefore, reliable EXIF data is important for accurate reconstruction results.
However 3D scene can also be reconstructed in the absence of the EXIF data. In this case Metashape
assumes that focal length in 35 mm equivalent equalsto 50 mm and tries to align the photosin accordance
with this assumption. If the correct focal length value differs significantly from 50 mm, the alignment can
giveincorrect resultsor even fail. In such casesit isrequired to specify initial cameracalibration manually.

The details of necessary EXIF tags and instructions for manual setting of the calibration parameters are
given in the Camera calibration section.

Lens distortion

The distortion of the lenses used to capture the photos should be well simulated with the camera model
used in the software. Generally, Brown'sdistortion model implemented in Metashape workswell for frame
cameras. However, since fisheye/ultra-wide angle lenses are poorly simulated by the mentioned distortion
model, it is crucial to choose proper cameratypein Camera Calibration dialog prior to processing of such
data - the software will switch to the appropriate distortion model.

Lens calibration

It is possible to use Metashape for automatic lens calibration. M etashape uses LCD screen asacalibration
target (optionally it ispossibleto use aprinted chessboard pattern, providing thatitisflat and al itscellsare
squares). Lens calibration procedure supports estimation of the full camera calibration matrix, including
non-linear distortion coefficients. The details of camera models are given in the Appendix D, Camera
model s section.

4 Note

 Lenscalibration procedure can usually be skipped in common workflow, as M etashape cal cul ates
the calibration parameters automatically during Align Photos process. However, if the alignment
results are unstable, for example, due to the lack of the tie points between the images, the lens
calibration may be useful.
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The following camera calibration parameters can be estimated:

f
Focal length measured in pixels.

CX, cy
Principal point coordinates, i.e. coordinates of lensoptical axisinterceptionwith sensor planein pixels.

b1, b2
Affinity and Skew (non-orthogonality) transformation coefficients.

k1, k2, k3, k4
Radia distortion coefficients.

pl, p2
Tangential distortion coefficients.

Before using lens calibration tool a set of photos of calibration pattern should be loaded in Metashape.

To capture photos of the calibration pattern:

1. Select Show Chessboard... command from the Lens submenu in the Tools menu to display the
calibration pattern.

2. Use mouse scroll wheel to zoom in/out the calibration pattern. Scale the calibration pattern so that
the number of squares on each side of the screen would exceed 10.

3. Captureaseries of photos of the displayed calibration pattern with the camerafrom dlightly different
angles, according to the guidelines, outlined below. Minimum number of photos for a given focal
length is 3.

4. When calibrating zoom lens, change the focal length of the lens and repeat the previous step for other
focal length settings.

5. Click anywhere on the calibration pattern or press Escape button to return to the program.
6. Upload the captured photos to the computer.

When capturing photos of the calibration pattern, try to fulfill the following guidelines:

» Make sure that the focal length keeps constant throughout the session (in case of zoom lens).
» Avoid glare on the photos. Move the light sources away if required.

» Preferably, the whole area of the photos should be covered by calibration pattern. Move the camera
closer to the LCD screenif required.

Toload photos of the calibration pattern:

1 Create new chunk using & Add Chunk toolbar button on the Workspace pane or selecting Add Chunk

command from the Workspace context menu (available by right-clicking on the root element on the
Workspace pane). See information on using chunks in Using chunks section.

2.  Select Add Photos... command from the Workflow menu.

13
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3. Inthe Open dialog box, browse to the folder, containing the photos, and select files to be processed.
Then click Open button.

4. Loaded photoswill appear in the Photos pane.

4 Note

e Open any photo by double clicking on its thumbnail in the Photos pane. To obtain good
calibration, the photos should be reasonably sharp, with crisp boundaries between cells.

¢ Unwanted photos, can easily be removed at any time.

« Before calibrating fisheye lens set the corresponding Camera Typein the Camera Calibration...
dialog available from the Tools menu. See information on other camera calibration settings in
Camera calibration section.

To calibrate camera lens
1. Select Calibrate Lens... command from the Lens submenu in the Tools menu.

2. Inthe Calibrate Lens dialog box, select the desired calibration parameters. Click OK button when
done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.

4. The calibration results will appear on the Adjusted tab of the Camera Calibration... dialog available
from the Tools menu. The adjusted values can be saved to file by using Save button on the Adjusted
tab. The saved lens calibration data can later be used in another chunk or project, providing that the
same cameraand lensis used.

4 Note

« After the calibration parametersfor the lens are saved, the actual image set captured by the same
camera and lens can be processed in a separate chunk. To protect the calibration data from being
refined during Align Photos process one should check Fix calibration box on the Initial tab for
the chunk with the datato be processed. In this caseinitial calibration valueswill not be changed
during Align Photos process.

After calibration is finished the following information will be presented:
Detected chessboard corners are displayed on each photo (the photo can be opened by double clicking on
its name in the Photos pane). It is preferable when the majority of the corners were detected correctly. For

each detected corner the reprojection error between the detected corner position and estimated position
according to the calculated calibration is also displayed. The errors are scaled x20 times for display.

Automated mission planning

M etashape introduces functionality for obtaining optimal sets of camera positions based on rough model
and creating mission plans using these optimal sets.

To generate adetailed mission plan perform asimple overhead flight and create arough polygona model.
Then, a set of the viewpoints which are enough to cover the surface of the object with sufficient overlap
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isautomatically generated. Finally, around-trip passing through all the generated viewpoints is computed
and can be exported in KML file format to be used for drone controlling application. Thistool is suitable
for DJI drones. We recommend using aircraft/drones with RTK GPSto significantly enhance flight safety
and precision.

Mission planning feature works as follows:

1. Makeanoverhead flight over the region of interest to capture abasic imagery set. To capture vertical
and concave surfaces better, use an oblique survey preset in the drone app instead of taking only
nadir photos.

2. Import photosto Metashape and align them, then build amodel of the object. Asonly rough geometry
isneeded for mission planning step, it is possible build mesh from tie point cloud or using low quality
settings to speedup computations. Check Bounding Box to include entire geometry of interest.

3.  Specify Home point for the drone at the expected take-off point. This can be done by placing a Point
shape on the rough model. For precise placement use an option to build texture for the model or to
set the point on an overhead photo that observes Home point.

4. Select Plan Mission submenu from the Tools menu. Specify parameters and run processing.

5. Export the flight plans from Metashape.

6. Import filesto drone app that supports KML flight plans with gimbal orientation.

4 Note

« Each flight must be watched by a pilot ready to take manual control over the drone in case of
GPS issues or unreconstructed obstacles such as wires or trees.

» Specify safe and restricted flight zones to enhance flight safety.

« |If drone battery gets low during the flight, replace it and restart the drone at the same altitude as
that of specified home point. The pilot will need to manually navigate drone to the position from
which the last visited waypoint isin line of sight to resume automatic flight safely.

» The pilot may need to disable built-in drone obstacle avoidance feature in order to perform range
flights. Be even more careful after disabling obstacle avoidance asdrone will longer stop or slow
down in case of any obstacle on the way. It's not recommended to disable obstacle avoidance
feature when flying using GNSS signal without RTK.
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Plan Mission parameters

Plan Mission
General

Focus on model selection

Focus on interesting zone: Interesting zone

Survey parameters

Camera model; Default camera (50 mm)
Resalution: Capture distance (m) 10
Image overlap (%) 70

Improve hard-to-reach regions coverage

Enable multi-photo waypoints (DI Pilot and Litchi C5V)

Obstade avoidance

safety distance {m): 5

Min altitude (m): i

safety zone: Allowed area
Festricted zone: Restricted area
Powerlines layer: Powerlines

Flight plan properties

Haome paint: home
Min waypaint spacing (m): 0.6
Min pitch (): 50
Max pitch (=) ]

Prefer horizontal movement

"Plan Mission" dialog

The following parameters control the photo alignment procedure and can be modified in the Plan Mission
dialog box:
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Focus on model selection
To consider only selected triangles of the model as target for reconstruction. In any case all
reconstructed triangles will be used for obstacle avoidance.

Focuson interesting zone
Polygons from the sel ected shape layer are used for the area selection. All mesh faces are selected that
fall into the polygonal shapes from the chosen layer when viewed from above. If any mesh faces are
used for Focus on model sel ection along with the zone, then both sourceswill be considered: manually
selected mesh faces and mesh faces corresponding to the selected shape layer.

Camera model
Choose a camera from the list, with a certain focal length in mm.

Resolution
Target image resolution. Can either be specified as GSD or distance in meters from the surface of
the rough model.

Image overlap (%)
Choose the desired overlap percentage.

I mprove hard-to-reach regions coverage
Optimize coverage of hard-to-reach regions of interest by generating additional viewpoints from
allowed space.

Enable multi-photo waypoints (DJI Pilot and Litchi CSV)
Convert close waypoints to rotate-and-shoot actions without changing drone position.

Safety distance (m)
Distance from the object which is restricted for putting waypoints within or planning path through.
Focus on selection parameter is ignored here - al parts of the object available in the rough model
are considered.

Min altitude (m)
Relative altitude to home point (in meters) which isrestricted for putting waypointswithin or planning
path through.

Safety zone
Shape layer with allowed regions.

Restricted zone
Shape layer with restricted regions.

Powerlines layer
Shape layer with the detected powerlines.

Home point
The desired take-off point can be defined as 3D point shape placed in scene. The Home point should
be located within Safety zone (in case it had been specified).

Min waypoints spacing (m)
Minimal distance between consecutive waypoints. The default value is set to 0.5 meters according
to DJI drones firmware.

Max waypoints per flight
Maximal possible number of waypointsper KML file. If flight plan has more waypointsthan specified
value, it will be split into chunks. The default value is set to 99 according to DJI drones firmware.
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Min pitch
Minimal pitch angle allowed by the drone gimbal.

Max pitch
Maximal pitch angle allowed by the drone gimbal .

Prefer horizontal movement
Traverse flat surfaces in horizontal zig-zag fashion instead of a vertical one. Vertica movement is
simpler to keep direct eye contact with the drone, while the horizontal movement may be more battery
efficient.

Export mission plan

To export the flight plans from Metashape select Export Camera Track command from the mission plan
context menu on the Workspace pane. Choose KML format and specify parametersfor export in the Export
Camera Track dialog window.

The following parameters available in the Export Camera Track dialog window:

Mission format
Specify mission formats from drop-down list. In Metashape available the following formats: DJI
Pilot, DJI WPML (WayPoint Markup Language) or Google Earth.

Min pitch
Specify the minimal pitch angle allowed by the drone gimbal.

Max pitch
Specify the maximal pitch angle allowed by the drone gimbal.

Max waypoints per flight
Specify the maximal possible number of waypoints per KML file. The default value is set to 99
according to DJI drones firmware.

Drone name
Specify the drone name from the drop-down list (M 300 RTK, M 30, M 30T, M3E, M3T).

Payload name
Specify payload name from the drop-down list. The corresponding payload name will be available
for each drone.

Payload position

Specify payload position from the drop-down list. The corresponding payload position will be
available for each drone.

4 Note

 Specify values for Drone name, Payload name, Payload positionis available only if DJ WPML
format is selected.

Excessive image elimination

Reduce overlap feature is made for analyzing excessive image sets to understand which images are useful
and which are redundant and may be disabled of removed.

1. Align photos using entire dataset and build rough mesh model from the tie point cloud.
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2. Select Reduce Overlap dialog available from the Tools menu.
3. Choose parameters in Reduce Overlap dialog box.
4. Click OK button.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.

6. After the operation is finished al the cameras which are not included into optimal subset will get
disabled.

Reduce overlap parameters

Reduce Overlap

General

Focus on model selection

Surface coverage: 3

Lok ] Cancel

"Reduce overlap" dialog
Reduce overlap dialog parameters:

Focus on selection
To consider only selected triangles of the polygonal model as target for reconstruction. Cameras that
do not have any of the selected polygons in the field of view would be automatically disabled.

Surface coverage
Number of cameras observing each point from different angles.
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Chapter 3. General workflow

Processing of images with Metashape includes the following main steps:

* loading data (images and |laser scans) into Metashape;

* inspecting loaded images and laser scans, removing unnecessary images and laser scans;
« aigning images and laser scans,

* building point cloud;

* building mesh (3D polygonal model);

 generating texture;

* building tiled model;

* building digital elevation model (DEM);

* building orthomosaic;

* exporting results.

If Metashape is used in the full function (not Demo) mode, intermediate results of the image processing

can be saved at any stage in the form of project files and can be used later. The concept of projects and
project filesis explained in the Saving intermediate results section.

Preferences settings

Metashape settings are available in the Metashape Preferences dialog window. To change the default
program settings for your projects select Preferences... command from the Tools menu (on macOS select
Preferences... command from the MetashapePro menu).
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Metashape Preferences

General GPU Metwork  Appearance  Mavigation  Advanced

User Interface

Language: Endlish

Default view: Point Cloud

Theme: Light

Shortouts: Customize...

Stereoscopic Display

Maode: Anaglyph

Parallzx: 1.0 H
Measurements

Latitudelongitude format: Dedmal degrees

Units: Coordinate system units

LIse derived units

Miscellaneous

Chedk for updates on program startup
Write log to file;

C:\UsersVog. txt

Cancel Apply
"Metashape Preferences” dialog (General tab)

The following settings are available in the Metashape Preferences dialog window:

General tab
The GUI language can be selected from the available list: English, Chinese, French, German, Italian,
Japanese, Russian, Spanish.

The GUI appearance can be set in the Theme, the available options are Dark, Light and Classic. The
theme set by default in Metashape Professional edition is Light.

The representation of the project can be selected from the Default view list. This parameter indicates
how the project isfirst represented when opened in Metashape. The available options are: Tie points,
Point cloud, Tiled model or Model.
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The preferable Units, that will be used in the project for all measurements can be set in the
Measurements section.

To enable stereo mode in Metashape, select the appropriate Stereoscopic Display mode. For more
information about stereo mode in M etashape see Stereoscopic mode.

Shortcuts for the menu and GUI commands can be adjusted via Customize... button.

It is possible to indicate the path to the Metashape log file, that can be shared with Agisoft support
team in case any problem arises during the data processing in M etashape.

GPU tab
M etashape exploits GPU processing power that speeds up the process significantly. The list of all
detected GPU devicesis presented on the GPU tab. To use GPU during M etashape processing enable
available GPU(s). The option to use CPU can also be selected on this tab. More information about
supported GPU(s) is available in the GPU recommendations section.

In order to optimize the processing performance it is recommended to disable Use CPU when
performing GPU accel erated processing option when at least one discrete GPU is enabled.

Network tab
This tab includes settings related to network and cloud processing. To enable Network processing
the corresponding option should be selected. For additional information about Network processing
in Metashape see Local network processing chapter. To enable cloud processing the corresponding
option should be selected. Configuring the cloud processing via Agisoft Cloud is described in the
Cloud processing chapter.

Appearance tab
Customization of theinterface elementsis available on the Appearance tab. For example, itispossible
to change the background color and parameters for the bounding box in the Model view, set color and
thicknessfor seamlinesin Ortho view, change the settings for displaying masksin Photo view and etc.

Navigation tab
On this tab the parameters of the 3D controller can be adjusted. See the Stereoscopic mode chapter
for additional information.

Advanced tab
Advanced tab allows to switch on such advanced features asfor exampl e rich Python console. To load
additional camera data from XMP (camera calibration, camera orientation angles, camera |location
accuracy, GPS/INS offset) enable the corresponding options on this tab.

Keep depth maps option hel ps save processing time in cases when the point cloud needs to be re-built
(for a part of the project) after itsinitial generation or when both mesh and point cloud are based on
the same quality depth maps.

Turning on Enable VBO support speeds up the navigation in the Model view for point clouds and
high polygonal meshes.

Fine-level task subdivision option allowsfor internal splitting of sometasksto sub-jobs, thus reducing
the memory consumption during processing of large datasets. The tasks that support fine-level
distribution are: Match Photos, Align Cameras, Build Depth Maps, Build Point Cloud, Build Tiled
Model, Build DEM, Build Orthomosaic and Classify Points.

M etashape allowsfor incremental image alignment, that can be useful in case of some datamissing in
theinitially aligned project. If this may be the case switch on Keep key points option before the initial
processing of the datais started (see Aligning photos and laser scans section).
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Loading source data

This section provides information on how to add source data (images and laser scans) into a Metashape
project and inspect them in order to ensure good quality of the processing results as well as on how to
work with image groups to conveniently operate with the images in a huge dataset. Further subsections
describe details on loading various specific types of data for processing in Metashape software.

Adding images

Before starting any operation it is necessary to point out which images will be used as a source for
photogrammetric processing. In fact, images themselves are not loaded into Metashape until they are
needed. So, when Add photos command is used, only the links to the image files are added to the project
contents to indicate the images that will be used for further processing.

Add Folder command is also available in Metashape for importing images into the project. It is used to
convenient load of imagery data from multiple sub-folders of a single folder or when the data should be
organized in a specific way to be correctly interpreted by Metashape (for example, when adding images
captured with rigid camerarigs).

Metashape uses full color range for image matching operation and does not downsample the color
information to 8 bhit. The point cloud points, orthomosaic and texture would also have the bit depth
corresponding to the original images, providing that they are exported in the formats that support non 8-
bit colors.

Toload a set of images

L Select Add Photos... command from the Workflow menu or click Add Photos toolbar button

on the Workspace pane.

2. In Add Photos dialog box browse to the folder containing the images and select files to be processed.
Then click Open button.

3. Selected images will appear on the Workspace pane.

4 Note

» Metashape accepts the foll owing image formats: JPEG (*.jpg, *.jpeg), JPEG 2000 (*.jp2, *.j2k),
JPEG XL (*.jxI), TIFF (* tif, * tiff), Digital Negative (*.dng), PNG (*.png), OpenEXR (*.exr),
BMP (*.bmp), TARGA (*.tga), Portable Bit Map (*.pgm, *.ppm), Norpix Sequence (*.seq),
AscTec Thermal Images (*.ara) and JPEG Multi-Picture Format (*.mpo). Image files in any
other format will not be displayed in the Add Photos dialog box. To work with such imagesit is
necessary to convert them to one of the supported formats.

If some unwanted images have been added to the project, they can be easily removed at any moment.

To remove unwanted images
1. Onthe Workspace pane select the cameras to be removed.

2. Right-click on the selected cameras and choose Remove Items command from the opened context

menu, or click X Remove Items toolbar button on the Workspace pane. Selected images will be
removed from the working set.
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Working with image groups

To manipulate the datain achunk easily, e.g. to apply disable/enable functionsto several cameras at once,
images in a chunk can be organized in image groups.

To move imagesto aimage group

1. Onthe Workspace pane (or Photos pane) select the images to be moved.

2. Right-click on the selected images and choose Move Images - New Image Group command from the
opened context menu.

3. A new group will be added to the active chunk structure and selected photos will be moved to that
group.

4. Alternatively selected images can be moved to a image group created earlier using Move Images -
Image Group - Group_name command from the context menu.

Automatic grouping images isimplemented in Metashape. It is possible to group images according to the
calibration data or by the capture date.

To arrange images to groups automatically

1. Right-click on the Images folder on the Workspace pane.

2. Enable checkbox for Calibration group or/and Capture date in the Group Images dialog window.
3. Click OK button.

4. New groups will be added to the active chunk.

4 Note

« Toautomatically delete groups that do not contain images, enable Remove empty image groups
optioninthe Group Imagesdialog window. Then the program will automatically check theimage
groups in the chunk and del ete them.

Inspecting loaded images

L oaded images are displayed on the Workspace pane along with flags reflecting their status.
The following flags can appear next to the cameralabdl:

NC (Not calibrated)
Notifiesthat the EXIF dataavailablefor theimageisnot sufficient to estimate the camerafocal length.
In this case Metashape assumes that the corresponding photo was taken using 50mm lens (35mm
film equivalent). If the actual focal length differs significantly from this value, manual calibration is
recommended. More details on manual camera calibration can be found in the Camera calibration
section.

NA (Not aligned)
Notifies that exterior camera orientation parameters have not been estimated for the image yet.

Exterior cameraorientation parameters are estimated at Align Photos stage or can beloaded vialmport
Cameras option.
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E=]
Notifies that Camera Sation type was assigned to the group.

Image quality

Poor input, e. g. vague photos, can influence the alignment results and the texture quality badly. To help to
exclude poorly focused images from processing M etashape suggests automatic image quality estimation
feature. Imageswith quality value of lessthan 0.5 units are recommended to be disabled and thus excluded

from aligment process nad texture generation procedure. To disable a photo use @ Disable button from
the Photos pane toolbar.

M etashape estimates image quality for each input image. The value of the parameter is calculated based
on the sharpness level of the most focused part of the picture.

To estimate image quality

1 Switch to the detailed view in the Photos pane using == Details command from the Change menu

on the Photos pane toolbar.
2. Select all photos to be analyzed on the Photos pane.

3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the
context menu.

4. Once the analysis procedure is over, a figure indicating estimated image quality value will be
displayed in the Quality column on the Photos pane.

Multispectral imagery

M etashape supports processing of multispectral imagesto create multispectral orthomosaics and calculate
various vegetation indices which are important source of information in agricultural and environmental
projects. Multispectral data can be loaded to a Metashape project in different formats: as a multichannel
TIFF file, as amultilayer TIFF file, as single channel TIFF file groups captured with Micasense, Parrot
and DJI cameras.

Multichannel TIFF files

M etashape supports processing of multispectral images saved asmultichannel (single page) TIFFfiles. The
main processing steps (Align photos, Build Point Cloud, Build DEM, Build Orthomosaic) for multispectral
images are performed based on the primary channel, which can be selected by the user. All spectral bands
are processed together to form amultispectral orthomosaic with the same channels asin the source images
during orthomosaic export.

Workflow for multispectral imagery processing does not differ from the common workflow for RGB
photos, except the additional primary channel selection step performed after adding images to the project.
It is recommended to select the channel which is sharp and as much detailed as possible as a primary
channel for processing.

To select primary channel

1 Add multispectral images to the project using —©Add Folder... command from the Wor kflow menu.
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2. Select folder containing the images in the Add Folder... dialog window. Click Select Folder button.
Add Photos dialog window will appear.

3. Sdlect Multi-camera system command in the Add Photos dialog.
4. Select Set Primary Channel... command from the chunk context menu in the Wor kspace pane.
5. Inthe Set Primary Channel dialog select the channel to be used as primary and click OK button.

Display of imagesin M etashapePhotos panewindow will be updated according to the primary channel
selection.

£ Note

e Seat Primary Channel... command is available for RGB images as well. Only one channel to be
used asthe basisfor photogrammetric processing, whereas, the Default option allowsfor all three
channelsto be used in the processing.

Multispectral orthomosaic export is supported in GeoTIFF format only. When exporting to other formats,
only primary channel will be saved.

Multilayer TIFF files

Metashape supports processing of multispectral datasets captured with multiple synchronized sensors
operating in the same or different spectral ranges. In this case multiple images are available for each
position and Metashape will estimate calibration parameters for each sensor separately as well as their
relative orientation within multi-sensor system.

All images for each camera position (number equals to the number of sensors) are contained in a separate
multilayer TIFF file. The number of multilayer imagesis equal to the number of camera positions.

Toload data from multilayer images

L Select —@Add Folder... command from the Workflow menu.

2. In the Add Folder dialog browse to the folder containing multilayer images and select files to be
processed. Then click Open button.

3. Inthe Add Photos dialog select Multi-camera system option.
4. Created chunk with multispectral cameras will appear on the Workspace pane.

After loading data from multilayer TIFF files, it is necessary to set unique Layer index value for each
Sensor.

To set unique Layer index for a sensor

1. Select Camera Calibration command from the Tools menu.
2. Select sensor in the left hand side menu.

3. Onthe Bandstab set unique value for Layer index parameter.

4. Repeat procedure for each sensor of multi-sensor system.
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MicaSense, Parrot and DJI multispectral cameras

M etashape supports processing of multispectral datasets captured with MicaSense (RedEdge, Altum),
Parrot Sequoia and DJI Phantom 4 Multispectral cameras. Although these cameras save data from each
sensor as a single-channel TIFF file, Metashape automatically organizes imagery data to multi-camera
system layout based on available meta data. Image file corresponding to all the bands should be selected
at once when loading data to the project.

To load data from MicaSense (RedEdge, Altum), Parrot Sequoia, DJI Phantom 4
Multispectral cameras

L Select “—@Add Folder... command from the Wor kflow menu.

2. Inthe Add Photos dialog box browse to the folder containing multispectral images and select files
to be processed. Then click Open button.

3. Inthe Add Photos dialog select Multi-camera system option.

4. Created chunk with multispectral cameras will appear on the Workspace pane. The labels of the
multispectral cameras would be taken from the first band image filenames.

For multispectral cameras by MicaSense, Parrot and DJl the default sensor order is defined by the
CentralWavelength value from the image meta data (sensor with the lowest value is added first). By
default master sensor will be sel ected asasensor with the lowest CentralWavelength value. Master sensor
and the order can be re-assigned in Camera Calibration dialog available from Tools menu. The default
order of the output orthomosaic channels corresponds to the order of the sensors.

Reflectance calibration for multispectral images acquired using MicaSense (RedEdge, Altum, etc.), Parrot
Sequoia, DJ Phantom 4 Multispectral cameras can be performed based on the radiometric panel images
and/or sun sensor metainformation. Read more in Vegetation indices cal culation section.

Vignetting correction information is saved in meta data in these types of cameras. This information will

be loaded automatically into Metashape and can be used to improve orthomosaic generation results. Read
more in Vegetation indices cal culation section.

Thermal imagery

Thermal images contain information about object temperature. M etashape supports processing of thermal
data from AscTec (ARA format), WIRIS (TIFF format) cameras and cameras saving data in R-JPEG
(FLIR data) format.

Toload thermal images

1 Add thermal images to the project using Add Photos... command from the Workflow menu.

2. Choose images in the Add Photos dialog.
3. Then click Open button.

For AscTec and WIRIS camera data it will be suggested to configure Palette settings to visualize
temperature values with pseudocolors.
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Rigid

To configure palette for temperature values visualization
1. Select one of the available presets or customize Palette in Raster Calculator dialog.

2. Click OK button to apply the palette settings and close the dial og.

[{ Note

« For R-JPEG datait isrequired to load theimagesto M etashape using multi-camera system layout
option. See Rigid camerarig data section.

camerarig data

Metashape supports processing of datasets captured with multiple synchronized cameras rigidly fixed
relatively to each other (camerarigs). In this case multiple images are available for each position of such
system and Metashape will estimate calibration parameters for each camera separately as well as their
relative orientation within camerarig.

Before adding images from rigid camera rigs it is necessary to organize files on the disk appropriately.
Images corresponding to each camera in the rig should be placed to a separate subfolder of the parent
directory. The number of subfoldersis equal to the number of camerasin the rig, whereas the order of the
images in each subfolder correspond to the shooting order (it means that the number of images in each
subfolder is expected to be the same).

Toload imagesfrom rigid camerarig

L Select —@Add Folder... command from the Workflow menu.

2. Inthe Add Folder dialog box browseto the parent folder containing subfolders with images, acquired
by different camerasin therig. Then click Select Folder button.

3. In the Add Photos dialog select Multi-camera system layout and choose Create sensor from each
subfolder option.

4. Selected images will be added as multi-camera system layout (see left side part of the Camera
Calibration diaog).

The labels of the cameras in the Workspace pane would be taken from the image filenames of the
first subfolder (sorted in aphabetic order) of selected parent folder. The first subfolder camera will be
automatically set as master camerain Camera Calibration dialog, the rest of the cameras will be tackled
as slave cameras to the master. To change master camera, you can use the corresponding command from
the context menu of the camera group displayed in the left side part of the Camera Calibration dialog.

The default assumption is that synchronized cameras have the same position in space. In case distance
between the cameras cannot be neglected, it is possible for Metashape to calculate relative camera of fset.
If offset parameters are known they can be input manually.

To set relative camer a offset for synchronized camer as manually
1. Select Camera Calibration command from the Tools menu.
2. Intheleft-hand part of the Camera Calibration dialog box select slave camerato set up offset

3.  Switch to Save offset tab.

28



General workflow

4. Check on Enable reference option for coordinates and/or angles. Adjust location/rotation options
should be enabled.

5. Input the relative camera offset values to the Reference column manually.

6. Adjust the valuesin the Accuracy column, according to the offsets measurement accuracy.
7. Repeat procedure for each slave camera.

M etashape uses the following coordinate system for slave camera offsets:

» X axis pointsto the right side of the image,

Y axis points to the bottom of the image,

» Z axis points along the viewing direction of the master camera.

Slave Camera Offset is calculated by the following formula:

Prmaster = Rx(omega) * Ry(phi) * Rakappg) * Petave + T

Where:

Pyave — point coordinates in slave camera coordinate system,

Pmaster — point coordinates in master camera coordinate system,

Rx(omega): Ry(phi» Rz(kappa) — rotation matrices around corresponding axes in clockwise direction,

T — dave camera of fset.

To allow for automatic calculation of relative camera offsetsin camerarig
1. Select Camera Calibration command from the Tools menu.

2. Inthe l€eft side part of the Camera Calibration dialog box select slave camera to calculate relative
offset for. Slave cameras are displayed as dropdown list for the corresponding master camera.

3. Switch to Save offset tab.
4. Check Adjust location option.

5. Theoffset for the selected slave camerawill be estimated in relation to master camera during camera
alignment or optimization procedures.

6. Repesat procedure for each slave camera
In case of rigid camerarigsvariance of rel ative offset can beinspected in the GPSINS Offset tab of Camera

Calibration dialog, see Variance column. Valuesin the Variance column are equal to squared standard
deviation of relative offset. Read more in Covariance matrix section.

Camera station data

If al the images or a subset of images were captured from one camera position - camera station, for
M etashape to process them correctly it is obligatory to move the cameras, corresponding to those images,
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to acamera group and mark the group as Sation. It isimportant that for all the imagesin a Station group
distances between camera centers were negligibly small compared to the minimal distance to the object
from the cameras in the group.

To mark group as camera station, right click on the camera group name and select Set Group Type
command from the context menu.

Photogrammetric processing will require at | east two camerastationswith overlapping imagesto be present
in a chunk. A panoramic picture, however, can be exported for the data captured from only one camera
station. Refer to Exporting results section for guidance on panorama export.

Laser scans data

M etashape supports structured terrestrial laser scans and unstructured aerial laser scans. All point attributes
including structured information are now preserved while importing.

[{ Note

« If the project has both laser scans dataand digital imagery for the same scenes, all the data should
be loaded to the same chunk and to be processed together.

Toimport laser scans
1.  Sedlect Import Point Cloud command from the Import submenu of the File menu.

2. Inthe Import Point Cloud dialog box browse to the folder containing the laser scans and select files.
Then click Open button.

3. Set the parameters for import and enable checkbox Use as laser scans in the Import Point Cloud
dialog window.

4. Click OK button to add the data into project.

[{ Note

« If Use as laser scans option was not enabled in the Import Point Cloud dialog window, then
after importing select all the point clouds related to the laser scans in the chunk's content on the
Workspace pane and choose Use as Laser Scans from the Point Cloud context menu.

« Multiple point clouds can be loaded at the sametime. Select al point clouds from the folder with
laser scans data for importing. In this case the parameters from the Import Point Cloud dialog
window will be applied to all the selected point cloud files.

If apoint cloud is assigned to be used as laser scans, then it can be displayed in Model view by using =
Show Laser Scanstoolbar button. Depending on the information recorded in the laser scan data, the cloud
can be displayed as various modes: Solid View, Colors View, Classes View, Intensity View, Elevation
View, Return View, Scan Angle View, Source ID View, Confidence View. See information about modes
in Toolbar buttons section.

In Metashape import of the shooting trajectory for a laser scan is available. Trajectory can be imported
from the following formats: TXT files (*.txt), SBET (*.out, *.sbet), SOL (*.sol), TerraScan (*.trj). In
order to be used properly, it should be imported to the project prior to importing laser scan data. Select
Import Trajectory command from the Import submenu of the File menu. Select file with trgjectory and
specify Columns (X, Y, Z, GPS Time), Delimiter (Tab, Comma, Semicolon, Space or other) and Skip
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rows parameter in the Import Trajectory dialog window. The trajectory will be displayed as various modes
(Solid View, Elevation View, Time View) in the Model view and new layer with the trajectory will also
appear in the Workspace pane. For convenient work with the aerial laser scan (for example, displaying
only part of the point cloud, or the exclusion of a turning area), masking tools for the trajectory (Mask
Selection, Unmask Selection, Crop Mask by Selection, Reset Mask) are implemented in Metashape. The
tools are available in the Tools > Trajectory menu. To apply masking, first select the desired area in the
Model view using the selection tools on the toolbar. Then select the desired command for masking from
the Tools menu.

For terrestrial laser scans the point cloud and spherical panoramas with depth maps information (captured
by the laser scanner) are also accessible on the Workspace pane. If terrestrial laser scans were pre-aligned
in athird-party application before importing to Metashape group such terrestrial laser scans to the single
folder and set the group typeto Fixed optionin order to preservethe existing registration information during
the bundle adjustment step performed in Metashape. To do that select al laser scans on the Workspace
pane, right-click on selection and choose Move Laser Scans > Create new laser scan group from the
context menu. Then in the newly created Group context menu select Set Group Type > Fixed option.

4 Note

* More than one instance of laser scan can be stored in one chunk. To save current laser scan
instance and edit its copy, right-click on Laser scan on the Workspace pane and choose Duplicate
option. It is important to disable the original laser scans after copying (choose Disable Laser
Scans option from the LIiDAR context menu). The disabled laser scans will not be displayed on
the Model view and will not be edited.

Import Point Cloud

Coordinate System
WG5S 84 (EPSG:4328)

Shift: E: 0 M: 0 A0

Coordinate Precision

Default

Custom (m): 0.01
Parameters
Use as laser scans
Scanner position: LInknowen

Mormal estimation neighbors: 28

Lok ] cancel

"Import Point Cloud" dialog
The following parameters can be changed in the Import Point Cloud dialog box:

Coordinate System
Set coordinate system from the dropdown list or upload parameters of a customized geographical
coordinate system corresponding to the point clouds being imported.
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Coordinate Precision
To specify a custom value for coordinate precision enable Custom (m) option and specify the value.
Or use Default option, then Metashape calculate coordinate precision automatically. The value will
correspond to the average precision value for al points from the point cloud.

Parameters
To import the point cloud as alaser scan, enable the Use as laser scans parameter.

If the point normals are not stored in the files being imported, Metashape would calculate the point
normals automatically. To determine the normal of apoint in a point cloud, M etashape approximates
the local surface of the model with a plane. If the point cloud was obtained in an unstructured form,
then Unknown option should be selected in Scanner Position field. If the point cloud was recorded
in a structured form, then the Origin parameter should be selected. If point cloud saves a trgjectory
file thenuse- Trajectory parameter. The Trajectory file option will be available only if thetrgjectory
has been imported to the project prior to the point cloud import.

The direction of the plane is determined by the nearby neighbors of a given point. The number
of nearby points to consider is defined by Normal estimation neighbors parameter value. If the
imported cloud isvery noisy, 28 (default value) neighbors may not be enough to determinethenormals
confidently. For such point clouds, it is worth increasing the Normal estimation neighbors value up
to 100. Increasing the number of neighborswill slow down the calculation, smooth out the normal's at
the corners, but will help to avoid noise. In some cases, increasing the number of neighbors can also
help to avoid large plots with the inverted normals.

Point cloud can be imported in the following formats: Wavefront OBJ (*.obj), Stanford PLY (*.ply),

ASPRS LAS (*.las), LAZ (*.laz), ASTM E57 (*.€57), ASCII PTS (*.pts, *.pts.gz), PTX (*.ptx), Point
Cloud Data (*.pcd).

Images with depth data

M etashape supports processing data from smart cameras with a depth sensor. Supported images can be
obtained using Apple devices with TrueDepth camera, that is the front camera of iPhone starting from
the 10th version (except SE) and the front camera of iPad Pro (released starting November 2018). If
images with the depth data were obtained from other cameras, Metashape will load them without depth
information.

Toimport depth images
1.  Select Import Depth Images... command from the Import submenu of the File menu.

2. Select images with depth datain the Open dialog.

3. Specify thefolder where the pre-processed images will be saved to (can be re-used from that location
later without aneed of completing the pre-processing procedure again).

4. Click OK button to add the data to the active chunk.

Images with depth data can be imported from the Dynamic Depth images format (*.jpg, *.jpeg)
Satellite imagery

M etashape can process panchromatic and multispectral satelliteimages, provided that sufficiently accurate

Rational Polynomial Coefficients (RPC) dataisavailablefor each image. Examples of supported satellites:
Beijing-3A, lIkonos, Planet Labs, Pleiades, SuperView, Jilin, WorldView.
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RPC coefficients are loaded automatically if they are present in RPC coefficient image tag. Alternatively,
they can be loaded from supplementary rpc.txt or .rpb files.

Toload satellite images
1. If RPC coefficients are provided in supplementary rpc.txt or .rpb files make sure that Load satellite

RPC data from auxiliary TXT files option is enabled in the Advanced tab of the Preferences dialog
before adding images to the project.

Add satellite images to the project using @Add Photos command from the Workflow menu.

3. Make sure that RPC coefficients are loaded correctly: check that Camera type is set to RPC for all
calibration groups which contain satellite imagesin Camera Calibration dialog.

Satelliteimages often have very large resol ution and navigation in the Photo view may be slow. Metashape
can take advantage of multi resolution TIFF files with overviews, which greatly improve user experience.

If the available satellite images do not contain overviews, it is highly recommended to create them first.
This can be done using Convert Images command from the Export submenu from the File menu.

To generate optimized TIFF imagesfor faster navigation in Photo view mode
1. Addoriginal imagesto an empty project as described in the previous procedure.
2. Select Convert Images... command from the File > Export menu.

3. Inthe Convert Images dialog make sure that Write tiled TIFF and Generate TIFF overviews options
are enabled. Need to enable Write BigTIFF file option if images are larger than 4GB.

4. Make sure that Filename template is set to some reasonable value. The default { filename} .{ fileext}
value should work in most cases.

5. Inthe Apply to section select All cameras and click OK button.

6. Inthe Select Folder dialog select a folder to save optimized images. It is recommended to select a
new empty folder for the images to make sure that original files are not overwritten.

7. Click Select Folder button to start conversion.

8.  When conversion is complete generated images can be loaded into a new project for processing.

4 Note

< Convert Images command automatically embeds RPC coefficientsin the generated files, soitis
not necessary to copy auxiliary TXT files to the new images folder.

Working with tiled satellite imagery

High resolution satellite images are often provided in atiled form, where each image is split in to multiple
TIFF files. Before loading into Metashape such data needs to be converted to combined TIFF files first.
This can be done using gdal_trandlate utility from GDAL package.

Below are example commands that can be used to perform conversion for different formats. These
commandswill generate multi-resolution TI1FF files with overviews and with embedded RPC coefficients.
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Converting DIMAP datasets

DIMAP images contain an XML index file for each image, which can be used for conversion using the
following commands:

gdal_trandate DIM_<datasethame>. XML combined.tif -co TILED=YES

gdaladdo -r average combined.tif 24 8 16 32

Converting DigitalGlobe datasets

Tiled DigitalGlobe images contain a TIL tile index file for each image, which needs to be used for
conversion:

gdal_trandate <datasetname>.T1L combined.tif -co TILED=YES

gdaladdo -r average combined.tif 24 8 16 32

Scanned images with fiducial marks

Metashape supports processing of analog aerial images (with fiducial marks) scanned to digital files.
Fiducial marks are needed in order to set the interior orientation parameters for scanned imagery. Read
more about camera calibration scanned imagery processing in Camera calibration for the scanned images
with fiducial marks section.

Toload scanned images

1 Add scanned images to the project using Add Photos... command from the Workflow menu.

2. In Add Photos dialog box browse to the folder containing the images and select files to be added to
the project.

3. Click OK button to close the dialog. Loaded images will appear in the Workspace pane.

Video data

M etashape allowsfor video data processing aswell, which can be beneficial for quick inspection scenarios,
for example. The video is to be divided into frames which will be further used as source images for 3D
reconstruction.

Toimport avideofile

1. Select Import Video... command from the File menu.

2. Inthe Import Video dialog inspect the video and set the output folder for the frames .
3. Set thefilename pattern for the frames and indicate the frame extraction rate.

4. Toimport part of the video, specify the parameters. Start fromand End at.

5. Click OK hutton for the frames to be automatically extracted and saved to the designated folder. The
images extracted from the video will be automatically added to the active chunk.
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4 Note

« In Metashape you can choose the automatic frame step (Small, Medium, Large) or set the
parameter manually via Custom option. Once the parameter valueis set, the program calcul ates
the shift for the framesto be extracted. For Small value, the shift of about 3% of the image width
will be taken into account. For Medium, it corresponds to 7% and for Large - 14% of the image
width.

After the frames have been extracted you can follow standard processing workflow for the images.

Aligning photos and laser scans

The camera position at the time of image capture is defined by the interior and exterior orientation
parameters.

Interior orientation parameters include camera focal length, coordinates of the image principal point and
lens distortion coefficients. Before starting processing in Metashape the following configuration steps
should be performed:

» Separate calibration groups should be created for each physical camera used in the project. It is aso
recommended to create a separate calibration group for each flight or survey. For details see Camera
groups subsection of Loading source data.

* For each calibration group initial approximation of interior orientation parameters should be specified.
In most casesthisisdone automatically based on EX1F metadata. When EXIF metadataisnot available,
initial interior orientation parameters needs to be configured according to the camera certificate.

» When using images captured with analog camera, it isnecessary to set the cameracalibration parameters
manually and also indicate fiducial marks on each image (for additional information see Camera
calibration for the scanned images with fiducial marks section).

Exterior orientation parametersdefinethe position and orientation of the camera. They are estimated during
image alignment and consist of 3 tranglation components and 3 Euler rotation angles.

Camera orientation angles conventions

M etashape allows to define camera orientation with either [yaw, pitch, roll], [omega, phi, kappa], [phi,
omega, kappa] or [apha, nu, kappa] angles. The more common scenario is to load [yaw, pitch, roll]
measurements directly from the airborne IMU system and, hence, default setting in Metashape isto tackle
the input values as [yaw, pitch, roll] data.

To provide compatibility with different processing workflows Metashape also supports [omega, phi,
kappa] datainput. Angles are used to transform coordinate system and align it with the image coordinate
system.

* Omegaistherotation around the X axis.
* Phi istherotation around the Y axis.

» Kappaisthe rotation around the Z axis.
Y aw, Pitch, Roll definition:

* Yaw istherotation around the Z axis.
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* Pitchistherotation around the X axis.

* Rall istherotation around the Y axis.

Alpha, Nu, Kappa definition:

» Alphaisthe rotation around the Z axis.

* Nuistherotation around the X axis.

» Kappaistherotation around the Y axis.

For images system of angular elements of exterior orientation ([yaw,pitch,roll], [omega, phi, kappa] or
[apha, nu, kappa]) can be switched in the Reference Settings dialog. Do not forget to click OK button in
the Reference Settings dialog to apply the changes.

In many cases survey systems are equipped with GPS/GNSS systems for measuring exterior orientation
parameters during capture. Thisdatacan be used as additional measurements during bundle adjustment. To
import afilewith exterior images orientation parameters see Assigning reference coordinatesin Coordinate
system section.

Exterior and interior image orientation parametersare cal cul ated using aerotriangul ation with bundle block
adjustment based on collinearity equations. Aerotriangulation allows to jointly adjust photogrammetric
measurements of tie points together with onboard measurements. As aresult, more accurate and reliable
exterior orientation parameters of images are obtained.

The result of this processing step consists of estimated exterior (translation and rotation) and interior

camera orientation parameters together with a tie point cloud containing triangulated positions of key
points matched across the images.

Toalign a set of photos
1. Select Align Photos... command from the Workflow menu.
2. Inthe Align Photos dialog box select the desired alignment parameters. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

After alignment is completed, computed camera positions and atie point cloud will be displayed in Model
view. You can inspect alignment results and remove incorrectly positioned cameras, if any. To see the
matches between any two images use View Matches... command from the image context menu in the
Photos pane.

Incorrectly positioned cameras can be realigned.

Torealign a subset of images

1. Reset alignment for incorrectly positioned cameras using Reset Camera Alignment command from
the photo context menu.

2. Set markers (at least 4 per images) on these imagess and indicate their projections on at least two
images from the already aligned subset. M etashape will consider these pointsto be true matches. (For
information on markers placement refer to the Coordinate system section).
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3. Select imagesto be realigned and use Align Selected Cameras command from the context menu.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

When the alignment step is compl eted, the tie point cloud and estimated camera positions can be exported
for processing with another software if needed.

To improve alignment results it may be reasonable to exclude poorly focused images from processing
(read more in Image quality section).

Alignment parameters

Align Photos

General

Accuracy: High
Generic preselection

Reference preselection  Source

Reset current alignme
Advanced
Key point limit; 40,000
Tie paint limit; 10,000
Apply masks to: one

Excude stationary tie points
Guided image matching

Adaptive camera model fitting

ok |
"Align Photos" dialog

The following parameters control the image matching and alignment procedure and can be changed in the
Align Photos dialog box:

Accuracy
Higher accuracy settings help to obtain more accurate camera position estimates. Lower accuracy
settings can be used to get the rough estimation of camera positionsin a shorter period of time.

While at High accuracy setting the software workswith the photos of the original size, Medium setting
causes image downscaling by factor of 4 (2 times by each side), at Low accuracy source files are
downscaled by factor of 16, and Lowest value means further downscaling by 4 times more. Highest
accuracy setting upscales the image by factor of 4. Since tie point positions are estimated on the
basis of feature spots found on the source images, it may be meaningful to upscale a source photo
to accurately localize atie point. However, Highest accuracy setting is recommended only for very
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sharp image data and mostly for research purposes due to the corresponding processing being quite
time consuming.

Generic preselection
The alignment process of large photo sets can take a long time. A significant portion of this time
period is spent on matching of detected features across the photos. Image pair presel ection option may
speed up this process due to selection of a subset of image pairs to be matched.

In the Generic preselection mode the overlapping pairs of photos are selected by matching photos
using lower accuracy setting first.

4 Note

Using only Refer ence presel ection mode without Generic preselection fits best the case when
only afew tie points are detected during the image matching stage, it may happen, for example,
for aerial surveys of forested areas or crop fields.

Reference preselection

In the Sour ce presel ection mode the overlapping pairs of photos are selected based on the measured
camera locations (if present). For oblique imagery it is necessary to set Capture distance value
(average ground height in the same coordinate system which is set for camera coordinates data) in the
Settings dialog of the Reference pane to make the preselection procedure work efficiently. Capture
distance information must be accompanied with yaw, pitch, roll/omega, phi, kappa datafor cameras.
Rotation parameters should be input in the Reference pane. Then the presel ection based on the new 3D
points calculated as original 3D point and vector in the direction of the camera view with the length
equal to theinput Capture Distance value.

The Estimated preselection mode takes into account the calculated exterior orientation parameters
for the aligned cameras. That is, if the alignment operation has been already completed for the project,
the estimated cameralocations will be considered when the Align Photos procedure isrun again with
the Estimated presel ection selected.

When using Sequential preselection mode the correspondence between the images is determined
according to the sequence of photos (the sequence number of the image) it is worth noting that with
this adjustment, the first with the last images in the sequence will aso be compared.

Reset current alignment
If thisoption is checked, all thetie, and key, and matching points will be discarded and the alignment
procedure will be started from the very beginning.

Additionally the following advanced parameters can be adjusted.

Key point limit
The number indicates upper limit of feature points on every image to be taken into account during
current processing stage. Using zero value allows Metashape to find as many key points as possible,
but it may result in a big number of lessreliable points.

Tiepoint limit
The number indicates upper limit of matching points for every image. Using zero value doesn't apply
any tie point filtering.

Apply mask to
If apply mask to key points option is selected, areas previously masked on the photos are excluded
from feature detection procedure. Apply mask to tie points option means that certain tie points are
excluded from alignment procedure. Effectively thisimpliesthat if some areais masked at least on a
single photo, relevant key points on the rest of the photos picturing the same areawill be also ignored
during alignment procedure (atie point is a set of key points which have been matched as projections
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of the same 3D point on different images). This can be useful to be able to suppress background in
turntable shooting scenario with only one mask. For additional information on the usage of masks
please refer to the Using masks section.

Exclude stationary tie points
Excludes tie points that remain stationary across multiple different images. This option enables
alignment without masks for datasets with a static background, e.g. in a case of a turntable with a
fixed camera scenario. Also enabling this option will help to eliminate false tie points related to the
camera sensor or lens artefacts.

Guided image matching

This option allows to effectively boost the number of keypoints per image as if the value of Key
point limit was straightforwardly increased, but without significant growth of processing time. Using
this parameter can improve results for images with vegetation (wooded terrain, grass, cornfields
and so on), spherical cameras and high resolution images (captured by professional grade cameras,
satellites or acquired by high-resolution scanning of the archival aerial images). To enable Guided
image matching, check corresponding option in Align Photos dialog and adjust Key point limit per
Mpx if needed. The number of detected points per image is calculated as (Keypoint limit per Mpx) *
(image size in Mpx). Small fraction will be extensively matched and used as guidance for matching
of remaining points.

Adaptive camera model fitting

This option enables automatic selection of camera parametersto beincluded into adjustment based on
their reliability estimates. For data sets with strong camera geometry, like images of a building taken
from all the sides around, including different levels, it helps to adjust more parameters during initial
camera alignment. For data sets with weak camera geometry , like atypical aeria data set, it helps
to prevent divergence of some parameters. For example, estimation of radial distortion parameters
for data sets with only small central parts covered by the object is very unreliable. When the option
is unchecked, Metashape will refine only the fixed set of parameters. focal length, principal point
position, three radial distortion coefficients (K1, K2, K3) and two tangential distortion coefficients
(P1, P2).

4 Note

< Tie point limit parameter allows to optimize performance for the task and does not generally
effect the quality of the further model. Recommended value is 10 000. Too high or too low tie
point limit value may cause some parts of the point cloud model to be missed. The reason is that
M etashape generates depth maps only for pairs of photos for which number of matching pointsis
abovecertain limit. Thislimit equalsto 100 matching points, unless moved up by thefigure"10%
of the maximum number of matching points between the photo in question and other photos,
only matching points corresponding to the area within the bounding box being considered.”

« The number of tie points can be reduced after the alignment process with Tie Points - Thin Point
Cloud command available from Tools menu. As aresultstie point cloud will be thinned, yet the
alignment will be kept unchanged.

Components

Someimage subsets may be not aligned asthe result of the Align Photos operation, if the sufficient amount
of tie points was not detected between such subsets. Such subsets which are not aligned with the main
subset will be grouped into individually aligned parts - Components.

The components into which the camera alignment have been split after the Align Photos operation will be
displayed in the chunk's contents of the Workspace pane inside the Components fol der.
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To align componentswith each other

1. Manually create markers which would connect the components with each other. It isrequired to use
at least 3 markers between each pair of components that do not lay on the same line. See information
about placing markersin Coordinate system section.

2. Inorder to switch between the components doubl e-click with the left mouse button on the component's
label in the Wor kspace pane.

3. After dl the components have been aligned with the help of markers, select them in the Workspace
pane and then use the Merge Components command from the context menu.

Incremental image alignment

In case some extra images should be subaligned to the set of already aligned images, you can benefit
from incremental image alignment option. To make it possible, two rules must be followed: 1) the scene
environment should not have changed significantly (lighting conditions, etc); 2) do not forget to switch on
Keep key points option in the Preferences dialog, Advanced tab BEFORE the whole processing is started.

To subalign some extra images added to the chunk with already aligned set of
images

1. Add extraphotos to the active chunk using Add photos command from the Workflow menu.
2. Open Align photos dialog from the Workflow menu.

3. Set alignment parameters for the newly added photos. IMPORTANT! Uncheck Reset alignment
option.

4. Click OK. Metashapewill consider existing key pointsand try to match them with key points detected
on the newly added images.

Point cloud generation based on imported camera data

M etashape supportsimport of exterior and interior camera orientation parameters. Thus, if precise camera
data is available for the project, it is possible to load them into Metashape along with the photos, to be
used asinitia information for 3D reconstruction job.

Toimport exterior and interior camera parameters

1. Select Import Cameras command from the File menu.

2. Select the format of the file to be imported.

3. Browsetothefile and click Open button.

4. The datawill be loaded into the software. Camera calibration data can be inspected in the Camera
Calibration dialog, Adjusted tab, available from Tools menu. If theinput file contains some reference
data (cameraposition datain some coordinate system), the datawill be shown on the Reference pane,

View Estimated tab.

Camera data can be loaded in one of the following formats: Agisoft (*.xml), PATB Camera Orientation
(*.ori), BINGO (*.dat), Inpho Project File (*.prj), Blocks Exchange (*.xml), Bundler (*.out), Realviz
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RZML (*.rzml), N-View Match (*.nvm), Alembic (*.abc), Autodesk FBX (*.fbx), VisionMap Detailed
Report (*.txt).

Once the data is loaded, Metashape will offer to build point cloud. This step involves feature points
detection and matching procedures. As aresult, a Tie Points cloud - 3D representation of the tie-points
data, will be generated. Build Point Cloud command isavailable from Tools - Tie Points menu. Parameters
controlling Build Point Cloud procedure are the same as the ones used at Align Photos step (see above).

Aligning laser scans

Aligning terrestrial laser scans

Aligning terrestrial laser scans can be performed in Metashape. There are two ways to start alignment for
terrestrial laser scans; use the Align Photos command from the Workflow menu or use Align Laser Scans
command from the laser scan context menu.

In the Align Photos dialog window specify the preferable parameters. The basic parameters can be used,
just asin the case of regular image alignment, the major difference is that it isimportant to enable Reset
current alignment option. Reset Alignment option also available from the laser scans context menu on the
Workspace pane.

If the terrestrial laser scans were aligned in a third-party application before importing laser scans into
M etashape, then merge laser scans in one group and set the group type to Fixed. Select all laser scans on
the Workspace pane and choose Move Laser Scans > New Laser Scan Group. Then in the Group context
menu select Set Group Type > Fixed.

Aligning terrestrial laser scans and images

M etashape supportsthe possibility to align terrestrial laser scans and imagestogether. To alignimagesand
laser scans use Align Photos command from the Workflow menu and enable the Reset current alignment
parameter in the Align Photos dialog window. The exterior orientation of the laser scans (pre-registration
information) will be reset, while the relative orientation of the laser scans within the group will be saved.
If reset for external alignment is not performed - the laser scans group will not be used by the algorithm
during alignment with the images. The result of the combined alignment of the laser scans and images
will be displayed in the Model view.

Markers can also be used for alignment.

Toalign laser scans and images use markers:

1. Align photos (use Workflow > Align Photos command).

2. Import point cloud into project as laser scans.

3. Uncheck Lock Transform option in the laser scan context menu.

4. UsePlace Marker command on the Model view to specify the marker projections on the point cloud.
In the Photo view marker projections can be assigned on the individual images.

5. Click Update button on the Reference pane.

4 Note

* By default, markers are shown as white flags in the Model view. If the position of a marker for
the active laser scan is specified, the flag becomes green. Also marker will be shows as agreen
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flag in the Model view, if no laser scans is set as active, but at least one projection has been
assigned for the marker to any laser scan. In all the other cases (i.e. if the positions of the markers
are only specified on the images) the flag remains white.

Building point cloud

M etashape allows to create a point cloud based on the calculated exterior and interior image orientation
parameters.

Point cloud generation is based on depth maps calculated using dense stereo matching. Depth maps
are calculated for the overlapping image pairs considering their relative exterior and interior orientation
parameters estimated with bundle adjustment. Multiple pairwise depth maps generated for each camera
are merged together into combined depth map, using excessive information in the overlapping regions to
filter wrong depth measurements.

Combined depth maps generated for each camera are transformed into the partial point clouds, which are
then merged into afinal point cloud with additional noisefiltering step applied in the overlapping regions.
The normalsin the partial point clouds are calculated using plane fitting to the pixel neighborhood in the
combined depth maps, and the colors are sampled from the images.

For every point in the final point cloud the number of contributing combined depth maps s recorded and
stored as a confidence value. This confidence value can be used later to perform additional filtering of low
confidence points using the Filter by Confidence... command from the Tools > Point Cloud menu.

M etashape tends to produce extra point clouds, which are of aimost the same density, if not denser, as
LIDAR point clouds. A point cloud can be edited and classified within Metashape environment and used
as a basis for such processing stages as Build Mesh, Build DEM, Build Tiled Model. Alternatively, the
point cloud can be exported to an external tool for further analysis.

To build a point cloud

1 Check the reconstruction volume bounding box. To adjust the bounding box use the Resize
Region, Cg" Move Region and 2?’ Rotate Region toolbar buttons. To resize the bounding box, drag
corners of the box to the desired positions; to move - hold the box with the left mouse button and
drag it to the new location.

2. Select the Build Point Cloud... command from the Wor kflow menu.

3. Inthe Build Point Cloud dialog box select the desired reconstruction parameters. Click OK button
when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

[ Note

« More than one instance of Point cloud can be stored in one chunk. In case you want to save
current Point cloud instance and build new one in current chunk, right-click on Point cloud and
uncheck Set as default option. To save current Point cloud instance and edit its copy, right-click
on Point cloud and choose Duplicate option.
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Build Point Cloud parameters

Build Point Cloud

General
Source data: Depth maps
Quality: High
Reuse depth maps
Advanced
Depth filtering: Mild

Calculate point colors

Calculate point confidence

Lo ] concel |

"Build Point Cloud" dialog

Sour ce data
Specifies the source (Depth Maps, Mesh or Tiled model) for the point cloud generation procedure.

If Depth Maps was sel ected as the source data then the following parameters can be adjusted:

Quality
Specifies the desired quality of the depth maps generation. Higher quality settings can be used to
obtain more detailed and accurate geometry, but they requirelonger timefor processing.Interpretation
of the quality parameters hereissimilar to that of accuracy settings given in Photo Alignment section.
The only differenceisthat in this case UltraHigh quality setting means processing of original photos,
while each following step implies preliminary image size downscaling by factor of 4 (2 times by each
side).

Reuse depth maps
Depth maps available in the chunk can be reused for the point cloud generation operation. Select
respective Quality and Depth filtering parameters values (see info next to Depth maps label on the
Workspace pane) in Build Point Cloud dialog and then check Reuse depth maps option.

Depth filtering modes
At the stage of point cloud generation reconstruction Metashape calculates depth maps for every
image. Due to some factors, like noisy or badly focused images, there can be some outliers among
the points. To sort out the outliers Metashape has several built-in filtering algorithms that answer the
challenges of different projects.

If there are important small details which are spatially distinguished in the scene to be
reconstructed, then it is recommended to set Mild depth filtering mode, for important features
not to be sorted out as outliers. This value of the parameter may also be useful for aerial projects
in case the area contains poorly textured roofs, for example. Mild depth filtering mode is also
required for the depth maps based mesh reconstruction.

If the area to be reconstructed does not contain meaningful small details, then it is reasonable
to choose Aggressive depth filtering mode to sort out most of the outliers. This value of the
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parameter normally recommended for aerial data processing, however, mild filtering may be
useful in some projects as well (see poorly textured roofs comment in the mild parameter value
description above).

Moderate depth filtering mode brings results that are in between the Mild and Aggressive
approaches. Y ou can experiment with the setting in case you have doubts which mode to choose.

Additionally depth filtering can be Disabled. But this option is not recommended as the resulting
point cloud could be extremely noisy.

The filtering modes control noise filtering in the raw depth maps. This is done using a connected
component filter which operates on segmented depth maps based on the pixel depth values. The
filtering preset control a maximum size of connected components that are discarded by the filter.

Calculate point colors
This option can be unchecked in case the points color is not of interest. This will allow to save up
processing time.

Calculate point confidence
If the option is enabled, the Metashape will count how many depth maps have been used to generate
each point cloud point. This parameter can used for point cloud filtering (see Editing point cloud).

4  Note

» Stronger filter presets remove more noise, but also may remove useful information in case there
are small and thin structuresin the scene.

If Model or Tiled model were selected as the source data then the following parameters can be adjusted:

Uniform point spacing (m)
Specifies the desired distance between points of the point cloud to be generated.

Estimated point count
Defines the expected number of points to be generated.

Import point cloud

Metashape allows to import a point cloud that can be used in the following processing steps. If you want
to upload a point cloud got from some external source (photogrammetry technology, laser scanning, etc),
you can use Import points command from the File menu. In the Import points dialog browse to afilein
one of the supported formats and click Open button.

Point cloud can beimported in one of thefollowing formats: Wavefront OBJ (*.obj), Stanford PLY (*.ply),
ASPRS LAS (*.las), LAZ (*.laz), ASTM E57 (*.€57), ASCII PTS (*.pts, *.pts.gz), PTX (*.ptx), Point
Cloud Data (*.pcd).

In Import Points dialog window specify Direction (Generic, Origin, Trajectory file) and avalue for Local
surface neighborsfor thefollowing formats: ASTM E57 (*.e57), ASCII PTS(*.pts, *.pts.gz), PTX (*.ptx).
If the point cloud was recorded in a structured form, then the Direction - Origin parameter should be used.
If the point cloud was obtained in an unstructured form, then use Direction - Generic. In order to determine
the normal of apoint in apoint cloud, Metashape approximate the local surface of the model with aplane.
The direction of the plane is determined by the nearby neighbors of a given point. The number of nearby
points to consider is determined by Local surface neighbors parameter. If the cloud is very noisy, 28
default neighbors may not be enough to confidently determine the normals. For such point clouds, it is

44



General workflow

worth increasing the number of neighbors under consideration to 100. Increasing the number of neighbors
will slow down the calculation, smooth out the normals at the corners, but will help avoid noise. In some
cases, increasing the number of neighbors can help avoid large inverted plots.

Building mesh

Mesh based on point cloud or depth maps data

M etashape can reconstruct polygona mesh model based on the point cloud information (Point Cloud, Tie
Points imported from external source) or based on the depth maps data.

Tobuild a mesh

1.

Check the reconstruction volume defined by the bounding box. If the default bounding box size and
orientation does not cover the entire area of interest or, in contrary, if a smaller volume should be
reconstructed, use manual tools (resize region, move region, rotate region) to adjust the working
volume.

To adjust the bounding box manually, use the Resize Region, % Move Region and gg’ Rotate
Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired
positions - only part of the scene inside the bounding box will be reconstructed. If the Height field
reconstruction method is to be applied, it is important to control the position of the red side of the
bounding box: it definesreconstruction plane. In this case make sure that the bounding box iscorrectly
oriented.

2. Select the Build Mesh... command from the Wor kflow menu.

3. Inthe Build Mesh dialog box select the desired reconstruction parameters. Click OK button when
done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

£ Note

< More than one instance of Mesh can be stored in one chunk. In case you want to save current
Mesh instance and build new one in current chunk, right-click on Mesh and uncheck Set as
default option. In case you want to save current Mesh instance and edit its copy, right-click on
Mesh and choose Duplicate option.
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Build Mesh parameters

Build Mesh
General
Source data: Depth maps
Surface type: Arbitrary (30)
Quality: High
Face count: High
Advanced
Interpolation: Enabled (default)
Depth filtering: Mild
Point dasses: All Select...

Calculate vertex colors

+unlimetric maslk
CC VOIUMETTIC Masks

ok |
"Build Mesh" dialog

Metashape supports severa reconstruction methods and settings, which help to produce optimal
reconstructions for a given data set.

Sour ce data
Specifies the source for the mesh generation procedure.

» Tiepointscan be used for fast 3D model generation based solely on the tie point cloud.

» Point cloud setting will result in longer processing time but will generate high quality output based
on the previously reconstructed or imported point cloud.

» Laser scans setting allows to use laser scans for the mesh reconstruction.

» Depth maps setting allows to use all the information from the input images more effectively
and is less resource demanding compared to the point cloud based reconstruction. The option
is recommended to be used for Arbitrary surface type reconstruction, unless the workflow used
assumes point cloud editing prior to the mesh reconstruction.

» Depth maps + Laser scans setting allows to use depth maps and laser scans data together for the
mesh reconstruction.

Surfacetype

« Arbitrary surface type can be used for modeling of any kind of object. It should be selected for
closed objects, such as statues, buildings, etc. It doesn't make any assumptions on the type of the
object being modeled, which comes at a cost of higher memory consumption.
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» Height field surface type is optimized for modeling of planar surfaces, such as terrains or
basereliefs. It should be selected for aerial photography processing as it requires lower amount of
memory and allows for larger data sets processing.

Quality
Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a
source option. Higher quality settings can be used to obtain more detailed and accurate geometry, but
they require longer time for the processing.

Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo
Alignment section. Theonly differenceisthat in this case UltraHigh quality setting means processing
of original photos, while each following step implies preliminary image size downscaling by factor
of 4 (2 times by each side). For depth maps based mesh generation Mild filtering option is used by
default, unless Reuse depth maps option is enabled. Aggressive filtering can be used if the excessive
geometry (such as isolated mesh components around the reconstructed object) is observed, however,
some fine level thin elements may be lost due to this depth filtering mode selection.

Face count

Specifiesthe maximum number of polygonsinthefinal mesh. Suggested values (High, Medium, Low)
present optimal number of polygons for amesh of a corresponding level of detail. For the point cloud
based reconstruction they are calculated based on the number of pointsin the source point cloud: the
ratio is 1/5, 1/15, and 1/45 respectively. It is still possible for a user to indicate the target number of
polygons in the final mesh through the Custom value of the Face count parameter. Please note that
while too small number of polygonsis likely to result in too rough mesh, too huge custom number
(over 10 million polygons) islikely to cause model visualization problemsin external software.

Additionally the following advanced parameters can be adjusted.

I nterpolation

If interpolation mode is Disabled it leads to accurate reconstruction results since only areas
corresponding to point cloud points are reconstructed. Manual hole filling is usually required at the
post processing step.With Enabled (default) interpolation mode Metashape will interpolate some
surface areas within a circle of a certain radius around every point cloud point. As a result some
holes can be automatically covered. Y et some holes can still be present on the model and are to be
filled at the post processing step. In Extrapolated mode the program generates holeless model with
extrapolated geometry. Large areas of extra geometry might be generated with this method, but they
could be easily removed later using selection and cropping tools.

Point classes
Specifies the classes of the point cloud to be used for mesh generation. For example, select only
Ground Points class to produce a DTM as opposed to a DSM. Preliminary Classifying point cloud
procedure should be performed for this option of mesh generation to be active. Option is only
applicable to point cloud based reconstruction.

Calculate vertex colors
If source data has color information (point cloud colors or images are present for the depth maps based
calculation) enabling this option would allow to calculate the colors for the mesh vertices and display
the interpolated colors for the mesh polygons in Shaded view mode.

Use strict volumetric masking
When this option is enabled, space volume covered with mask from at least one photo will be
suppressed. Each mask is strict - so you should use them as little as possible to prevent accidental
suppressing some surface parts. Each mask al so makes mesh reconstruction slower. For example strict
volumetric masks are useful to suppress noise between fingers by masking space between them from
single camera. Also this is useful to suppress textureless background stuck to object contours - by
masking out background from single camera. For additional information on the usage of masks please
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refer to the Using masks section. The option is only applicable for the Depth Maps source option
selected.

Reuse depth maps
If available depth maps should be reused for mesh generation, select respective Quality (seeinfo next
to Depth maps label on the Workspace pane in the chunk's contents) and then check Reuse depth maps
option. The option is applicable to the depth maps based reconstruction method only.

4 Note

» Metashape tends to produce 3D models with excessive geometry resolution, so it may be
reasonable to perform mesh decimation after geometry computation. More information on mesh
decimation and other 3D model geometry editing tools is given in the Editing model geometry
section.

Import mesh

Mesh can beimported using Import model command from the File menu. Thefollowing import formatsare
supported: Wavefront OBJ (*.obj), 3DS models (*.3ds), OpenCTM models (*.ctm), COLLADA (*.dag),
Stanford PLY (*.ply), STL models (*.stl), Alembic (*.abc), Autodesk FBX (*.fbx), Aturodesk DXF
(*.dxf), U3D models (*.u3d).

Building model texture

Color calibration

If the lighting conditions have been changing significantly during capturing scenario, it is recommended
to use Calibrate colors option from the Tools menu before Build texture procedure. The option can help
to even brightness and white balance of the images over the data set. Please note that for large data sets
Calibrate colors procedure can turn out to be quite time consuming.

To calibrate colors
1. Select Calibrate colors... command from the Tools menu.

2. Select the desired colors calibration parameters in the Calibrate colors dialog box. Click OK button
when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Color calibration parameters

Calibrate Colors
Parameters

Source data: Model

Calibrate white balance

resct | (RSN
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Build

"Calibrate Colors" dialog

Source data

Defines what data should be taken as the basis for overlapping areas estimation.
Tie points - the quickest yet the roughest estimation available.

Model - gives more precise results, but only on condition that the surface is detailed enough. This
parameter value is the recommended one if the aim is to calibrate colors to improve the quality of
the model texture.

DEM - is a reasonable alternative to Model value for large data sets when it is not feasible to
reconstruct solid polygonal model (mesh).

Calibrate white balance

Additional option to be switched on if white balance should be evened as well.

In Metashapeit is possibleto manually set color level adjustmentsfor one or moreimages using the Adjust
color levelstool. The Adjust Color Levelstool is available from the selected images context menu in the
Photos pane. If the image is very dark or overexposed, you can manually set adjust the levels for each
channel of theimage in the Color levels dialog of the tool or set the Average value for al channels.

Texture

The texture feature allows to build different types of textures for amodel.

To generate 3D model texture

1

2.

Select Build Texture... command from the Wor kflow menu.

Select the desired texture generation parameters in the Build Texture dialog box. Click OK button
when done.

The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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Texture gen eration parameters

Buid Texture

General
Texture type: Diffuse map
Source data: Images
Mapping mode: Generic
Blending mode: Mosaic (default)
Texture sizefcount: 8192 |
Advanced

Enable hole filing
Enable ghosting filter
T £

ransrer exmre

Lok ] cancel

"Build Texture" dialog

m

The following parameters control various aspects of texture atlas generation:

Texturetype
Diffuse map - the basic texture that stores the colors of the model surface.

Normal map - texture map that allowsto calculate the illumination of the model parts from different
light sources in the post-processing workflow.

Occlusion map - atexturethat contai ns pre-cal culated shading information from background lighting.

Displacement map - a black-and-white texture where each pixel has a value from 0 to 255. These
values are used to determine the height of each point on the surface of the object.

Sour ce data
Images - allow to build a color texture map (diffuse map) based on the aligned images of the model
or transferred from another model with already generated color texture map.

3D modd - the normal and occlusion texture maps can be built based on another model and the
relief of the model specified in the Source data field will be transferred to the current model. Usually
it is recommended to use the more detailed model as a source data for the Normal, Occlusion and
Displacement map generation for the 3D model with the lower polygon count. Normal map option
will not be available in the Source data field, if less than two 3D model instances are present in the
active chunk.

Mapping mode
The texture mapping mode determines how the object texture will be packed in the texture atlas.
Proper texture mapping mode selection helps to obtain optimal texture packing and, consequently,
better visual quality of the final model.
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The default mode is the Generic mapping mode; it allows to parametrize texture atlas for arbitrary
geometry. No assumptions regarding the type of the scene to be processed are made; program tries
to create as uniform texture as possible.

In the Orthophoto mapping mode the whol e object surfaceistextured in the orthographic projection.
The Orthophoto mapping mode produces even more compact texture representation than the
Adaptive orthophoto mode at the expense of texture quality in vertical regions.

In the Adaptive orthophoto mapping mode the object surface is split into the flat part and vertical
regions. The flat part of the surface is textured using the orthographic projection, while vertical
regionsaretextured separatel y to maintain accurate texture representation in such regions. Wheninthe
Adaptive orthophoto mapping mode, program tends to produce more compact texture representation
for nearly planar scenes, while maintaining good texture quality for vertical surfaces, such aswalls
of the buildings.

Spherical mapping mode is appropriate only to a certain class of objects that have a ball-like form.
It allows for continuous texture atlas being exported for this type of objects, so that it is much easier
to edit it later. When generating texture in Spherical mapping mode it is crucial to set the bounding
box properly. The whole model should be within the bounding box. The red side of the bounding box
should be under the model; it defines the axis of the spherical projection. The marks on the front side
determine the O meridian.

The Single camer a mapping mode allows to generate texture from a single image. The image to be
used for texturing can be selected from Texture from: list.

The Keep uv mapping mode generates texture atlas using current texture parametrization. It can
be used to rebuild texture atlas using different resolution or to generate the atlas for the model
parametrized in the external software. Keep uv option preserves the original number of texture atlas
pages, i.e. Texture count parameter can't be changed.

Blending mode (not used in Single camera mapping mode)
Selectstheway how color values of pixelsfrom different cameraswill be combined in thefinal texture.

Mosaic - implies two-step approach: it does blending of low frequency component for overlapping
images to avoid seamline problem (weighted average, weight being dependent on a number of
parameters including proximity of the pixel in question to the center of the image), while high
frequency component, that is in charge of picture details, is taken from a single image - the one that
presents good resolution for the area of interest while the camera view is ailmost along the normal to
the reconstructed surface in that point.

Average - uses the weighted average value of al pixels from individual photos, the weight being
dependent on the same parametersthat are considered for high frequency component in mosaic mode.

Max I ntensity - the image which has maximum intensity of the corresponding pixel is selected.
Min Intensity - the image which has minimum intensity of the corresponding pixel is selected.

Disabled - the image to take the color value for the pixel from is chosen like the one for the high
frequency component in mosaic mode.

Texturesize/ count
Specifies the size (width & height) of the texture atlas in pixels and determines the number of files
for texture to be exported to. Exporting texture to severa files allows to archive greater resolution of
the final model texture, while export of high resolution texture to a single file can fail due to RAM
limitations.
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Multi-pagetexture atlas generation issupported for Generic mapping mode only and K eep UV option,
if the imported model contains proper texture layout.

Additionally the following advanced parameters can be adjusted.

Enable holefilling
Thisoption is enabled on default since it helps to avoid salt-and-pepper effect in case of complicated
surface with numerous tiny parts shading other parts of the model. Only in case of very specific tasks
might it be recommended to switch the function off.

Enable ghosting filter
In case the scene includes some thin structures or moving objects which failed to be reconstructed

as part of polygona model, it can be useful to switch on this option to avoid ghosting effect on the
resulting texture.

4 Note

* HDR texture generation requires HDR photos on input.

To improve resulting texture quality it may be reasonable to exclude poorly focused images from
processing (read more in Image quality section).

It isalso recommended to use the Remove Lighting tool for texture improvement. Refer to Editing textures
section of the manual for the details.

View Mesh UVs

In Metashape it is possible to analyze Mesh UV dtatistic. You can evaluate the quality of the resulting
texture using data in this dialog window.

To open UV Mapping dialog window
1. Select View Mesh UVs... command on Mesh submenu from the Tools menu.

2. Check parameters for the built texture in UV Mapping dialog box. Y ou can save data from this page
using Save Page button.
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UV Mapping

View
® Color
Diffuse map
Scaling
CQwverlap

Fesaolution

Statistics

Fill ratio: 69.6%
Cverlap ratio: 3.43e-05%
Min scaling: 63.1%
Max scaling: 135%

Min resolution: 75.5%
Max resolution:  116%

Page 12 — E -

"UV Mapping" dialog

The texture layout is displayed on the right side of the dialog window and depends on which parameter
is selected in View section. Satistics section presents numerical parameters. The parameters from View
section and corresponding Statistics section values are described below:

View
Color - displays the colors of the mesh vertices.

Diffuse map - display the basic texture that stores the colors of the model surface.

Scaling - displaysthe ratio of the area of the texture triangle to its area on the mesh surface. The min
and max scaling values in the Satistics section correspond. The colors display the following: blue -
min scaling, red - max scaling.

Overlap - displays how many pixelsin the atlas correspond to more than one triangle in the mesh.

Resolution - displays the detail as a percentage. It is calculated as the ratio of the number of pixels
for the triangle from the most detailed photo to the area of the triangle in the atlas. In the Statistics
section the percentage (min and max values) is displayed. The colors display the following: blue -
minimal resolution of the texture, red - maximal resolution of the texture, the good enough values
are colored in green.

Statistics
Fill ratio: - displays the percentage of occupied pixels on the atlas page.
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Overlap ratio: - value of the overlap as a percentage corresponds to Overlap parameter in View
section. Thisvaluewill be O in anideal case.

Min scaling: - minimum scaling value as a percentage.

Max scaling: - maximum scaling value as a percentage.

Min Resolution: - minimum resolution value as a percentage.
Max Resolution; - maximum resolution value as a percentage.

To save information from each map (Color, Diffuse map, Scaling, Overlap, Resolution) use Save page
button on the lower left corner of the dialog window.

To switch between the pages of the texture atlas use Next page and Previous page buttons at the bottom of
the dialog window. The number of pages corresponds to the number specified in Build texture dial og box.

Building tiled model

Hierarchical tiles format is a good solution for city scale modeling. It allows for responsive visualization
of large area 3D models in high resolution. The tiled model can be either opened in Metashape itself or
with Agisoft Viewer - acomplementary tool included in Metashape installer package, or with some other
external application which supports a hierarchical tiles format.

Tiled model is build based on point cloud, mesh or depth maps data. Hierarchical tiles are textured from
the source imagery.

[{ Note

« Build Tiled Model procedure can be performed only for projects saved in .PSX format.

< More than one instance of Tiled Model can be stored in one chunk. In case you want to save
current Tiled Model instance and build new onein current chunk, right-click on Tiled Model and
uncheck Set as default option. In case you want to save current Tiled Model instance and edit its
copy, right-click on Tiled Model and choose Duplicate option.

To build atiled model

1. Check the reconstruction volume bounding box - tiled model will be generated for the area within
bounding box only. To adjust the bounding box use the % Move Region, Resize Region and
82’ Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the
desired positions.

2. Select the Build Tiled Model... command from the Wor kflow menu.

3. Inthe Build Tiled model dialog box select the desired reconstruction parameters. Click OK button
when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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Build Tiled Model parameters

Build Tiled Model

General
Source data: Depth maps
Quality: High
Pixel size (m): 0.000219426
Tile size: 256
Face count: Medium
Advanced
Depth filtering: Mild

Enable ghosting filter

Reuse depth maps

Merge tiled model

Lo ] cancel |

"Build Tiled Model" dialog

Sour ce data
Depth maps - is recommended for large projects when Build Mesh procedure is not feasible due to
processing time and result management issues.

Point cloud - can be used as an alternative to the depth maps based option in case the point cloud has
been already generated for any other purposes, whereas the depth maps are not stored in the project
or have been generated with the filtering option different from Mild.

Mesh - alows to keep all the details in the tiled model if a very detailed mesh has been generated
previously.

Depth maps + Laser scans - allows to use depth maps and laser scans data together for the building
tiled model.

Pixel size (m)
Suggested value shows automatically estimated pixel size due to input imagery effective resolution.
It can be set by the user in meters.

Tilesize
Tile size can be set in pixels. For smaller tiles faster visualization should be expected.
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Face count
Suggested values (High, Medium, Low) present optimal number of polygons for atiled model block
of acorresponding level of detail. Itisstill possiblefor auser to indicate the target number of polygons
in the final mesh through the Custom value of the Face count parameter.

Quality

Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a
source option. Higher quality settings can be used to obtain more detailed and accurate geometry, but
they require longer time for the processing. Interpretation of the quality parameters hereis similar to
that of accuracy settings given in Photo Alignment section. The only difference is that in this case
Ultra High quality setting means processing of origina photos, while each following step implies
preliminary image size downscaling by factor of 4 (2 times by each side). For depth maps based tiled
model generation Mild filtering option is used, unless Reuse depth maps option is enabled.

Additionally the following advanced parameters can be adjusted.

Transfer model texture
If there is a textured mesh model in the chunk, its texture can be reused for the tiled model texture
generationinstead of sourceimages. Theoptionisonly availableif Meshis selected asa Source option
for the tiled model generation.

Enable ghosting filter
In case the scene includes some thin structures or moving objects which fails to be reconstructed as
part of polygona model, it can be useful to enable this option to avoid ghosting effect on the resulting
texture.

Reuse depth maps
Depth maps available in the chunk can be reused for the tiled model generation operation. Select
respective Quality and Depth filtering parameters values (see info next to Depth maps label on the
Workspace pane) in Build Tiled Model dialog and then check Reuse depth maps option. The optionis
only available if Depth maps are selected as a Source option for the tiled model generation.

Merge tiled model
This option allows to match the grid of tiles with the existing tiled model in the project and merge
newly created tiles with the existing model to the single tiled model.

Import Tiled Model

In Metashape you can add atile model to aproject using Import Tile Model command from the File menu.

Tiled model can be imported in Agisoft Tiled Model (*.tls) format.

Building digital elevation model

Digital elevation model (DEM) is a2.5D model of a surface represented in aform of aregular grid, with
height values stored per every cell of the grid. In Metashape DEM can be rasterized from a point cloud,
tie points, mesh or generated directly from depth maps.

Metashape allows to create both digital surface model (DSM), i.e. 2.5D model of the Earth surface with
all the objects on it, and digital terrain model (DTM) which represents the bare ground surface without
any objects like plants and buildings. DTM can be built only based on the point cloud data, which should
be classified into ground points and other semantic classes before DTM generation step. See Classifying
point cloud section of the manual for information about optionsto classify/filter point cloud in Metashape
software.
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M etashape enablesto perform DSM/DTM-based point, distance, area, and volume measurements, as well
as generate cross-sections for the part of the scene selected by user. Furthermore, DEM can serve as a
sourcefor contour lines cal culations within M etashape software. More information about the measurement
functionality can be found in Performing measurements on DEM section of the manual.

4 Note

» Build DEM procedure can be performed only for projects saved in .PSX format.

« DEM can be calculated for referenced or scaled projects only. So before building DEM it is
necessary to ensure that a coordinate system for the model is set correctly or the project is scaled
(using at least one scale bar). For guidance on Setting coordinate system please go to Coordinate
system

* Morethan one instance of DEM can be stored in one chunk. To save current DEM instance and
build new onein current chunk, right-click on DEM and uncheck Set as default option. To save
current DEM instance and edit its copy, right-click on DEM and choose Duplicate option.

DEM iscalculated for the part of the model within the bounding box. To adjust the bounding box use the
% Resize Region and 22; Rotate Region toolbar buttons. Rotate the bounding box and then drag corners
of the box to the desired positions.

DEM isdisplayedin Ortho and Model view. In Metashapethe following DEM display modes are available
in Ortho view: Elevation, Slope and Aspect. Use to the corresponding buttons on the toolbar to change the
DEM display mode. When displaying DEM in Sope mode, the slope value in degrees (from 0 to 90) is
based on the elevation value at each point. In Aspect mode, the aspect of slope will be displayed, measured
clockwise in degrees from 0 to 360 (where 0 is north, 180 - to the south).

To build DEM
1. Sedlect the Build DEM... command from the Wor kflow menu.

2. Inthe Build DEM dialog box set Coordinate system for the DEM generation or choose the projection
type.

3. Select source datafor DEM rasterization.
4, Click OK button when done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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Build DEM parameters

Buid DEM

Projection

Type: Geographic Flanar Cylindrical

WG5S 84 (EPSG::4326)

Parameters

Source data: Dense doud
Quality:
Interpolation: Enabled (default)

Point dasses: All

Advanced
Depth filtering:

Reuse depth maps

Region
Setup boundaries:  5.651350 - | 5.656036 ¥
Reset 51990867 - | 51993418 ¥
Resolution {m): 0.274885
Total size (pix): 1171 ¥ 1032

Lo ] concel |

"Build DEM" dialog

Projection type
Geographic - allows to choose a geographic coordinate system from the dropdown list or upload
parameters of a customized geographical coordinate system. The coordinate system set by default is
the coordinate system previously selected for the model itself. Metashape allowsto choose a different
one, providing that corresponding datum transformation parameters are available.
Planar . Metashape allows to project DEM onto a plane set by the user. In this case, select projection
plane and orientation of the resulting DEM. The plane can be determined by a set of markers (if there
areno 3 markersin adesired projection planeit can be specified with 2 vectors, i. €. 4 markers). Planar
projection type may be useful for DEM generation in projects concerning facades, for example.
Cylindrical - allowsto project DEM on acylindrical surface. In this case height valueis calculated as
the distance from the model surface to the cylindrical surface. Refer to Building orthomosaic section
to see the options.
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Sour ce data

It is recommended to calculate DEM based on Point cloud data, as this option alows to perform
the point classification and surface generation based on the certain classes only. If the classification
is not required and the point cloud is not needed by the task requirements, Depths maps option is
recommended. Preliminary elevation data results can be generated from aTie points, avoiding Build
Point Cloud step for time limitation reasons. Mesh and Tiled model options can be used, if DEM
should follow the polygonal model precisaly or point cloud has not been reconstructed. Point cloud
+ Laser scans - allowsto use point cloud and laser scans data together for the building DEM.

Quality
Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a
source option. Higher quality settings can be used to obtain more detailed and accurate model, but
they require longer time for the processing. Interpretation of the quality parameters hereis similar to
that of accuracy settings given in Photo Alignment section. The only difference is that in this case
Ultra High quality setting means processing of origina photos, while each following step implies
preliminary image size downscaling by factor of 4 (2 times by each side).

I nterpolation
If interpolation mode is Disabled it leads to accurate reconstruction results since only areas
corresponding to point cloud or polygonal points are reconstructed. Usualy this method is
recommended for Mesh and Tiled Model data source.

With Enabled (default) interpolation mode Metashape will calculate DEM for al areas of the scene
that arevisible on at least oneimage. Enabled (default) setting isrecommended for DEM generation.

In Extrapolated mode the program generates holeless model with some elevation data being
extrapolated up to the bounding box extents.

Point classes
The parameter alows to select a point class (classes) that will be used for DEM calculation.

Setup boundaries
Metashape generates DEM only for the area inside the bounding box. To calculate DEM for a
particular rectangular part of the project, use Region section of the Build DEM dialog. Indicate
coordinates of the bottom |eft and top right cornersof the region. Suggested valuesindicate coordinates
of the bottom left and top right corners of the whole areato be rasterized, the area being defined with
the bounding box.

Resolution (m)
Resolution value shows effective ground resolution for the DEM estimated for the source data. DEM
that is based on the tie point and point cloud can be generated in the default resolution only. In this
case the value depends on the Quality parameter value used at Build Point Cloud step. When using
Depth Maps as Source data, the resolution will be recalculated relative to the quality depth map. Use
Depth Maps, Mesh or Tiled model as Source data to enter resolution value manually.

Total size (pix)

Size of the resulting DEM, calculated with respect to the ground resolution, is presented in Total size
section fields.

Import DEM

Metashape allows to import a DEM in project in GeoTIFF (* .tif) format. Use Import DEM... command
fromtheFilemenutoimport DEM. Inthe mport DEM dial og browseto afile and select coordinate system.
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Building orthomosaic

Orthomosaic is a combined image created by seamless merging of the original images projected on the
object surface and transformed to the selected projection. A polygonal model (mesh) or adigital elevation
model can be selected as a surface where the images will be projected to.

Metashape allows using one of the following projection types. Geographic, Planar or Cylindrical.
Geographic projection servesfor most typical task of creation an orthomosaic in ageographical coordinate
system. Planar projection allows to select arbitrary orientation of projection plane which is useful for
projects concerning facades or other non-horizontal surfaces. To minimize distortions for objects of a
cylindrical shape, like tubes, round towers, tunnels, etc., a Cylindrical projection type can be used.

M etashape enables to perform orthomosaic seamline editing for better visual results (see Orthomosaic and
panorama seamlines editing section of the manual).

For multispectral imagery processing workflow Ortho view tab presents Raster Calculator tool for NDVI
and other vegetation indices calculation to analyze crop problems and generate prescriptions for variable
rate farming equipment. More information on NDV | calculation functionality can be found in Vegetation
indices calculation section.

£ Note

 Build Orthomosaic procedure can be performed only for projectssavedin .PSX format for chunks
with the existing mesh or DEM.

* More than one instance of Orthomosaic can be stored in one chunk. In case you want to save
current Orthomosaic instance and build new one in current chunk, right-click on Orthomosaic
on the Workspace pane and uncheck Set as default option. In case you want to save current
Orthomosai ¢ instance and edit its copy, right-click on Orthomosaic and choose Duplicate option.

« In the Ortho view a Basemap for the orthophotomosaic can be included as a bottom layer.
Select Show Basemap from the Ortho view toolbar. In M etashape two modes of the Basemap are
supported: Map and Satellite. Map - displays map tiles using Open Street Map. Satellite option
display satellite layer.

If the lighting conditions have been changing significantly during capturing scenario, it is recommended
to use Calibrate colors option from the Tools menu before Build Orthomosai ¢ procedure. The option can
help to even brightness and white balance of theimages over the data set. Please notethat for large data sets
Calibrate colors procedure can turn out to be quite time consuming. See information on color calibration
parameters in Building model texture section.

To build Orthomosaic
1. Select the Build Orthomosaic... command from the Wor kflow menu.

2. In the Build Orthomosaic dialog box select Coordinate system in which the orthomosaic will be
generated or select projection type.

3. Select type of Surface datathat will be used to build the orthophoto.
4. Click OK button when done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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Build orthomosaic parameters

Build Orthomosaic

Projection

Type: Geographic Planar Cylindrica

Parameters

Surface: DEM

Blending mode: Mosaic (default)
Refine seamlines
Enable hole filing

Enable ghosting filter

Pixel size (%): 2.132585e-06 X
[ Metres... | 1.316672-06 Y
Max. dimension {pix): 40596
Region
Setup boundaries: - ¥
- v
Total size (pix): X

oc ] cancel |

"Build Orthomosaic" dialog

Projection type
Geographic - allows to choose a geographic coordinate system from the dropdown list or upload
parameters of a customized geographical coordinate system. The coordinate system set by default
is the coordinate system previously selected for the model itself. Y ou can switch to a different one,
providing that corresponding datum transformation parameters are available.

Planar . Metashape allowsto project the orthomosaic onto a plane set by the user, providing that mesh
isselected asthe surface type. Y ou can select projection plane and orientation of the orthomosaic. The
plane can be determined by a set of markers (if there are no 3 markersin adesired projection plane it
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can be specified with 2 vectors, i. e. 4 markers). Planar projection type may be useful for orthomosaic
generation in projects concerning facades or other vertical surfaces.

Cylindrical - allowsto project orthomosaic on acylindrical surface. It helpsto avoid severedistortions
while projecting cylindrical objects, like tubes, round towers, tunnels, etc.

Toproject 3D pointsonacylindrical surface one needsto: 1) definethecylinder, i.e. defineitsaxisand
itsradius; 2) drop aperpendicular fromthe 3D point to the axisof the cylinder - the point of intersection
of the perpendicular and the cylindrical surface isthe projection of the 3D point in question; 3) agree
on how to define x and y coordinates of a point on the cylinder. For the purpose of orthomosaic and
DEM generation in cylindrical projection Metashape defines x and y coordinates of a point on the
cylinder in the following way: x - along the curvein the zero-plane, y - along the zero-element of the
cylindrical surface (zero-line), where zero-plane and zero-line are to be defined.

M etashape offers four methods to perform projecting on cylindrical surface. They differ in how the
four core elements - cylinder axis and radius, zero-plane and zero-line - are defined.

Current Region. The cylinder isinscribed in the Bounding box: the axis goes through the cross sign
on the bottom side of the Bounding box perpendicular to the bottom plane; the radiusis defined as one
half of the shorter side of the rectangle in the bottom of the Bounding box. Zero-plane goes through
the center of the Bounding box perpendicular to the axis; zero-line belongs to the Bounding box side
which is opposite to the side with the vertical marks.

Current View. The axisis set as the line from the viewpoint to the center of rotation for the model.
Radius is defined as one half of the shortest of all the edges of the Bounding box. Zero-plane goes
through the center of rotation for the model perpendicular to the axis; zero-line goes through the
highest point (in monitor-related coordinate system) of the curve in the zero-plane.

Markers. At least three marker are required. The first pair sets the axis. The third marker defines
zero-point, i.e. defines zero-plane and zero-line, on condition that radiusis the distance from the third
marker to the axis.

XIY/Z. The axisis the line parallédl to the corresponding Cartesian axis - X/Y/Z, going through the
center of the Bounding box. Radius (r) is defined as one half of the shortest edge of the Bounding box.
Zero-plane goes through the center of the Bounding box perpendicular to the axis, zero-line is the
line opposite to the cut line. The cut line definition for each of the three possible optionsisillustrated
on the Figure below.

Interior projection option allows to switch to projecting on the inner surface of the cylinder.

Surface
Orthomosaic creation based on DEM data is especially efficient for aerial survey data processing
scenarios alowing for time saving on mesh generation step. Alternatively, mesh surface type allows
to create orthomosaic for less common, yet quite demanded applications, like orthomaosaic generation
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for facades of the buildings or other models that might be not referenced at all. For projects with laser
scans, it is possible to use them to build orthomosaic.

Blending mode
M osaic (default) - implements approach with datadivision into several frequency domainswhich are
blended independently. The highest frequency component is blended along the seamline only, each
further step away from the seamline resulting in aless number of domains being subject to blending.
Aver age - uses the weighted average color value of all pixels from individual images.
In Disabled mode the color value for the pixel is taken from the image with the camera view being
almost along the normal to the reconstructed surface in that point.

Pixel size
Default value for pixel size in Export Orthomosaic dialog refers to ground sampling resolution, thus,
it is useless to set a smaller value: the number of pixels would increase, but the effective resolution
would not. However, if it is meaningful for the purpose, pixel size value can be changed by the user
in coordinate system units or in meters.

Max. dimension (pix)
The parameter allows to set maximal dimension for the resulting raster data.

Back face culling
The option allows to neglect on projecting parts of the surface where normals are counter directed to
the targeted projection plane.

Enable holefilling
Thisoption is enabled on default since it helps to avoid salt-and-pepper effect in case of complicated
surface with numeroustiny parts shading other parts of the source surface model. Only in case of very
specific tasks might it be recommended to switch the function off.

Enable ghosting filter
The filter alows to exclude moving objects (such as cars, trains, and so on) when building
orthomosaic. Don't recommend enable ghosting filter if DTM used as a surface.

Refine seamlines
The option is recommended to be used for DTM-based orthomosaics in order to make automatically
created seamlines to bypass buildings and other complex objectsin order to avoid visua artefacts on
the final image and time consuming manual orthomosaic patching.

M etashape generates orthomosaic only for the areainside the bounding box. However, if the orthomosaic
should be generated for a particular (rectangular) part of the project, Region section of the Build
Orthomosaic dialog should be used for indication of the coordinates of the bottom | eft and top right corners
of the region to be applied in the left and right columns of the textboxes respectively. Estimate button
allows you to see the coordinates of the bottom left and top right corners of the whole area.

Estimate button al so enablesto control total size of the resulting orthomosai c dataaccording to the currently
selected reconstruction area and resolution (Pixel size or Max. dimension parameters). The information is
shown in the Total size (pix) section fields.

Import Orthomosaic

M etashape allows to import a orthomosaic in project. Use Import Orthomosaic... command from the File
menu. In the Import Orthomosaic dialog browse to afile and select coordinate system.

Orthomosai ¢ can beimported in one of thefollowing formats: GeoTIFF (*.tif), GeoPackagefiles (*.gpkg),
MBTiles (*.mbtiles), KML files (*.kml, *.kmz), TMStiles (* .xml, *.zip).
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Building panorama

Metashape is capable of panorama stitching for images taken from the same camera position - camera
station. To indicate for the software that loaded images have been taken from one camera station, one
should move those photos to aimage group and assign Station type to it. For information on image groups
refer to Loading source data section.

To build panorama

1. Select the Build Panorama command from the Workflow menu.

2. Setting parameters for building panoramain the Build Panorama dialog.
3. Click OK button for starting generate panorama.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

£ Note

 Build Panorama procedure can be performed only for projects saved in .PSX format.

Build panorama parameters

Buid Panorama
Preview

Carmera group:  Group 1

Parameters
Apply to: Active chunk
Blending mode: Maosaic (default)

Enable ghosting filter

Feagion
Setup boundaries:  -130 - 130 X
Reset -33 - | B3 L
Image size (pix): 27034 ¥ 13517

ok _J Cancel ]

"Build Panorama' dialog
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Preview

Camera group - select camera station for building panorama.
Orientation and rotation parameter s - setting orientation and rotation using corresponding buttons
for building panorama.

Parameters

Apply to - select chunk or entire workspace.

Blending mode - selects the method how color values of pixels from different cameras will be
combined in the final panorama (Mosaic, Average, Disabled). Mosaic - implies two-step approach:
it does blending of low frequency component for overlapping images to avoid seamline problem
(weighted average, weight being dependent on a number of parameters including proximity of the
pixel in question to the center of the image), while high frequency component, that is in charge of
picture details, is taken from a single image - the one that presents good resolution for the area of
interest while the camera view is amost along the normal to the reconstructed surface in that point.
Average - uses the weighted average value of all pixels from individual photos, the weight being
dependent on the same parametersthat are considered for high frequency component in mosaic mode.
Disabled - the image to take the color value for the pixel from is chosen like the one for the high
frequency component in mosaic mode.

Enable ghosting filter - in case the scene includes some thin structures or moving objects, it can be
useful to switch on this option to avoid ghosting effect on the resulting panorama.

Region

Setup boundaries - set boundaries for the region of panoramato be built. Text boxesin thefirst line
(X) dlow to indicate the angle in the horizontal plane and the second line (Y) serves for anglein the
vertical plane limits.

I mage size (pix) - option enables to control the dimensions of the resulting image file.

Saving intermediate results

Certain stages of 3D model reconstruction can take a long time. The full chain of operations could
eventually last for 4-6 hours when building a model from hundreds of photos. It is not always possible to
complete al the operations in one run. Metashape allows to save intermediate results in a project file.

Metashape project archive (PSZ2)

Metashape Archive files (*.psz) may contain the following information:

List of loaded photographs with reference paths to the image files.

Cameraalignment data such as camera exterior orientation parameters, tie point cloud and set of refined
camera calibration parameters for each calibration group.

Masks applied to the photos in project.
Depth maps for cameras.
Point cloud with information on points classification.

Reconstructed 3D polygona model with any changes made by user. This includes mesh and texture
if it was built.

List of added markers aswell as of scale-bars and information on their positions.

Structure of the project, i.e. number of chunksin the project and their content.
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Notethat since M etashape tends to generate extradense point cloudsand highly detailed polygonal models,
project saving procedure can take up quite along time.

Metashape project file (PSX)

The software also allows to save Metashape Project file (*.psx) which stores the links to the processing
resultsin *.psx file and the dataitself in * .files structured archive. Thisformat enables responsive loading
of large data (point clouds, meshes, etc.), thus avoiding delays on reopening athousands-of -photos project.
DEM, orthomosaic, panorama and tiled model generation options are available only for projects saved
in PSX format.

Y ou can save the project at the end of any processing stage and return to it later. To restart work simply
load the corresponding file into Metashape. Project files can also serve as backup files or be used to save
different versions of the same model.

Project files use relative paths to reference original photos. Thus, when moving or copying the project file
to another location do not forget to move or copy photographs with all the folder structure involved as
well. Otherwise, Metashape will fail to run any operation requiring source images, although the project
file including the reconstructed model will be loaded up correctly. Alternatively, you can enable Store
absol ute image paths option on the Advanced tab of the Preferences dialog available from Tools menu.

Exporting results

M etashape supports export of processing results in various representations: tie points and point clouds,
camera calibration and camera orientation data, mesh, etc. Orthomosaics and digital elevation models
(both DSM and DTM), aswell as tiled models can be generated according to the user requirements.

Tie point cloud and camera calibration data can be exported right after photo alignment is completed. All
other export options are available after the corresponding processing step.

If you are going to export the results (point cloud / mesh / tiled model ) for the chunk that is not referenced,
please note that the resulting file will be oriented according to a default coordinate system (see axes in
the bottom right corner of the Model view), i. e. the model can be shown differently from what you see
in Metashape window.

[ 1 .
To aign the model orientation with the default coordinate system use ““#* Rotate object button from the

F
Toolbar. @ Move object and “& Scale object instruments can be used to adjust the size and location of
the unreferenced model.

In some cases editing model geometry in the external software may be required. M etashape supports model
export for editing in external software and then allows to import it back as it is described in the Editing
model geometry section of the manual.

Main export commands are available from the File menu.

Point cloud export

To export tie pointsor point cloud
1. Select Export Points... command from the File menu.
2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. Inthe Export Points dialog box select desired type of point cloud: Tie points or Point cloud.

66



General workflow

4. Specify the coordinate system and indicate export parameters applicable to the selected file type,
including the point cloud classes to be saved.

5. Click OK button to start export.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Folit in blocks option in the Export Points dialog can be useful for exporting large projects. It is available
for referenced models only. Y ou can indicate the size of the section in xy plane (in meters) for the point
cloud to be divided into respective rectangular blocks. The total volume of the 3D sceneis limited with
the Bounding Box. The whole volume will be split in equal blocks starting from the point with minimum
x and y values. Note that empty blocks will not be saved.

In some casesit may bereasonableto edit point cloud before exporting it. To read about point cloud editing
refer to the Editing point cloud section of the manual.

M etashape supports point cloud export in the following formats:
» Wavefront OBJ (*.ohbj)

o Stanford PLY (*.ply)

e XYZ Point Cloud (*.txt)
« ASPRSLAS (*.las)

o LAZ (*.laz)

« ASTM E57 (*.€57)

e Topcon CL3 (*.cl3)

« ASCII PTS (*.pts)

e Autodesk DXF (*.dxf)

« U3D (*.u3d)

» Adobe PDF (*.pdf)
 Point Cloud Data (*.pcd)
* potree (*.zip)

* Cesium 3D Tiles (*.zip)
» Agisoft OC3 (*.oc3)

4  Note

« Saving color information of the point cloud is not supported by the OBJ and DXF formats.

* Saving point normals information is not supported by the LAS, LAZ, PTS, CL3 and DXF
formats.

Metashape supports direct uploading of the point clouds to the following resources. 4DMapper (not
supported for tie points), Cesium (not supported for tie points), PointBox, PointScene and Sketchfab. To
publish your point cloud online use Upload Data... command from the File menu.
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Tie points and camera calibration, orientation data
export

To export camera calibration and camera orientation data select Export Cameras... command from the
File menu.

M etashape supports camera data export in the following formats:
» Agisoft XML structure (*.xml)

* Bundler (*.out)

» CHAN files (*.chan)

» Boujou (*.txt)

* Realviz RZML (*.rzml)

» Omega Phi Kappa (*.txt)

» PATB Project (*.pro)

» BINGO Project (*.dat)

« ORIMA (*.txt)

* MayaASCIl (*.ma)

» AeroSys Exterior Orientation (*.orn)
* Inpho Project File (*.prj)

* Summit Evolution Project (*.smtxml)
 Blocks Exchange (* .xml)

» Alembic (*.abc)

» Autodesk FBX (*.fbx)

[{ Note

« Cameradataexport in Bundler and Boujou file formats will savetie point cloud datain the same
file

e Cameradataexport in Bundler file format would not save distortion coefficients k3, k4.

To export control points and tie points data one should choose one of the following export formats in the
Export Cameras dialog: BINGO, ORIMA, PATB, Summit Evolution or Blocks exchange. Tie points and
Control points can be exported only along with interior and exterion orientation parameters of the cameras.

Asaresult of export in PATB format, the following files will be written:
example.pro

Project file PATB. It contains information on the units of measurement (microns/millimeters). This
eliminates the ambiguity in interpreting the data on import.
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exampleim
File with coordinates of tie points projections on the images.

example.con
File with measured coordinates of the ground control points.

example.ori
File with the calculated parameters of the exterior orientation for the cameras.

example.at
File with the calculated coordinates of tie points (adjusted terrain coordinates).

[{ Note

e *.imand *.con formats are input filesfor PATB and *.ori. and *.at are output formats.

Asaresult of export in BINGO format, thefollowing fileswill bewritten to the destination folder: itera.dat
(ITERA file); image.dat (IMAGE COORDINATE file); geoin.dat (GEO INPUT file); gps-imu.dat (GPS/
IMU data).

As aresult of export in Summit Evolution format two files will be created (*.cam, *.smtxml). File in
* .cam format includesinformation about cameracalibration parameters. Filein * .smtxml format is Summit
Evolution project file.

To export / import camera calibration data only select Camera Calibration... command from the Tools

menu. Using ="/ H buttonsit is possible to load / save camera calibration datain the following formats:
» Agisoft Camera Calibration (*.xml)

» Australis Camera Parameters (*.txt)

» Australisv7 Camera Parameters (* .txt)

» PhotoModeler Camera Calibration (*.ini)

» 3DM CalibCam Camera Parameters (*.txt)
» CaCam Camera Calibration (*.cal)

* Inpho Camera Calibration (*.txt)

» USGS Camera Calibration (*.txt)

» Pix4D Camera Cadlibration (*.cam)

* OpenCV Camera Calibration (*.xml)

» Photomod Camera Calibration (* .x-cam)

» Z/I Distortion Grid (*.dat)

o STMap (*.tif, *.exr)

£ Note

« STMap (*.tif, *.exr) format is only available for export camera calibration result.
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Panorama export

To export panorama

1. Select Export > Export Orthomosaic > Export JPEG/TIFF/PNG... command from the File menu.
2. Set exporting parameters and click Export... button.

3. Browsethe destination folder and formats.

4. Click Save button.

M etashape supports panorama export in the following formats:
* JPEG (*.jpg)

« JPEG 2000 (* .jp2)

e JPEG XL (*.jxI)

e TIFF/GeoTIFF (* tif, *.tiff)

* PNG (*.png)

 BMP (*.bmp)

» GeoPackage (*.gpkQg)

* MBTiles (*.mbtiles)

* TileMap Service Tiles (*.zip)

» Google Map Tiles (*.zip)

» Google KMZ (*.kmz)

e World Wind Tiles (*.zip)
3D model export

To export 3D model
1. Select Export Model... command from the File menu.
2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. Inthe Export Model dialog specify the coordinate system and indicate export parameters applicable
to the selected file type.

4. Click OK button to start export.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

If a model generated with Metashape is to be imported in a 3D editor program for inspection or further
editing, it might be helpful to use Shift function while exporting the model. It allows to set the value to
be subtracted from the respective coordinate value for every vertex in the mesh. Essentialy, this means
tranglation of the model coordinate system origin, which may be useful since some 3D editors, for example,
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truncate the coordinates values up to 8 or so digits, while in some projects they are decimals that make
sense with respect to model positioning task. So it can be recommended to subtract a value equal to the
whole part of acertain coordinate val ue (see Reference pane, Camera coordinates val ues) before exporting
the model, thus providing for areasonable scale for the model to be processed in a 3D editor program.

M etashape supports model export in the following formats:
» Wavefront OBJ (*.obj)

» 3DSfileformat (*.3ds)

* VRML models (*.wrl)

« COLLADA (*.dae)

e Stanford PLY (*.ply)

e X3D models (*.x3d)

» STL models (*.stl)

» Alembic (*.abc)

» Autodesk FBX (*.fbx)

* Autodesk DXF Polyline (*.dxf)

« Autodesk DXF 3DFace (*.dxf)

» Open Scene Graph Binary (*.osgb)
» Open Scene Graph Text (*.osgt)

* Binary gITF (*.glb)

» U3D models (*.u3d)

» Adobe PDF (*.pdf)

» Google Earth KMZ (*.kmz)

Some fileformats (OBJ, 3DS, VRML, COLLADA, PLY, FBX) save texture image in aseparate file. The
texture file should be kept in the same directory as the main file describing the geometry. If the texture
atlas was not built only the model geometry is exported.

M etashape supports direct uploading of the models to Sketchfab resource. To publish your model online
use Upload Data... command from the File menu.

Tiled model export

To export tiled model
1. Select Export Tiled Model... command from the File menu.
2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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M etashape supports tiled model export in the following formats:

Cesium 3D Tiles (*.zip)

Scene Layer Package (*.9lpk)
PhotoMesh Layer (*.zip)
Agisoft Tiled Model (*.tls)
Agisoft Tile Archive (*.zip)
OpenSceneGraph Binary (*.zip)

OpenSceneGraph Text (*.zip)

Agisoft Tiled Model can be visualized in Agisoft Viewer application, which is included in Agisoft
M etashape Professional installation package. Thanksto hierarchical tilesformat, it allowsto responsively
visualize large models.

M etashape supports direct uploading of the tiled models to the following resources. 4DMapper, Melown
Cloud, Cesium. To publish your tiled model online use Upload Data... command from the File menu.

Orthomosaic export

To export Orthomosaic

1. Select Export Orthomosaic... command from the File menu.

2. Inthe Export Orthomosaic dialog box specify coordinate system for the Orthomosaic to be saved in.

3. Check Write KML file and / or Write World file options to create files needed to georeference the
orthomosaic in the Google Earth and / or aGIS.

4. Click Export... button to start export.

5. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

£ Note

« Write KML file option is available only if the selected export coordinate system is WGS84 due
to the fact that Google Earth supports only this coordinate system.

« Worldfile specifies pixel size in meters and geographic coordinates of the upper-left pixel of the
exporting orthomosaic. Thisinformation is already included in GeoTIFF file, however, it could
be duplicated in the external files for some reason. If orthomosaic is exported in JPEG, PNG or
BMP file formats and should have the georeferencing information World file should be written.

If the export file of afixed size is needed, it is possible to set the length of the longer side of the export
filein Max. dimension (pix) parameter. The length should be indicated in pixels.

Salit in blocks option in the Export Orthomosaic dialog can be useful for exporting large projects. You
can indicate the size of the blocks (in pix) for the orthomosaic to be divided into. The whole areawill be
split in equal blocks starting from the point with minimum x and y values. Note that empty blocks will
not be saved.
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To export a particular part of the project use Region section of the Export Orthomosaic dialog. Indicate
coordinates of the bottom | eft and top right corners of the region to be exported in theleft and right columns
of the text boxes respectively. Reset button allows you to see the coordinates of the bottom left and top
right corners of the whole area.

Alternatively, you can indicate the region to be exported using polygon drawing option in the Ortho view
tab of the program window. (For instructions on polygon drawing refer to Shapes section of the manual.)
Once the polygon is drawn, right-click on the polygon and set it as aboundary of the region to be exported
using Set Boundary Type option from the context menu.

Default value for pixel size in Export Orthomosaic dialog refers to ground sampling resolution, thus, it
isuseless to set a smaller value: the number of pixels would increase, but the effective resolution would
not. If you have chosen to export orthomosaic with a certain pixel size (not using Max. dimension (pix)
option), it is recommended to check estimated Total size (pix) of the resulting file to be sure that it is not
too large to be correctly saved to the targeted file format.

For (Geo)TIFF export compression type may be set by the user. The following options are available:
LZW, JPEG, Packbits, Deflate. Additionally, the file may be saved without compression (None value
of the compression type parameter). Write BigTIFF file option allows to save files bigger than standard
TIFF limit of 4Gb. Total size textbox in the Export Orthomosaic dialog helps to estimate the size of the
resulting file. However, it is recommended to make sure that the application you are planning to open the
orthomosaic with supports BigTIFF format. Alternatively, you can split a large orthomosaic in blocks,
with each block fitting the limits of a standard TIFF file.

While exporting orthomosaic in JPEG format, JPEG quality parameter controls balance between
compression level (i.e. quality of the result) and export file size: the higher the value of the parameter (%)
the more emphasisis on the quality at the expense of alarger resulting file.

The following formats are supported for orthomosaic export:
* TIFF/GeoTIFF (* tif)

» GeoPackage (*.gpkQg)

» Google KMZ (*.kmz)

* MBTiles (*.mbtiles)

e Tile Map Service Tiles (*.zip)
» Google Map Tiles (*.zip)

» World Wind Tiles (*.zip)

* JPEG (*.jpg)

» JPEG 2000 (*.jp2)

o JPEG XL (*.jxI)

* PNG (*.png)

« BMP (*.bmp)

M etashape supports direct uploading of the orthomosaicsto the following resources. 4DM apper, MapBox,
Melown Cloud, Picterra, Cesium. To publish your point cloud online use Upload Data... command from
the File menu.
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Multispectral orthomosaic export is supported in GeoTIFF format only. When exporting in other formats,
only primary channel will be saved. Multispectral orthomosaic has all channels of the original imagery.
Optionally the alpha channel may be included that defines transparency being used for no-data areas of
the orthomosaic.

To export Multispectral orthomosaic

1. Select Export Orthomosaic... command from the File menu.

2. Follow steps 2-3 from Orthomosai ¢ export procedure above.

3. Select None value for Raster transform parameter.

4. Click Export button to start export.

5. Browse the destination folder, choose GeoTIFF type, and print in the file name. Click Save button.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

To export Seamlines

1. Select Generate Seamlines... command from the Orthomosaic submenu from the Tools menu.

2. Click right button on Shapes layer on the Workspace pane.

3. Select Export Layers from the context menu.

4. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

The following formats are supported for seamlines export:
» Shapefiles (*.shp)

» KML files (*.kml)

* KMZ files (*.kmz)

» DXFfiles (*.dxf)

» GeoJSON files (*.geojson)

» GeoPackage files (*.gpkg)
NDVI data export

Vegetation index data export is available with the Export Orthomosaic... command from the File menu.
Vegetation index data can be saved as two types of data:

1. asagrid of floating point index values calculated per pixel of orthomosaic (multichannel orthomosaic
if several vegetation indices have been calculated for the project)

2. as an orthomosaic in pseudocolors according to a pallet set by user (exports only data for the first
vegetation index or combined data for selected 3 vegetation indices, providing that False Color valueis
set for the Color palette parameter).
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The format is controlled with Raster transform option in Export Orthomosaic dialog. None value allows
to export orthomosaic generated for the data before any index cal culation procedure was performed.

Digital Elevation Model (DSM/DTM) export

Metashape allows to calculate and then export both a digital surface model (DSM) and a digital terrain
model (DTM) (see Building digital elevation model section).

To export Digital Elevation Model
1. Select Export DEM... command from the File menu.
2. Inthe Export DEM dialog specify coordinate system to georeference the DEM.

3. Check Write KML file and/or Write World file options to create files needed to georeference the
DEM in the Google Earth and/or a GIS.

4. Click Export button to start export.
5. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4 Note

* Write KML file option is available only if the model is georeferenced in WGS84 coordinate
system due to the fact that Google Earth supports only this coordinate system.

» World file specifies coordinates of the four corner vertices of the exporting DEM. This
information is already included in GeoTIFF elevation data as well as in other supported file
formats for DEM export, however, you could duplicate it for some reason.

If export file of afixed sizeis needed, it is possible to set the length of the longer side of the export filein
Max. dimension (pix) parameter. The length should be indicated in pixels.

Unlike orthomosaic export, it is sensible to set smaller pixel size compared to the default value in DEM
export dialog; the effective resolution will increase. If you have chosen to export DEM with a certain pixel
size (not using Max. dimension (pix) option), it is recommended to check estimated Total size (pix) of the
resulting file to be sure that it is not too large to be correctly saved to the targeted file format.

No-data value is used for the points of the grid, where elevation value could not be calculated based on
the source data. Default value is suggested according to the industry standard, however it can be changed
by user.

Split in blocks option in the Export DEM dialog can be useful for exporting large projects or meeting
special DEM requirements. (See Orthomosaic export section for details.)

To export a particular part of the project use Region section of the Export DEM dia og (see Orthomosaic
export section for details). Similarly to orthomosaic export, polygons drawn over the DEM on the Ortho
tab of the program window can be set asboundariesfor DEM export. (For instructions on polygon drawing
refer to Shapes section of the manual.)

The following formats are supported for DEM export:

* GeoTIFF elevation data (* .tif)
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Metashape supports direct uploading of the elevation models to the following resources. 4DMapper,
MapBox, Melown Cloud, Cesium. To publish your el evation model online use Upload Data... command

JPEG (*.jpg)

JPEG 2000 (*.jp2)

JPEG XL (*.jxI)

PNG (*.png)

BMP (*.bmp)

GeoPackage (*.gpkg)
MBTiles (*.mbtiles)

Tile Map Service Tiles (*.zip)
Google Map Tiles (*.zip)
Google KMZ (*.kmz)

World Wind Tiles (*.zip)
Arc/Info ASCII Grid (*.asc)
Band interleaved file format (*.bil)

XYZ fileformat (*.xyz)

from the File menu.

4 Note

* In Metashape DEM export colored from RGB palette is supported. Select Palette option in the
Raster transform section of the Export DEM dialog box. The palette option is supported for the
following export formats. TIFF, JPEG, JPEG2000, PNG.

Render Photos

M etashape allowsto render frames from viewpoints specified by the user. Thismay be useful, for example,
in casethetarget sceneisamovingoneanditiscrucia to keep the number of simultaneously taken frames
minimal during capture. A 3D model can be generated based on some optimal humber of photos, and later

on extra frames can be rendered in Metashape software.

This functionality also allows to correct the initial images in such away as to make them appropriate for

lenticular photography.
£ Note

e Thisoption is available after Align photos step. Please note that it works only for unreferenced

chunk.

Torender extraframesfrom a 3D model

1
2.

Select Render Photos... command of Export subcommand of File menu.

In the Render Photos dialog output image size and filename templ ate.
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3. Check Interpolate image positions.

4.  Specify the number of images to be rendered.

5. Specify the quality for depth maps cal culation (see Building point cloud section) and click OK button.
6. Inthe Model view drag the plane of zero parallax to the desired position.

7. Specify the export area (the part of the scene to be rendered) - adjust the size of the gray plane (drag
the corners). Note that yellow rectangles indicate the footprint for all input images.

8.  Adjust the step between the viewpoints for images to be rendered. They are marked with blue points.
Drag the starting/ending blue dots.

9. Click OK button in the top part of the Model view.

10. Specify the folder for the rendered images to be stored to and click OK button.

To correct theinput imagesfor the lenticular photography
1. Select Render Photos.. command of Export subcommand of File menu.
2. Inthe Render Photos dialog output image size and filename template.

3. Uncheck Interpolate image positions and click OK button.

4. Inthe Model view drag the plane of zero parallax to the desired position.

5. Specify the export area (the part of the scene to be rendered) - adjust the size of the gray plane (drag
the corners). Note that yellow rectangles indicate the footprint for al input images.

6. Adjust the step between the viewpoints for imagesto be rendered. They are marked with blue points.
Drag the starting/ending blue dots.

7. Click OK button in the top part of the Model view.

8. Specify the folder for the rendered images to be stored to and click OK button.

Extra products to export

In addition to main targeted products Metashape allows to export some other processing results, like:

- Convert Images... command is available from Export submenu of the File menu and allowsto export free
of lens distortions and geometrically corrected images. It also allowsto convert large imagesto apyramid-
optimized TIFF format for prompt navigation in the Photo view mode.

In the Parameter s section of the Convert Images dialog window the user can check the following options:
Transform to initial calibration (this parameter includes: remove distortion, center principal point and
square pixels), Apply color correction and Update GPS meta data. Metashape supports export of the
images with GPS data refined during alignment and additionally corrected basing on the GCPs (if those
were used in the project). Filename template for converted images should also be specified in the dialog
window.

In the Compression section of the Convert Images dialog window the user can set one of the suggested
TIFF compression parameters. LSW, JPEG, Packbits, Deflate; set JPEG quality and specify if Tiled TIFF,
BigTIFFfileor TIFF overviews should a so be saved. The corrections can be applied to all cameras, entire
workspace, selected cameras or even to a current photo.
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- Depth map for any image (Export Depth... command available from photo context menu). Y ou can export

diffuse map, depth map and normal map.

- Individually orthorectified images (Export Orthophotos... command available from Export submenu of

the File menu).

- High resolution image of the model asit is shown in the Model view or in Ortho view mode. Capture
View command available from the context menu shown on right button click in the Model or Ortho view.

£ Note

* You need to have mesh model generated in the chunk in order to export diffuse map, depth map

and normal map.

Survey Statistics

M etashape generates a report with Survey Statistics. Survey Satistics contains information about camera
overlap, cameralocations, camerarotationsand ground control points. To createareport inthe PDFformat,

Convert Images

Parameters
Transform to initial calibration
Apply color correction

Merge mult

0

Update GPS meta data

Filename template: {flename}. {fileext}

Compression

TIFF compression: LZW

JPEG quality: 99
Write tiled TIFF Write BigTIFF file
Generate TIFF overviews

Apply to

All cameras Entire waorkspace

Salartad Famerss Current r
20 Cameras L

Lok ] cConcel ]

"Convert Images' dialog

read Processing report generation section.

To create Survey Statistics

1. Select Survey Satistics command from the Tools menu.
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2. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

3. In the Survey Satistics dialog displayed camera overlap, camera locations, camera rotations and
ground control points. Information about survey statistics can be export in the following format:
JPEG, JPEG 2000, PNG, TIFF, BMP, OpenEXR, TARGA.

4. Click Close button to close the dialog.

Survey Statistics Tabs

Camera overlap
Image with camera locations and image overlap.

Camera locations
Image with cameralocations and error estimates. Z error is represented by ellipse color. X,Y error are
represented by ellipse shape. Estimated camera locations are marked with a block dot.

Camerarotations
Image shows camera orientations and error estimates

Ground control points
Image shows control and check point locations and error estimates. Z error is represented by ellipse
color. X,Y errors are represented by ellipse shape. Estimated locations are marked with a dot for
control points or T-crossing for check points.

Connectivity

During initial image alignment, one or more components are generated. Each component represents a
connected photogrammetric network. In the process of editing tie points or markers, the connectivity
of an individual component may be lost, which will lead to incorrect determination of the relative
orientation parameters in the component. The Connectivity tab displaysalist of disconnected camera
groups, helping to locate the camera groups where alignment is incorrect. The user can either use
additional markers between listed groups of images or split the groups into separate connected
components.

Rolling Shutter
If the option Enablerolling shutter compensation is enabled in the Camera calibration dial og window
before alignment step, the visualization of therolling shutter effect can be observed on the tab. On the

image: y-axis of each camera is represented as red line; estimated camera movement is represented
by green line; cameras without rolling shutter effect are grayed out.

Processing report generation

Metashape supports automatic processing report generation in PDF format, which contains the basic
parameters of the project, processing results and accuracy evaluations.

To generate processing report
1. Select Generate Report... command from the File menu.
2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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M etashape processing report presents the following data:
* Orthomosaic sketch.

» Survey data including coverage area, flying altitude, GSD, general camera(s) info, as well as overlap
statistics.

» Camera calibration results: figures and an illustration for every sensor involved in the project.
» Camera positioning and orientation error estimates.

» Ground control and check points error estimates.

* Scale bars estimated distances and measurement errors.

 Digital elevation model sketch with resolution and point density info.

» Processing parameters used at every stage of the project.

[{ Note

» Processing report can be exported after alignment step.

Survey Data

Fig. Cameralocations and image overlap - shows the model and position the cameras is shown and the
number of overlapsisdisplayedin color.

Number of images - total humber of images uploaded into the project.

Camera stations - number of aligned images.

Flying altitude - average height above ground level.

Tie points - total number of valid tie points (equals to the number of pointsin the tie points cloud).
Ground resolution - effective ground resolution averaged over al aligned images.

Projections - total number of projections of valid tie points.

Coverage area - size of the areathat has been surveyed.

Reprojection error - root mean sgquare reprojection error averaged over all tie points on all images.

Table. Cameras - table with the parameters: camera model, resolution, focal length, pixel size,
precalibrated.

Reprojection error is the distance between the point on the image where a reconstructed 3D point can be

projected and the original projection of that 3D point detected on the photo and used as a basis for the
3D point reconstruction procedure.

Camera Calibration

For precalibrated cameras interior parameters input by the user are shown on the report page. If acamera
was not precalibrated, interior camera parameters estimated by Metashape are presented.
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Fig. Imageresidualsfor camera - displaysthereprojection errorsfor thetie points detected on the source
images, averaged across all theimages of the calibration group and inside the certain "cells" on theimages.

Camera name (focal length) - camera model name and number of images.
Type - cameratype.

Resolution - image dimensions in pixels.

Focal Length - focal length in mm.

Pixel Size - pixel sizein pm.

Table. Calibration coefficients and correlation matrix - table with the calibration coefficients and
parameters of the covariance matrix (F, Cx, Cy, B1, B2, K1, K2, K3, K4, P1, P2).

Camera Locations

Fig. Cameralocationsand error estimates - presenting camera locations and error estimates. Z error is
represented by ellipse color. X, Y error are represented by €ellipse shape. Estimated camera locations are
marked with ablack dot.

X error (m) - root mean square error for X coordinate for all the cameras.

Y error (m) - root mean square error for Y coordinate for al the cameras.

XY error (m) - root mean square error for X and Y coordinates for all the cameras.
Z error (m) - root mean square error for Z coordinate for al the cameras.

Total error (m) - root mean square error for X, Y, Z coordinates for all the cameras.
Total error = sgrt(Sumi=1" [(Xi, est - Xi,in)> + (Yi, est - Yi, in)* + (Zi, est - Zi,in)] / 1)
Xi. in - input value for X coordinate for i camera position,

Xi, est - €stimated value for X coordinate for i camera position,

Yi in- input value for Y coordinate for i camera position,

Yi, et - €stimated value for Y coordinate for i camera position,

Z; in - input value for Z coordinate for i camera position,

Z; o - estimated value for Z coordinate for i camera position,

Camera Orientations

Fig. Camera orientations and error estimates - shows camera orientations and error estimates. Arcs
represent yaw error estimates.

Yaw error (in degrees) - error for yaw.
Pitch error (in degrees) - error for pitch.
Roll error (in degrees) - error for roll.

Total error (in degrees) - root mean square error all angles.
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Ground Control and Check Points

Fig. GCP locations and error estimates - displays GCP locations and error estimates. Z error is
represented by elipse color. X,Y errors are represented by ellipse shape. Estimated GCP locations are
marked with a dot or crossing.

XY error (m) - root mean square error for X and Y coordinates for a GCP location / check point.
Z error (m) - error for Z coordinate for a GCP location / check point.

Error (m) - root mean square error for X, Y, Z coordinates for a GCP location / check point.
Proj ections - number of projections for a GCP location / check point over al the images.

Error (pix) - root mean sgquare error for X, Y coordinates on an image for a GCP location / check point
averaged over al theimages.

Total - root mean square error all the GCP locations / check points.

Scale Bars
Distance (m) - scale bar length estimated by Metashape.
Error (m) - difference between input and estimated values for scale bar length.

Total - root mean square error al the scale bars in Control/Check section.

Digital Elevation Model
Fig. Reconstructed digital elevation model - presenting digital elevation model.
Resolution - effective resolution of the exported DEM estimated for the source data.

Point Density - average number of point cloud points per square meter.

Processing Parameters

Processing report contains processing parameters information, which is also avail able from Chunk context
menu. Along with the values of the parameters used at various processing stages, this page of the report
presents information on processing time.

For projects calculated over network processing time will be displayed as a sum of the time spent for
processing by each node.

M etashape matches images on different scales to improve robustness with blurred or difficult to match
images. The accuracy of tie point projections depends on the scale at which they were located. Metashape
uses information about scale to weight tie point reprojection errors. Key point size is the Sigma of the
Gaussian blur at the pyramid level of scales at which the key point was found.

In the Reference pane settings dial og tie point accuracy parameter corresponds to the normalized accuracy
- i.e. accuracy of tie point projection detected at the scale equal to 1. Tie points detected on other scaleswill
have accuracy proportional to their scales. This helps to obtain more accurate bundle adjustment results.

On the processing parameters page of the report (as well asin chunk information dialog) two reprojection
errors are provided: the reprojection error in the units of key point scale (this is the quantity that is
minimized during bundle adjustment), and the reprojection error in pixels (for convenience). The Mean
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key point size value is averaged Key point size value over all key points. Average tie point multiplicity
value istheratio of the total number of projections to the number of tie points.

Camera track creation and fly through video
rendering

In Metashape you can create an overview video of the model along a certain trajectory. Cameratrack can
be created automatically (using simple preset options), imported from external file and edited manually.

Editing and creation of a track is carried out through the animation panel. To open the panel select
Animation command from the View menu.

To manually create a track and add a viewpoint, click Append button on the Animation pane. Append
option will add the current viewpoint to the active cameratrack.

To automatically create Horizontal track

1. Click Create button on the Animation pane toolbar.

2. Choose Horizontal preset parameter in Create Track dialog window and set the Keyframe count.
3. Click OK button.

4. Adjust the position of the viewpoint in the cameratrack in Model view by dragging the left mouse
button to display it visually.

To automatically create Vertical track

1. Click Create button on the Animation pane toolbar.

2. Choose Vertical preset parameter in Create Track dialog window and set the Keyframe count.
3. Click OK button.

4. Adjust the position of the viewpoint in the cameratrack in Model view by dragging the left mouse
button to display it visualy.

Horizontal and vertical track presets are basing on the bounding box - the colored side of the box istreated
as XY plane. The center of the bounding box defines the point of focus and the size of the bounding box
defines the rotation radius.

Use Resize Region and 3?: Rotate Region toolbar buttons to adjust the size and orientation of the
bounding box and then create a new horizontal or vertical animation track, once the orientation of the
bounding box fits your needs.

4 Note

« To display the camera track path, select Show animation command from the Show/Hide items
submenu on the Model menu.

Camera track parameters can be adjusted in the Animation Settings dialog window. The following
parameters can be changed: Camera Track Label, Duration (in seconds), Field of view (deg), Smooth
cameratrack option, Loop cameratrack option, Rotation angles convention. Click Settings button on the
Animation pane to open Animation Settings dial og.
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Torecord thevideo
To record the video according to the created camera track to the externa file:
1. Click on Capture button on the Animation pane toolbar.

2. Select the desired export parameters in the Capture Video dialog, such as export video resolution,
compression type and frame rate.

3. Tosavethetrack path to external file click Save button on the Animation pane.
M etashape supports camera track export in the following formats:

» CameraPath

« KML

. CSV
4 Note

» That KML format is only supported for projects georeferenced in geographic/projected systems
convertible to WGS84 system.

Stereoscopic mode

Metashape supports stereoscopic mode. In Metashape hardware stereo is supported only for systems
(graphics cards) that support the technology Quad Buffered Stereo.

Before starting to use stereo mode adjust the Stereoscopic Display modein the General tab of Preferences
dialog available from Tools menu. Metashape supports simply anaglyph display mode (for red/blue
glasses) aswell ashardware stereo mode that assumes polarization glassesand professional grade hardware
(GPU that supports quad-buffer stereo and 3D monitor). The parameters of the 3D controller can be
adjusted on the Navigation tab available in the Preferences dialog window.

For example, when using Stealth3DMouse controller, virtual com port should be installed before thistype
of controller could be selected on the Navigation tab available in the Preferences dialog window. If 3D
controller cannot be configured on the Navigation tab - the steps below should be executed:

» check the USB Serial Comport in the Ports section of Device manager dialog;

* open Port Settingstab of Propertiesdial og window, then click on Advanced tab. In the Advanced Settings
dialog switch the COM port number to COM3;

* restart the computer;

* in Metashape open Preferences dialog window from Tools menu and in the Navigation tab you should
be able to select COM 3 port then for the Stealth3DMous device.

Working with stereo pairsin Metashapeis performed in Model view pane with Top predefined view set up.
Setting up stereo mode

1. Align photos. More information about photo alignment refer to Aligning photos and laser scans
section.
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2. Switch to Model view pane.
3. Select Top command from Predefined Views submenu of Model menu.

4, Select Sereo mode view command from the View Mode submenu of the Model menu.

Turn on stereo pair overlay by clicking == Show Images toolbar button.

Navigation
1. Navigate through overlaying stereo pair with right mouse button pressed.

2. Tocontrol 3D cursor depth, navigate with the right mouse button and Shift key pressed. When using
the 3D controller, height change is performed with the help of a special whesl.

Stereo pair selection
1. Right button click on the area of interest on the model and select Filter by point command.

2. Inthe Photos pane select both images of a stereo pair, right click on the selection and choose Look
Through command.

3. To avoid switching between stereo pairs while navigating through model, lock current overlaying

stereo pair by clicking D Lock Image toolbar button.

4. Incaseyou need to select another stereo pair, repeat step two.
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Camera calibration

Calibration groups

While carrying out Align Photo procedure Metashape estimates both interior and exterior camera
orientation parameters, including nonlinear radial distortions. For the estimation to be successful it is
crucia to apply the estimation procedure separately to images taken with different cameras. Once images
have been |oaded in the program, M etashape automatically divides them into calibration groups according
to theimage resolution and/or EXIF metadata: cameratype and focal length. When using manual approach
described below it isimportant to follow the described steps for each calibration group individually.

Calibration groups can be rearranged manually.

To createanew calibration group

1. Select Camera Calibration... command from the Tools menu.

2. Inthe Camera Calibration dialog box, select images to be arranged in a new group.
3. Choose Create Group command from the selected images context menu.

4. A new group will be created and depicted on the | eft-hand part of the Camera Calibration dialog box.

To move images from one group to another
1. Select Camera Calibration... command from the Tools menu.
2. Choose the source group from the list on the left-hand part of the Camera Calibration dialog box.

3. Select images to be moved and drag them to the target group on the left-hand part of the Camera
Calibration dialog box.

To place each image into a separate group the Split Groups command can be used. The command is
available on the right button click on a calibration group name in the left-hand part of the Camera
Calibration dialog box.

Camera types

Metashape supports four major types of camera: frame camera, fisheye camera, spherical camera and
cylindrical camera. Additionally RPC camera type is available for satellite imagery that is accompanied
with the RPC metainformation. Cameratype can be set in Camera Calibration dialog box available from
Tools menu.

Frame camera. If the source data within a calibration group was shot with a frame camera, for successful
estimation of camera orientation parameters the information on approximate focal length (pix) isrequired.
Obviously, to calculate focal length valuein pixel it is enough to know focal length in mm along with the
sensor pixel sizein mm. Normally this datais extracted automatically from the EXI1F meta data.

Frame camerawith Fisheyelens. If extrawide lenses were used to get the source data, standard Metashape
cameramodel will not allow to estimate camera parameters successfully. Fisheye cameratype setting will
initialize implementation of a different camera model to fit ultra-wide lens distortions.
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Spherical camera (equirectangular projection). In case the source data within a calibration group was shot
with aspherical camera, cameratype setting will be enough for the program to cal cul ate cameraorientation
parameters. Only images in equirectangular representation are required with no additional information.

Spherical camera Cylindrical projection. In case the source data within a calibration group is a set of
panoramic images stitched according to cylindrical model, camera type setting will be enough for the
program to calculate camera orientation parameters. No additional information is required.

Satellite images with RPC. To automatically detect the camera type, select Preferences command from
Tools menu. Click Advanced tab and turn on the check box Load satellite RPC data from auxiliary TXT
files.

[{ Note

* When using the Full model for rolling shutter it is recommended to align images with the
Adaptive camera model fitting option.

In case source images lack EXIF data or the EXIF datais insufficient to calculate focal length in pixels,
M etashape will assume that focal length equalsto 50 mm (35 mm film equivalent). However, if theinitial
guess values differ significantly from the actual focal length, it islikely to lead to failure of the alignment
process. So, if images do not contain EXIF meta data, it is preferable to specify focal length (mm) and
sensor pixel size (mm) manually. It can be done in Camera Calibration dialog box available from Tools
menu. Generally, thisdataisindicated in cameraspecification or can be received from some online source.
To indicate to the program that the camera orientation parameters should be estimated based on the focal
length and pixel sizeinformation, it is necessary to set the Type parameter on the Initial tab to Auto value.

Camera calibration parameters

Photogrammetric calibration of camerasis performed to determine the values of the interior orientation of
the cameras, including the parameters of distortion of the cameralens. The camera calibration parameters
can be set manualy, if they have been acquired as part of the precalibration procedure.

To specify the camera calibration parameters
1. Select Camera Calibration... command from the Tools menu.

2. Select calibration group, that requires re-estimation of camera orientation parameters, on the |eft-
hand side of the Camera Calibration dialog box.

3. Inthe Camera Calibration dialog box, select Initial tab.

>

Modify the calibration parameters displayed on the Initial tab.

o

Set the Type to the Precalibrated value.

6. Repeat for every calibration group where applicable.
7. Click OK button to set the calibration.

The following calibration parameters are available:

f
Focal length measured in pixels.
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CX, cy
Principal point coordinates, i.e. coordinatesof lensoptical axisinterceptionwith sensor planein pixels.

b1, b2
Affinity and Skew (non-orthogonality) transformation coefficients.

k1, k2, k3, k4
Radial distortion coefficients.

pl, p2
Tangential distortion coefficients.

4 Note

 Alternatively, initia calibration data can be imported from file using Load button on the Initial
tab of the Camera Calibration dialog box. In addition to Agisoft cameracalibration fileformat it
ispossibletoimport datafrom Australis, PhotoModeler, 3DM CalibCam, CalCam, Inpho camera
calibration, USGS camera calibration, Pix4D camera calibration, OpenCV, Photomod and Z/I
Distortion Grid formats.

Initial calibration data will be adjusted during the Align Photos processing step. Once Align Photos
processing step is finished adjusted calibration data will be displayed on the Adjusted tab of the Camera
Calibration dialog box. Thedetailsabout distortion model sused in M etashapearegiveninthe Appendix D,
Camera models section.

If very precise calibration datais available and should be preserved during camera calibration procedure,
click Select... button next to Fixed parameters: item. In Fixed parameters dialog choose calibration
parameters that are to be fixed and click OK button. The initial values for the chosen parameters will not
be changed during Align Photos and Optimize Cameras operations.

In some cases it may be required to estimate a sub-set of parameters individually for each camerain the
calibration group. In this click Select button and choose these parameters in Image-variant parameters
dialog box.

Adjusted camera calibration data can be saved to file using Save button on the Adjusted tab of the Camera
Calibration dialog box.

Camera calibration for the scanned images with fiducial
marks

Cameracalibration for the scanned imagesis performed based on the fiducial marksinformation. Oncethe
datais uploaded al the scanned images from the same analog camera should be placed in the designated
calibration group. Metashape will automatically put the cameras to the same calibration group, providing
that they have been scanned to the images of the same resolution.

If the scanned images from different cameras have been uploaded to the same chunk, it is required to
divide them manually into different calibration groups. It could be done in Camera Calibration dialog
available from Tools menu. To move images to a designated calibration group manually select cameras
on the Camera Calibration dialog window and select Merge Groups command from the cameras context
menu.

Metashape supports the following transformation type for scanned images: Conformal, Affine and
Projective. The transformation type is configured in the Fiducials tab in the Camera calibration dialog
box. By default program uses Conformal transformation type.
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4 Note

» Fiducial tab available only for film cameras. It is important to enable the Film camera with
fiducial marks option in the Camera Calibration dialog box for all scanned images.

Conformal transformation is a linear fractional transformation (please note that is not an affine
transformation). Thus the generation of a special conformal transformation involves use of multiplicative
inversion, which is the generator of linear fractional transformations.

Affinetransformationisageometric transformation that preserveslinesand parallelism, but not necessarily
Euclidean distances and angles.

Projective transformation is the composition of a pair of perspective projections. Projective
transformations do not preserve sizes or angles but do preserve incidence and cross-ratio: two properties
which are important in projective geometry.

Metashape enables automatic detection of the majority of the fiducial marks types. See the illustration

below.
OD{2. .8 muan

Supported fiducial marks.

To calibrate scanned images with automatically detectable fiducial marks
1. Select Camera Calibration... command from the Tools menu.

2. Inthe Camera Calibration dialog box check Film camera with fiducial marks option.

3. Close Camera Calibration dialog with OK button.

4. Run Detect Fiducials... command from the Markers submenu from the Tools menu. Specify the type
of fiducia: Generic or Right angle in the Detect Fiducials dialog window. Use Generic type for
fiducial marks like circle with dot, dot, crosshair, and so on. If fiducial marks represent angles, then
select Right angle as detection type. For the Right angle type of fiducial marks important to specify
Fiducials position (Cornersand sides, Corners, Sdes), according to where fiducial marksarelocated
on the images. Enable Generate background masks option for automatic creation of the masks for
black fields on the scanned images.

5. IntheCamera Calibration dialog box print in coordinates of the automatically detected fiducial marks
on the image according to the analog camera certificate. They should be measured in coordinate
system associated with the sensor: origin - in the center of the sensor; axes X - to the right, axes Y
- downwards; in millimeters (mm).

6. Close Camera Calibration dialog with OK button and proceed to general Metashape processing
workflow starting from Align Photos... step. The software will automatically scale and orientate all
the photos according to the fiducial marks information.

In case your fiducial marks type is not among those supported for automatic detection (see Figure above),
please place a feature request with Agisoft support team: support@agisoft.com. The current version of

the software alows to perform calibration of the scanned images based on such fiducial marks manually
following the procedure outlined below.

To calibrate scanned images with non-standard fiducial marks manually

1. Select Camera Calibration... command from the Tools menu.
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2. Inthe Camera Calibration dialog box check Film camera with fiducial marks option.

3.  OntheFiducialstab add fiducial mark instances, the number should be equal to the amount of fiducial
marks used on the original photos.

4. Print in coordinates of the fiducial marks on the image according to the analog camera certificate.
They should be measured in coordinate system associated with the sensor: origin - in the center of
the sensor; axes X - to theright, axes Y - downwards; in millimeters (mm).

5. Close Camera Calibration dialog with OK button.

6. Thenitisnecessary to place al the fiducials on each photo from the calibration group.
7. Open the photo in Photo view.

8.  Zoominto afiducia mark center.

9. There are two ways to place a fiducial mark. Use Place Fiducial command from the context menu
or enable Place Fiducial button on the toolbar. In first case: choose a corresponding fiducial mark
instance from the dropdown list. In the second case, an intelligent placement of markerswill be used,
it is important to correctly place the first 2 markers on the image in order. Perform the placement
of the rest, then the program will prompt their location. After all 4 fiducials are placed Metashape
will switch the image to the next one automatically to continue measurement of fiducial marks on
the next image.

10. Incaseyou need to replace onefiducial mark with another right-click fiducial mark and use Replace
Fiducial command from its context menu. You will need to choose a corresponding fiducial mark
instance from the dropdown list.

11. After placing al the fiducia mark instances, you can proceed to genera Metashape processing
workflow. The software will automatically scale and orientate all the photos according to the fiducial
marks information.

4 Note

« If there is no camera certificate with fiducial marks coordinates information for the data set in
question, then it will be necessary to additionally run Calibrate Fiducials... command from the
context menu of the selected images in the Camera Calibration dialog box. All the images from
the respective calibration group should be selected for the purpose.

 Itisrecommended to mask out al the margins with auxiliary information on scanned photos to
avoid negative effect on the stability of the further processing.

Analyzing calibration results

M etashape provides a number of tools to analyze camera calibration results available from context menu
of acameragroup in the Camera Calibration dialog.

Distortion
Distortion tab presents estimated camera distortion plot. Total, Radial, Decentering, Corrections
and Residual options are available in the tab. Distortion graph represent the distortion values and
direction according to the adjusted calibration coefficients values. It shows the plot in the discrete
vectors mode for a central point in the corresponding image cell. Residual s presents residuals graph
which alows to evaluate how adequately the camera is described with the applied mathematical

90



Referencing

model. Notethat residual s are averaged per cell of animage and then acrossall theimagesin acamera
group. Scale reference under the plot indicates the scale of the distortions/residuals.

Profile
Profile tab presents increase of the corresponding radial and decentering distortions with distance
from the center of the image. Profiles can be saved asimage.

Correlation
Correlation tab presents:

» Adjusted values of the interior camera orientation parameters;
» Errors- standard deviation, read more in Covariance matrix section;

» Correlation values for interior camera orientation parameters - reflect the degree of correlation
between the corresponding parameters.

Vignetting
Vignetting tab presents radiometric distortion of the lens. Metashape uses radiometric distortion
parameters of the lens from photos meta data, in case there is no information about radiometric
distortion of the lens in photos meta data Vignetting tab is inactive. Radiometric distortion can be
calculated manually using Calibrate Colors command available from the Tools menu, read more in
Building model texture section.

Georeferencing

To set georeferenced coordinates system for aproject, it is necessary to use data on geographical reference
(ground control points (markers) coordinates and/or camera coordinates data). If there is no geographic
reference data, then the project will be created in the local coordinate system.

Initially Metashape expects both GCPs and camera coordinates data to be specified in the same coordinate
system and assigns it as the coordinate system of the chunk. In such a case all the outputs by default will
be referenced in this particular coordinate system.

If the GCPs and camera coordinates data is measured in different coordinate systems, Metashape alows
to input this data as is, provided that either all the coordinate systems are based on the same datum or
for all of them transformation-to-WGS84 parameters are specified in the coordinate system definition or
manually set in the datum transformation settings dialog.

Metashape supports a wide range of various geographic and projected coordinate systems, including
widely used WGS84 coordinate system. Besides, almost all coordinate systems from the EPSG registry
are supported as well.

Information about the coordinates of images or markers is usualy stored in a separate text file that is
imported into the project.

Methods to input coordinates data

Reference coordinates can be specified in one of the following ways:

» Loaded from a separate text file (using character separated values format). This method is suitable for
image coordinates and for markers.

 Entered manually in the Reference pane. This method is suitable for image coordinates and for markers.
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 Loaded from GPS EXIF tags (if present).

Toload reference coordinates from a text file

1 Click = Import toolbar button on the Reference pane. (To open Reference pane use Reference

command from the View menu.) Browse to the file containing recorded reference coordinates and
click Open button.

2. IntheImport CSV dialog set the coordinate system if the data presents geographical coordinates.
3. Select the delimiter and indicate the number of the data column for each coordinate.

4. Indicate columnsfor the orientation dataif present. Make sure that the proper angle triple (according
to the source data) is set: [yaw,pitch,roll], [omega, phi, kappa], [phi, omega, kappa] or [apha, nu,
kappa] .

5. Optionally, indicate accuracy values for coordinates and rotation angles.

6. Click OK button. The reference coordinates data will be loaded onto the Reference pane.

4 Note

« Information on the accuracy of the source coordinates (x, y, z) aswell as of the source orientation
angles can be loaded with a CSV file as well. Check Load Accuracy option and indicate the
number of the column where the accuracy for the data should be read from. It is possible to
indicate the same accuracy column for all three coordinates/angles.

Example of a reference coordinates file in CSV format (*.txt)

Thereference coordinates can beloaded onto the Reference pane using character separated text file format.
Each reference point isspecifiedin thisfile on aseparateline. Samplereference coordinatesfileisprovided
below:

# <l abel > <l ongitude> <l atitude> <hei ght> <yaw> <pitch> <roll >
| MG 01. JPG 40.165011 48.103654 433.54 15.54 0.39 0. 87
| MG _02. JPG 40. 165551 48.103654 434.72 15.73 0.38 1.21
| MG _03. JPG 40.166096 48.103640 435.63 15.67 0.24 1.04

Individual entries on each line should be separated with atab (space, semicolon, comma, etc) character.
All lines starting with # character are treated as comments.

Records from the coordinate file are matched to the corresponding cameras or markers basing on the
label field. Camera coordinates |abels should match the file name of the corresponding photo including
extension. Marker coordinates |abels should match the labels of the corresponding markersin the project

file. All labels are case insensitive.

M etashape can interpret degrees, minutes, seconds signsin aCSV file. An example entry:

| M300001. j pg, 19°39' 59. 99"E, 60° 20' 0. 05"N, 100. 073997
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Alternatively, a"colon" sign can be used as a delimiter:

| M300002. j pg, 19: 39: 59. 99E, 60: 20: 0. 05N, 100. 073997

[ Note

» Character separated format does not include information about coordinate system used. Relevant
coordinate system should be set in the Reference Settings dialog after loading the file with
coordinates data.

« Altitude value should indicate the height above the ellipsoid (or above geoid, if corresponding
compound coordinate system is selected in the Reference pane settings dialog), not the height
above mission start point, etc.

To assign reference coor dinates manually

L Switch to the View Source mode using E View Sour ce button from the Reference pane toolbar. (To

open Reference pane use Reference command from the View menu.)

2. Onthe Reference pane select x/y/z or angle data cells and press F2 button on the keyboard to assign
values to corresponding coordinates/angles.

3. Repeat for every marker/camera position (orientation angle) needed to be specified.

4. To remove unnecessary reference coordinates select corresponding items from the list and press Del
key.

Click F‘:[ﬂ Update toolbar button to apply changes and set coordinates.
4 Note

« Additiondly, it is possible to indicate accuracy data for the coordinates / orientation angles.
Select Set Accuracy... command from the context menu of an image on the Reference pane and
input accuracy data both for position (i.e. x,y,z coordinates) and orientation (i.e. [yaw, pitch,
roll], [omega, phi, kappa], [phi,omega,kappa] or [apha, nu, kappa] angles) data. It is possible
to select several cameras and apply Set Accuracy... command simultaneously to all of them.
Alternatively, you can select Accuracy (m) or Accuracy (deg) text box for a certain camera
on the Reference pane and press F2 button on the keyboard to type the text data directly onto
the Reference pane. Note that "/* delimiter allows to enter different accuracy data for x, y, z
or orientation angles ([yaw, pitch, roll], [omega, phi, kappa], [phi,omegakappa] or [apha, nu,
kappa]) data respectively.

Toload reference coordinates from GPS EXIF tags

Click E Import EXIF button on the Reference pane. (To open Reference pane use Reference
command from the View menu.) The reference coordinates data will be loaded into the Reference
pane.
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2. I the corresponding options in the Advanced tab o the Preferences window are checked on, it is
also possible to load camera orientation angles and |ocation/rotation accuracy parameters from XMP

extension of the image header. The data will be loaded upon clicking E Import EXIF button.

RTK/PPK camera coordinates data

If the source data includes RTK/PPK measurements, it is important to input accuracy values for all the
respective cameras onto the Reference pane. Otherwise default accuracy value (10 m) will be assumed for
all camera coordinates in the chunk, hence, the value of the RTK/PPK measurements will efficiently be
lost and the processing results will not be referenced with expected accuracy. In case the coordinates input
for the cameras are measured for the point where the measuring instrument is mounted (not the camera
itself) it is also necessary to input measurement instrument shift with respect to the cameraitself on GPY
INS Offset tab of Camera Calibration dialog available from Tools menu.

After reference coordinates have been assigned Metashape automatically estimates coordinatesin alocal
Euclidean system and calcul ates the referencing errors. To see the results switch to the View Estimated or

View Errors modes respectively using @ View Estimated and L_l_ View Errorstoolbar buttons.

GPS/INS Offset

Z cam
GPS

®

Ycam

Z offset

Yoffset

=/ > Xcam

X offset

GPS offset.

Rotation angles for the camera coordinates in M etashape are defined around the following axes. yaw axis
runs from top to bottom, pitch axis runs from left to right wing of the drone, roll axis runs from tail to nose
of the drone. Zero values of the rotation angle triple define the following camera position aboard: camera
looks down to the ground, frames are taken in landscape orientation, and horizontal axis of the frame is
perpendicular to the central (tail-nose) axis of the drone. If the camera is fixed in a different position,
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respective yaw, pitch, roll values should be input on GPS/INS Offset tab of Camera Calibration dialog.
The signs of the angles are defined according to the right-hand rule. See Figure below.

INS offset.

[ Note

e Step 5 can be safely skipped if you are using standard GPS system (not that of superhigh
precision).

In Select Coordinate Systemdiaog it is possible to ease searching for the required georeferencing system
using Filter option. Enter respective EPSG code (e.g. EPSG::4302) to filter the systems.

Ground control and check points

M etashape supports control and check points. Control points are used to reference the model. While check
points are used to validate accuracy of the camera alignment and optimization procedures results.

To load coordinates for control and check points

1 Click = Import toolbar button on the Reference pane. (To open Reference pane use Reference

command from the View menu.) Browse to the file containing control and check points coordinates
and click Open button.

2. IntheImport CSV dialog set the coordinate system if the data presents geographical coordinates.

3. Select the delimiter and indicate the number of the data column for each coordinate.

4. Optionally, indicate accuracy values for coordinates.
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5. Click OK button. The reference coordinates datawill be loaded onto the Reference pane on Markers
section.

How to specify control or check point types
1. Select marker on the Reference pane.

2. Ensurethat the selected marker has at least two projections placed on the aligned images. Y ou should
check pointsbox. If the check box isenabled, the point isthe control point. When check box isdisable,
the point is the check point.

3. Input control/check point coordinates information to the Source Values tab of the Reference pane.
4. Enable marker on the Reference pane to make it a control point or disable to useit as a check point.

5. Control and check point errors can be inspected on the Errors Values tab.

[{ Note

* After you change the point type click '_*','f! Update toolbar button from the Reference pane.

« After use the Update button, the 7th parametric transformation is performed.

Placing markers on the images

The position of markers is determined by their coordinates in the images. To determine the spacial
coordinatesof themarkers, it isnecessary to measure planar coordinates of themarkerson at |east 2 images.

M etashape supports two approaches to marker placement: manual marker placement and guided marker
placement. Manual approach implies that the marker projections should be indicated manually on each
image where the marker is visible. Incorrect projection markers affect accuracy. Be careful when placing
the markers on theimages, specify the exact position, and see that the markers are not obscured by foreign
objects (for example, grass or foliage). In such cases, it is better not to put a marker on such an image.
Manual marker placement does not require 3D model and can be performed even before image alignment.

In the guided approach marker projection is specified for a single image only. Metashape automatically
projects the corresponding ray onto the model surface and calculates marker projections on the rest of
the photos where marker is visible. Marker projections defined automatically on individual photos can be
further refined manually. Reconstructed 3D model surfaceis required for the guided approach.

Guided marker placement usually speeds up the procedure of marker placement significantly and also
reduces the chance of incorrect marker placement. It is recommended in most cases unless there are any
specific reasons preventing this operation.

To place amarker using guided approach
1. Open animage where the marker is visible by double clicking on its name.

2 Switch to the marker editing mode using ”:L? Show Markerstoolbar button.

3. Right click on the image at the point corresponding to the marker location.

4. Select Add Marker command from the context menu. New marker will be created and its projections
on the other photos will be automatically defined.
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4 Note

« If the 3D model is not available or the ray at the selected point does not intersect with the model
surface, the marker projection will be defined on the current image only.

 Guided marker placement can be performed in the same way from the 3D view by right clicking

on the corresponding point on the model surface and using ﬂ% Create Marker command fromthe
context menu. While the accuracy of marker placement in the 3D view isusually much lower, it
may be still useful for quickly locating the photos observing the specified location on the model.

To view the corresponding photos use "% Filter Photos by Markers command again from the
3D view context menu. If the command isinactive, please make sure that the marker in question
is selected on the Reference pane.

If the circle under the flag is @ red in the Model view, the marker is selected. If © yellow -
the marker is not selected.

Markers are shown as } white flagsin Model view. If the position of a marker for each image

is specified, the flag bet:om%ll'—‘rJ green.

To place amarker using manual approach

1 Create marker instance using "%Add marker button on the Workspace pane or by Add Marker

command from the Chunk context menu.

2. Opentheimagewherethe marker projection needsto be added by double clicking on the photos name.

Switch to the marker editing mode using ”Q? Show Markers toolbar button.

4. Right click at the point on theimage where the marker projection needsto be placed. From the context
menu open Place Marker submenu and select the marker instance previoudly created. The marker
projection will be added to the current image.

5. Repeat the previous step to place marker projections on other photos if needed.

To save up time on manua marker placement procedure Metashape offers guiding lines feature. When
amarker is placed on an aligned image, Metashape highlights lines, which the marker is expected to lie
on, on the rest of the aligned photos.

4 Note

« If a marker has been placed on at least two aligned images Metashape will find the marker

projections on the rest of the photos. The calculated marker positions will be indicated with j‘
icon on the corresponding aligned photos in Photo view mode.

Automatically defined marker locations can be later refined manually by dragging their projections on the
corresponding photos.

The commands Unpin marker and Block marker are available from the context menu of the marker on
the image. To reset the updated marker position, select Unpin marker command, the marker will display
as a blue flag. If Blocks marker option is selected, then the marker projection on particular image will
not be displayed.
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Torefine marker location

1. Open the image where the marker is visible by double clicking on the image's name. Automatically

placed marker will be indicated with ":t?i con.

Switch to the marker editing mode using ”:t? Edit Markerstoolbar button.

3. Movethe marker projection to the desired location by dragging it using left mouse button. Once the

marker location is refined by user, the marker icon will changeto ”‘—‘D
4 Note

* To list photos where the marker locations are defined, select the corresponding marker on the
Workspace pane. The photos where the marker is placed will be marked with al]l? icon on the

Photos pane. To filter photos by marker use "ﬁ Filter by Markers command from the 3D view
context menu.

In those cases when there are hesitati ons about the features depicted on theimage, comparative inspection
of two photos can prove to be useful. To open two photos in Metashape window simultaneously Move to
Other Tab Group command is available from Photo tab header context menu.

M etashape supports automatic marker projection refinement based on the image content. Choose Refine
Markers command from the Markers submenu of the Tools menu.

To open two images simultaneously

1. Inthe Photos pane double click on one image to be opened. The image will be opened in anew tab
of the main program window.

2. Right click on the tab header and choose Move to Other Tab Group command from the context menu.
The main program window will be divided into two parts and the image will be moved to the second
part.

3.  Thenext image will be opened with a double click will be visualized in the active tab group.

M etashape automatically assignsdefault |abelsfor each newly created marker. Theselabel s can be changed
using the Rename... command from the marker context menu in the Workspace / Reference pane.

Working with coded and non-coded targets

Coded and non-coded targets are specially prepared, yet quite simple, real world markers that can add
up to successful 3D model reconstruction of a scene. Targets are artificial markers placed in the scene to
provide manual image correspondencesin case automatic matching fails. Coded and non-coded targets can
mark object point to be used for georeferencing. In the figure of coded targets their identifier is recorded,
which allowsto automatically and accurately comparetheir projectionson different images. The difference
between coded and non-coded targets is that while a non-coded target looks like an ordinary full circle
or afigure (circle / rectangular) with 4 segments, the coded target has a ring parted in black and white
segments around the central full circle.

Coded targets advantages and limitations

Coded targets (CTs) can be used as markers to define coordinate system and scale of the model or as
true matches to improve alignment procedure. M etashape functionality includes automatic detection and
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matching of CTson sourceimages, which allowsto benefit from marker implementation in aproject while
saving time on manual marker placement. Moreover, automatic CTs detection and marker placement is
more precise then manual marker placement.

Metashape supports four types of circle CTs: 12 bit, 14 bit, 16 bit and 20 bit. While 12 bit pattern is
considered to be decoded more precisely, 14 bit, 16 bit and 20 bit patterns allow for a greater number of
CTsto be used within the same project.

To be detected successfully CTs must take up a significant number of pixels on the source images. This
leadsto anatural limitation of CTsimplementation: while they generally proveto be useful in close-range
imagery projects, aerial photography projects will demand too huge CTsto be placed on the ground, for
the CTs to be detected correctly. Hence, for aerial photography projects it makes sense to consider hon-
coded targets implementation.

Coded targets in workflow

CTs supported by Metashape can be generated by the program itself.

To createa printable PDF with coded targets

1. Select Print Markers... command from the Tools menu.

2. Specify the CTstype and desired print parametersin Print Markers dialog.
3. Click OK.

Once generated, the pattern set can be printed and the CTs can be placed across the scene to be shot and
reconstructed.

When the images with CTs seen on them are loaded to the program, Metashape can detect and match the
CTsautomatically.

To detect coded targets on sour ce images

1. Select Detect Markers... command from the Tools menu.

2. Specify parameters of detector in Detect Markers dialog according to the CTstype.

3. Click OK.

Metashape will detect and match CTs and add corresponding markers to the Reference pane.

CTs generated with Metashape software contain even number of sectors. However, previous versions of
M etashape software had no restriction of thiskind. Thus, if the project to be processed contains CTs from
previousversions of M etashape software, it isrequired to disable parity check in order to make the detector
work.

Non-coded targets implementation

Non-coded targets can al so be automatically detected by M etashape (see Detect Markersdialog). However,
for non-coded targets to be matched automatically, it is necessary to run align photos procedure first.

4 Note

< Non-coded target detection operation should be started only after the camera alignment is
completed, asthe processistrying to match detected target projections between multiple photos.
Non-coded target detection wouldn't work on not aligned cameras.
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Non-coded targets

Non-coded targets are more appropriate for aerial surveying projects due to the simplicity of the pattern
to be printed on alarge scale.

To detect non-coded tar gets on images

1
2.

3.

Select Detect Markers... command from the Tools menu.

Specify parameters (Marker type, Tolerance, Maximumresidual (pix)) of detector in Detect Markers
dialog. For a non-coded target select the appropriate target type in the Marker type section from the
available options: Cross (non coded) and Circle (non coded). Tolerance parameter doesn't correspond
to the size of the target, but rather defines the tolerance of the projection detection. Set the value
corresponding the maximum difference of the target on oblique images from the ideal target pattern.
Maximum residual (pix) parameter indicates how large the residual value of the detected center is.

Click OK.

When non-coded targets are detected M etashape all ows automatic matching of detected non-coded targets
with referencing coordinatesimported from file. When importing referencing coordinates check thel gnore
labelsbox inthelmport CSV dialog. M etashapewill try to match all markersfor which 3D coordinates have
been estimated during image alignment (not only non-coded target markers) with imported referencing
coordinates. If automatic marching fails, manual re-naming of non-coded target markers is required in
accordance with CSV file information.

Coordinate system

In Metashape allows to set the coordinate system for the chunk. It may differ from the coordinate system
that cameras and/or markers use.

Setting coordinate system for chunk

1

Click ‘@& Settings button on the Reference pane toolbar.

In the Reference Settings dialog box select the Coordinate System for chunk - in the very first
dropdown menu list.

If necessary, it is possible to set individual coordinate system for cameras and markers in the
Reference pane settings dialog by checking the corresponding option and selecting proper coordinate
systems.

Specify the assumed measurement accuracy in the left-hand side part of the dialog.

If the information about GPS system shift with respect to the camera itself is available, it is worth
inputting it on GPS/INS Offset tab of Camera Calibration dialog available from Tools menu. See
GPS offset, INS offset images.

Specify the assumed image coordinates accuracy in the corresponding column of the dialog.

Specify Capture distance parameters for the datasets where the images are captured with the oblique
camera mount (more than 20-30 degrees from the vertical).

100



Referencing

8. Click OK button to initialize the coordinate system and estimate geographic coordinates.

4 Note

* When the coordinate information for the camera locations is present in the Source values tab
of the Reference pane and the Capture Distance parameter is not defined, the Reference Pair
Preselectionwill consider only XY Z coordinatesfor preliminary identification of the overlapping
image pairs. For each camera the certain number of closest neighbors will be selected for the
image matching operation.

« When the Capture Distance parameter is input and camera orientation angles (yaw, pitch, roll
or omega, phi, kappa) are present along with the XY Z camera locations in the Reference pane,
then for the neighbors estimation the following points are considered: from the original camera
locations the vector is sent according to the orientation angles, the length of the vector is equal
to the Capture Distance parameter values. So for each camerathe new 3D location is calculated
(X"'Y'Z") and these new poaints are used for the neighbors estimation.

« |If camera orientation angles are not loaded to the Source values tab or Reference preselection is
not enabled in the Align Photos dial og, the Capture Distance parameter will be ignored.

Coordinate system editor

If the target coordinate system is not on the list, it is possible to set its parameters manually. In Select

Coordinate Systemdia og choose any coordinate systemand click « 4 Edit button. (Obviously, itisoptimal
to select a coordinate system which parameters are the most similar onesto the target coordinate system.)
Enter the proper name for the system to be shown on the list and edit al the parameters according to the
coordinate system definition.

Configurable datum transformation

If the project coordinate system should be converted to WGS84, Datum Transformation Settings dialog

isamed at controlling proper parameters for the conversion. The dialog can be accessed via @8 Setti ngs
button next to Coordinate System selection field in the Reference Settings dial og.

Using different vertical datums

By default Metashape requires al the source atitude values for both cameras and markers to be input as
values measured above the ellipsoid. However, M etashape allowsfor the different geoid model s utilization
as well. Metashape installation package includes only EGM96 geoid model, but additional geoid models
can be downloaded from Agisoft's website if they are required by the coordinate system selected in the
Reference pane settings dialog. Downloaded geoid model from the supported list should be copied to
\geoids\ folder in Metashape install ation directory before using the corresponding coordinate system from
GULI.

Please refer to the following web-page to review the list of supported geoid models: http:/
www.agisoft.com/downl oads/geoids/.

Additional features of the Reference pane

To view the estimated geographic coordinates, reference errors and variance switch between the View
Estimated, View Errorsand View V ariance modes respectively using @ View Estimated, L_l_ View Errors

and El View Variance toolbar buttons. A click on the column name on the Reference pane sorts the
markers and cameras by the datain the column. At this point you can review the errors and decide whether
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additional refinement of marker locations is required (in case of marker based referencing), or if certain
reference points should be excluded.

To save the errors and/or estimated coordinates use =2l Export toolbar button on the Reference pane.

To reset a chunk georeferencing, use Reset Transform command from the chunk context menu on the
Workspace pane. [R] indicator of a chunk being georeferenced will be removed from the chunk's name
on the Workspace pane.

4 Note

» Unchecked reference points on the Reference pane are not used for georeferencing and
optimization. Use context menu to check/uncheck selected items. See Ground control and check
points section.

« After adjusting marker locations on the images, the coordinate system will not be updated

automatically. It should be updated manually using 'Tﬂ Update toolbar button on the Reference
pane.

» Metashape allowsto convert coordinates data between different coordinate systems. To calculate

the coordinates of the camera positions and/or markersin a different coordinate system use |
Convert toolbar button on the Reference pane.

Optimization

Optimization of camera alignment

Optimize Cameras command performs a full bundle adjustment procedure on the aligned
photogrammetric block, simultaneously refining exterior and interior camera orientation parameters and
triangulated tie point coordinates. The adjustment is performed based on all available measurements and
corresponding accuracies, i.e. coordinates of projections of tie points and markers on images in image
coordinate system; GPS coordinates of camera positions; GCP coordinates; scale bar distances.

4 Note

 If markers are used for the optimization process, it is recommended to distribute the control
points evenly over the survey object. It is also necessary that the markers are not located on one
straight line.

To ensure maximum geometric accuracy of processing results, it isimportant to always run optimization
procedure after adding/editing measured values and/or their accuracies, e.g. loading GPS camera
coordinates, adding GCPs, changing accuracy settings.

4 Note

« By default optimization adjusts both exterior and interior camera orientation parameters. When
working with a precalibrated camera, it is possible to load available calibration in the Camera
Calibration dialog and set the parameters asfixed. Fixed parameters will not be adjusted during
optimization step.

To optimize camera alignment

1. Setthe marker and/or camera coordinates to be used for optimization (if not done yet).
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Click &% Setti ngstoolbar button on the Reference pane and set the coordinate system (if not doneyet).

3. Inthe Reference Settings dialog box specify the assumed accuracy of measured values aswell asthe
assumed accuracy of marker projections on the source images.

4. Click OK button.

5. Indicaterelative GPS device and/or INSto cameracoordinates (if infoisavailable) on GPSINSOffset
tab of Camera Calibration dialog available from Tools menu.

6. Check Adjust GPS/INS offset box.
7. Click OK button.

Click & Optimize toolbar button on the Reference pane.
9. In Optimize Camera Alignment dialog box check additional camera parameters to be optimized.

10. Click OK button to start optimization.
{  Note

« Step 5 can be safely skipped if you are using standard GPS (not that of extremely high precision).

« Using RTK / PPK camera coordinates datawill also provide more accurate results. More details
about using RTK / PPK data can be found in Coordinate system section.

» The optimization procedure discards active depth maps, point cloud and mesh model from the
chunk. It is recommended to rebuild these objects after performing the optimization.

» The optimization process can improve the results of alignment and reduce the errors.

Optimize Camera Alignment parameters

Optimize Camera Alignment

General
Fit f Fit cx, cy
Fitki Fitpl
Fit k2 Fit p2
Fit k3 Fit b1
Fit k4 Fitb2
Advanced

Adaptive camera model fitting
Estimate tie point covariance

Fit additional corrections

Lok ] Cancel
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"Optimize Camera Alignment" dialog window

Fit additional corrections
With this option enabled Metashape estimates additional coefficients that are necessary to achieve
better accuracy. There are different corrections that allow to compensate the distortions that cannot
be described by the Brown's model (see Appendix D, Camera models section). This option may be
helpful for the datasets acquired drone with RTK/PPK, when no GCPs are used.

Adaptive camera model fitting
This option enables automatic selection of camerainterior orientation parametersto be adjusted. Read
more about in Aligning photos and laser scans section.

Estimatetie point covariance
The function allows to estimate the covariance values of the tie points.

Image coordinates accuracy for markersindicates either how precisely the markerswere placed by the user
or how precisely the markers were adjusted by the user after being automatically placed by the program.

Capture distance parameter is used to make reference preselection mode of alignment procedure work
effectively for oblique imagery. See Aligning photos and laser scans for details.

Camera, marker and scale bar accuracy can be set per item (i.d. per camera/marker/scale bar) using
Accuracy column on the Reference pane. Accuracy values can be typed in on the pane per item or for a
group of selected items. Alternatively accuracy values can be uploaded along with camera/marker data as
atext file (see Assigning reference coordinates subsection of Coordinate system). Additionally different
accuracy per coordinate can be indicated using "/" as a separator between values in the Accuracy column.

GPS/INS offset values specified by the user can aso be adjusted by Metashape with respect to
measurement accuracy that may be indicated on the GPSINStab of Camera Calibration dialog. Uncheck
Adjust GPSINS offset box to alow for adjustment procedure.

Generally it is reasonable to run optimization procedure based on the markers data only. The coordinates
of GCPs are measured with significantly higher accuracy compared to GPS coordinates of the camera
positions. Thus using the markers data gives more precise optimization results. It is also quite often that
GCPs and camera coordinates are measured in different coordinate systems, thus using both cameras and
markers data in optimization simultaneously is not possible.

The results of the optimization procedure can be evaluated with the help of error information on the
Reference pane. In addition, distortion plot can be inspected along with mean residuals visualized per
calibration group. This data is available in the Camera Calibration dialog (accessible form Tools menu)
from the context menu of acameragroup - Distortion Plot... command. Notethat residual s are averaged per
cell of an image and then across all theimagesin acamera group. Scale reference under the plot indicates
the scale of the distortions/residuals. Read morein What do the errorsin the Reference pane mean? section.

In case the optimization results are not satisfying, they can be recalculated with lower values of accuracy
parameters, i.e. assuming ground control measurements to be more accurate.

Covariance matrix

If additional analysesis required, extra option Estimate tie point covariance can be selected on running
the Optimization procedure. As a result, Metashape will calculate covariance matrix for the bundle
adjustment calculations. Covariance matrix captures the uncertainty of the transformation. Covariance
matrix diagonal elements are variances, o'iiz; the positive square root of the variance, 4, is caled the
standard deviation. Standard deviation values for the camera position coordinates and rotation angles can
be inspected on the Reference pane - View Variance tab. Covariance matrix off-diagonal elements are
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covariances, 4ij. Thevalue of each covariance reflectsthe degree of correlation between the corresponding
parameters. Calculated covariance valuesfor the tie points can beinspected in the Model view using Point
Cloud Covariance command available from View Mode submenu of Model menu. Vector associated with
each tie point indicates the direction and value of the largest error for thetie point estimated position (large
semi-axis of the error ellipsoid determined by the covariance values). The color code is aimed to help to
perceive the general distribution of the errors across the tie point cloud at a glance.

Scale bar based optimization

Scale bar is the representation of any known distance within the scene. The known distance can be a
standard ruler or a specially prepared bar of a known length. The scale bar is a handy tool to apply
additional reference data to the project. The scale bars can prove to be useful when there is no way to
place ground control points all over the scene. The scale bars also allow to save field work time, sinceit is
significantly easier to place several scale bars with precisely known length, than to measure coordinates
of multiple markers using special equipment. In addition, Metashape allows to use the distance between
camerapositions as ascale bar (mostly for rigged camera systemsin controlled environment), thus making
it possible to avoid marker and/or ruler placement within the scene. Surely, scale bar based information
will not be enough to set a coordinate system, however, the information can be successfully used while
optimizing the results of image alignment. It will also be enough to perform measurements in Metashape
software. See Performing measurements on 3D model.

To add a scale bar between markers

1. Placemarkersat the start and end points of the future scale bar. For information on marker placement
please refer to the Coordinate system section of the manual.

2. Select both markers on the Reference pane using Ctrl button.

Select E& Create Scale Bar command form the Model view context menu. The scale bar will be
created and added instantly to the Scale Bar list on the Reference pane.

Switch to the E View Source mode using the Reference pane toolbar button.

5. Double click on the Distance (m) box next to the newly created scale bar name and enter the known
length of the bar in meters.

To add a scale bar between camer as

1. Select the two cameras on the Workspace or Reference pane using Ctrl button. Alternatively, the
cameras can be selected in the Model view window using selecting tools from the toolbar.

Select B2 Create Scale Bar command form the context menu. The scale bar will be created and added
instantly to the Scale Bar list on the Reference pane.

Switch to the E View Source mode using the Reference pane toolbar button.

4. Doubleclick on the Distance (m) box next to the newly created scale bar name and enter the known
length of the bar in meters.

Torun scale bar based optimization

1. Onthe Reference pane check all scale barsto be used in the optimization procedure.
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Click ‘@& Settings toolbar button on the Reference pane. In the Reference Settings dialog box specify
the assumed accuracy of measured scale bar lengths.

3. Click OK button.

Click # Optimize toolbar button. In the Optimize Camera Alignment dialog box check additional
camera parameters to be optimized if needed. Click OK button to start optimization.

After the optimization is complete, the estimated coordinates of the cameras and markers will be updated
aswell asall the georeferencing errors. To analyze optimization results switch to the View Estimated mode
using the Reference pane toolbar button. The estimated scale bar distance will be displayed in the scale
bar section of the Reference pane.

Todeletea scale bar
1. Select the scale bar to be deleted on the Reference pane.
2. Right-click on it and chose Remove Scale Bars command from the context menu.

3. Click OK for the selected scale bar to be deleted.

What do the errors in the Reference pane
mean?

To analyze errors switch to the View Errors mode using the corresponding button on the Reference pane.

Camer as section

1. Error (m) - residual per coordinate or in 3D space. That is distance between the input (source) and
estimated positions of the camera.

2. Error (deg) - residual per orientation angle or in 3D space (that is root mean sgquare error calculated
over al three orientation angles).

3. Error (pix) - root mean square for reprojection errors for each valid tie point detected on the image.

4. Fid. error (pix) - root mean square for reprojection errors for al valid fiducial mark detected on the
image.

5. Totd error - root mean square for al the values in the corresponding column.
Reprojection error is the distance between the point on the image where a reconstructed 3D point can be

projected to and the original projection of the 3D point detected on the image and used as a basis for the
3D point reconstruction procedure.

M arkers section

1. Error (m) - residual per coordinate or in 3D space. That is distance between the input (source) and
estimated positions of the marker.

2. Error (pix) - root mean square for the reprojection error for the marker calculated over al images
where marker projection is placed.
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3. Total error (Control pointsand Check points) - root mean squarefor all thevaluesinthe corresponding
column.

If the total reprojection error for some marker seems to be too large, it is recommended to inspect
reprojection errors for the marker on individual images. The information is available with Show Info
command in the marker context menu on the Reference pane.

In Metashape the estimated check point coordinates, that are displayed (as well as the error values) on
the Reference pane, are calculated based on minimization of the reprojection error only, without taking
into account measured check point coordinates in 3D-space. Thus the displayed values do not correspond
the adjusted coordinates from the bundle adjustment step, and are cal culated solely from weighted image
measurements.

On the other hand, estimated coordinates of the control points correspond to the adjusted values, as they
are calculated taking into account both reprojection error and measured object space coordinates. This
approach allows for better detection of the measurement errors.

To observer the difference between measured (source) and triangulated (estimated) control point
coordinates only, temporary uncheck the corresponding entry on the Reference pane (thus making it a
check point) and observe the values on the Errors tab. Note that Update button shouldn't be pressed after
conversion of a control point to acheck point, otherwise the estimated values would be recal culated with
the given reference point excluded from the computation.

Scale Bar s section

1. Error (M) - residua for the distance, it equals the difference between the input (source) scale bar
length and the measured distance between two cameras or markers representing start and end points
of the scale bar.

2. Total error (Control scale bars and Check scale bars) - root mean square for all the values in the
corresponding column.
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Performing measurements on 3D model

M etashape supports measuring of distances on the model, as well as of surface area and volume of the
reconstructed 3D model. All theinstructions of this section are applicable for working in the Model view of
the program window, both for analysis of Point Cloud or of Mesh data. When working in the Model view,
all measurements are performed in 3D space, unlike measurements in Ortho view, which are planar ones.

Distance measurement

Metashape enables measurements of distances between the points of the reconstructed 3D scene.
Obviously, model coordinate system must be initialized before the distance measurements can be
performed. Alternatively, the model can be scaled based on known distance (scale bar) information to
become suitable for measurements. For instructions on setting coordinate system please refer to the
Coordinate system section of the manual. Scale bar concept is described in the Optimization section.

To measuredistance

L Select & Ruler instrument from the Toolbar of the Model view.

2. Click on the point of the model where the measurement should be started from.

3. Upon the second click on the model the distance between the indicated points will be shown right
in the Model view.

4. Thedistance can be measured along the polyline drawn with the Ruler.

5. To complete the measurement and to proceed to a new one, please press Escape button on the
keyboard. The result of the measurement will be shown on the Console pane

Shape drawing is enabled in Model view as well. See Shapes section of the manual for information on
shape drawing. Measure command avail able from the context menu of a selected shape allowsto learn the
coordinates of the vertices aswell as the perimeter of the shape.

To measure several distances between pairs of points and automatically keep the resulting data, markers
can be used.

To measur e distance between two markers

1. Placethe markersin the scene at the targeted locations. For information on marker placement please
refer to the Coordinate system section of the manual.

2. Select both markers to be used for distance measurements on the Reference pane using Ctrl button.

Select Ef Create Scale Bar command form the 3D view context menu. The scale bar will be created
and an instant added to the Scale Bar list on the Reference pane.

Switch to the estimated values mode using @ View Estimated button from the Reference pane
toolbar.
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5.

The estimated distance for the newly created scale bar equals to the distance that should have been
measured.

To measur e distance between camer as

1. Select the two cameras on the Workspace or Reference pane using Ctrl button. Alternatively, the
cameras can be selected in the Model view window using selecting tools from the Toolbar.

2 Select B2 Create Scale Bar command form the context menu. The scale bar will be created and an
instant added to the Scale Bar list on the Reference pane.

3 Switch to the estimated values mode using @ View Estimated button from the Reference pane
toolbar.

4. The estimated distance for the newly created scale bar equals to the distance that should have been
measured.

4 Note

» Pleasenotethat the scalebar used for distance measurements must be unchecked on the Reference
pane.

» The distance values measured by Metashape are displayed in meters.

Shape-based measurements

Polyline and Polygon measur ements

1

Indicate aline to make a cut of the model usi ng’c\ Draw Polyline "/ Draw Polygon tool from the
Model view.

Double click on the last point to indicate the end of a polyline.
Right button click on the polyline/polygon and select Measure... command from the context menu.

Inthe Measure Shape dial og window the coordinates of the vertexes, perimeter and coordinate system
are displayed.

Point measur ement

1.

2.

3.

Select **" Draw Point from the Toolbar of the Model view and draw a point on the model.
Right button click on the point and select Measure... command from the context menu.

Inthe Measure Shape dialog window the coordinates of the point and coordinate system are displayed.

Surface area and volume measurement

Surface area or volume measurements of the reconstructed 3D model can be performed only after the scale
or coordinate system of the scene is defined. For instructions on setting coordinate system please refer to
the Coordinate system section of the manual.
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To measure surface area and volume
1. Select Measure Area and Volume... command from the Tools menu.

2. Thewhole model surface areaand volume will be displayed in the Measure Area and Volume dialog
box. Surface area is measured in square meters, while mesh volume is measured in cubic meters.

V olume measurement can be performed only for the models with closed geometry. If there are any holes
in the model surface Metashape will report zero volume. Existing holes in the mesh surface can be filled
in before performing volume measurements using Close Holes... command from the Tools menu.

Performing measurements on DEM

Metashape is capable of DEM-based point, distance, area, and volume measurements as well as of
generating cross-sections for a part of the scene selected by the user. Additionally, contour lines can be
calculated for the model and depicted either over DEM or Orthomosaic in Ortho view within Metashape
environment. Measurements on the DEM are controlled with shapes: points, polylines and polygons. For
information about how to create and work with shapes please refer to Shapes section of the manual.

Point measurement

Ortho view alows to measure coordinates of any point on the reconstructed model. X and Y coordinates
of the point indicated with the cursor as well as height of the point above the vertical datum selected by
the user are shown in the bottom right corner of the Ortho view.

Distance measurement

To measuredistance with a Ruler

L Select & Ruler instrument from the Toolbar of the Ortho view.

2. Click on the point of the DEM where the measurement should be started from.

3. Upon the second click on the DEM the distance between the indicated points will be shown right
in the Ortho view.

4. Thedistance can be measured along the polyline drawn with the Ruler.

5.  To complete the measurement and to proceed to a new one, please press Escape button on the
keyboard. The result of the measurement will be shown on the Console pane.

To measur e distance with shapes

1 Connect the points of interest with a polyline using A Draw Polyline tool from the Ortho view

toolbar.
2. Double click on the last point to indicate the end of a polyline.
3. Right button click on the polyline and select Measure... command from the context menu.

4. Inthe Measure Shape dialog inspect the results. Perimeter value equals to the distance that should
have been measured.
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In addition to polyline length val ue (see perimeter value in the Measure Shape), coordinates of the vertices
of the polyline are shown on the Planar tab of the Measure Shape dialog.

4 Note

« Measure option is available from the context menu of a selected polyline. To select a polyline,
click on it by the left mouse button. A selected polylineiscolored in red.

Area and volume measurement

To measure area and volume

1 Draw apolygon on the DEM using _/Draw Polygon instrument to indicate the areato be measured.

2. Right button click on the polygon and select Measure... command from the context menu.

3. Inthe Measure Shape dialog inspect the results: see area value on the Planar tab and volume values
on the Volume tab.

M etashape allows to measure volume above best fit / mean level / custom level planes. Best fit and mean
level planes are calculated based on the drawn polygon vertices. Volume measured against custom level
plane allows to trace volume changes for the same area in the course of time.

[ Note

* Measure option is available from the context menu of a selected polygon. To select a polygon,
click on it by the left mouse button. A selected polygon is colored in red.

Cross sections and contour lines

Metashape enables to calculate cross sections, using shapes to indicate the plane(s) for a cut(s), the cut
being made with aplane parallel to Z axis. For apolyline/polygon the program will calculate profilesalong
all the edges starting from the first drawn side.

To calculate cross section

1. : . A e
Indicate a line to make a cut of the model using Draw Polyline / ' Draw Polygon tool from
the Ortho view toolbar.

2. Double click on the last point to indicate the end of a polyline.

3. Right button click on the polyline/polygon and select Measure... command from the context menu.

4. Inthe Measure Shape dialog inspect the results on the Profile tab of the dialog.

Generate Contours... command is available either from DEM label context menu on the Wor kspace pane
or from the Tools menu.

To generate contours
1. Select Generate Contours... command from Tools menu.

2. Inthe Generate Contours dialog select DEM as the source data for calculation.
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3. Setvauesfor Minimal altitude, Maximal altitude parameters as well as the Interval for the contours.
All the values should be indicated in meters.

4. Click OK button once done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

6. When the procedure is finished, a shape layer with "contours" label will be added to the project file
structure shown on the Workspace pane.

Contour lines can be exported using Export Contours command from the contour lines label context menu
on the Wor kspace pane. Alternatively the command is available from the File menu. In the Export Contour
Linesdialogit is necessary to select the type of the contour lines to be exported. A shape file can store the
lines of the same type only: either polygons or polylines.

Transform DEM

M etashape supports transformation of the digital elevation models. Different DEMs can be subtracted one
from another for the changes observation purposes.

Transform DEM

Coordinate System

WGE5 84 (EP5G::4326)

Farameters

Calculate difference

DEM2

Region

Setup boundaries; £,533043 - | £5.551036 ¥
46.562140 | - 46578330 | Y
Resaolution {m/pix): 0,16528
Total size (pix): 3345 x 10833

Lok ]
"Transform DEM" dialog
Totransform DEM
1. Select DEM from which you want to transform on the Wor kspace pane.
2.  Select Transform DEM... command from Tools menu.

3. Inthe Transform DEM... dialog select the check Calculation difference box and select the file from
the drop-down list for calculation.

4. Press OK button to calculate transform DEM.
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5. Inthedialog box click Yes button in order to create a new DEM instance with the calculation resullt.
If No button in pressed, the result will overwrite the active DEM instance contents.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

7. When the procedure is finished, a layer with transform DEM label will be added to the project file
structure shown on the Workspace pane.

Vegetation indices calculation

The vegetation index is used to analyze vegetation cover and is calculated as a result of operations with
different spectral channels. There are many vegetation indicesfor example such as: Normalized Difference
Vegetation Index (NDV1), Enhanced Vegetation Index (EVI), Green Normalized Difference Vegetation
Index (GNDVI) and so on.

Multispectral cameras

M etashape enables to calculate NDVI and other vegetation indices based on the multispectral imagery
input. Vegetation index formula can be set by the user, thus allowing for great flexibility in data analysis.
Calculated data can be exported asagrid of floating point index values cal culated per pixel of orthomosaic
or as an orthomosaic in pseudocolors according to a palette set by the user. In case several indices
are calculated for the same orthomosaic, the results can be exported as a multichannel orthomosaic,
one channel per index. Furthermore, values of 3 different vegetation indices can be mixed to represent
combined results as afalse color "RGB" image.

Reflectance calibration

In Metashape you can execute the reflectance calibration of multispectral image data acquired using
MicaSense (RedEdge, Altum), Parrot Sequoiaand DJI Phantom 4 Multispectral cameras based on images
of the radiometric panel and/or sun sensor meta data. Metashape can automatically sort out calibration
images to the special camera group on the Workspace pane if the image meta data says that the images are
for calibration. The images will be disabled automatically (not to be used in actual processing). If thereis
no such information in the image meta data, the calibration images will be detected automatically during
calibrate reflectance procedure, providing that the radiometric panel has a proper QR-code attached.

[ Note

» Please do not forget to add reflectance calibration images to the chunk together with the main
image set.

To perform reflectance calibration
1. Choose Calibrate Reflectance from the Tools menu.

2. PressLocate Panelshbutton. Asaresult theimages with the panel will be moved to the separate folder
and the masks would be applied to cover everything on the images except the pandl itself. If you are
using the panel for the first time, and its calibration is not added to Metashape internal database yet,
you will be prompted to load calibration from CSV file.

3. Ifyoudon't have aCSV filewith calibration information, you can enter calibration values manually.
It can be done manually in Calibrate Reflectance dialog or using Select Panel... button. In the Select
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Reflectance Panel dialog it is possible to: load reflectance information from aCSV file; save current
table (wavelength / reflectance factor); edit the name of a panel in the database (the nameisused in
Calibrate Reflectance dialog); remove the panel from the database.

4. Check on Use reflectance panel and Use sun sensor options in the Calibrate Reflectance dialog to
perform calibration based on panel data and/or image meta information.

5. Click OK to start calibration process.

Vignetting correction
Reflectance calibration results can be improved based on the vignetting correction.
Vignetting is modeled in Metashape using a 3 degree bivariate polynomial:
V(x, y) = exp(sum; cj * X * y)

- wherex and y represent normalized pixel coordinates, so that top |eft corner of the image has coordinates
(-1, -1), and bottom right corner has coordinates (1, 1).

- Gj are vignetting coefficientsin Metashape vignetting model . Coefficients can be obtained by converting
coefficients from XMP image meta data into a Metashape model or calculated during Calibrate Colors
process.

To compensate vignetting in the image, each pixel value is divided by corresponding vignetting factor.
I'=1/ exp(sumjj cjj * X * yj)

where

x=2*(i+05)/w-1

y=2*(+05/h-1

i, - integer column and row pixel coordinates

w, h—image width and height in pixels

X, Y - normalized pixel coordinates

| - pixel intensity in the original image with vignetting

I' - pixel intensity in the corrected image without vignetting
Vegetation index calculation

To calculate a vegetation index
1. Open orthomosaic in the Ortho tab double-clicking on the orthomosaic |abel on the Workspace pane.

2 Open Raster Transformtool using "2 Raster Transform button from the Ortho view toolbar.

3. Ontheleft-hand side of the Transform tab of the Raster Calculator dialog all the bands of the input
imagesarelisted. Set avegetation index expression on the Output Bands side of thetab using keyboard
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input and operator buttons of the raster calculator if necessary. If the expression isvalid, the line will
be marked with “?f?si gn.

Y ou can set several vegetation index expressionsto be calculated. Use Q X buttons to add/delete
linesin thelist of output bands.

5. Click OK button to have the index (or indices) calculated. The result - orthomosaic with vegetation
index (or indices) information, each index being stored in a separate channel, can be exported with
Export orthomosaic command from the File menu. For guidance on the export procedure, please refer
to NDVI data export section of the manual.

6. Alternatively to Step 5, if you would like to have the index visualized in Ortho view of Metashape
window for inspection, follow Steps 6-12. Check Enable transform box and switch to the Palette tab
of the Raster Calculator dialog.

7. Select output band in Use band field on the Palette tab.

Click '_HJII'UU pdate button to have the histogram of the index values shown on the | eft-hand side of the
Palette tab.

9. Select the range of meaningful index values either manually on the histogram or apply automatically
calculated range with the Auto button at the bottom of the tab.

10. Select palette preset from the drop-down list on the right-hand side of the Pal ette tab.

11. Click Apply button. Once the operation is completed - all the vegetation indices are calculated, the
index values stored in the selected output band (indices cal culated according to the selected output
band expression set on the Transformtab of the Raster Calculator) will be shown in the Ortho view,
index values being visualized with pseudocolors according to the palette set in the Raster Calculator
dialog.

12. You can either continue your work in Raster Calculator or click OK button to close the dialog.

Pal ette defines the color for each index value to be shown with. M etashape offers several standard pal ette
presets on the Pal ette tab of the Raster Calculator dialog. A preset (Heat, NDV1, Gray scale) can be chosen
from the drop-down list on the Palette tab of the Raster Calculator dialog. Alternatively, the user can

upload the palette from a Surfer Color Spectrum (*.clr) file (= Import Palette), preliminary prepared in
an external tool.

The palette can also be edited within M etashape environment using DAdd Color and @ Remove Color
buttons on the Pal ette tab of the Raster Calculator dialog. For each new line added to the palette acertain
index value should be typed in. Double click on the newly added line to type the value in. A customized

palette can be saved for future projects using HExport Palette button on the Palette tab of the Raster
Calculator dialog.

The range of meaningful index values can be manually adjusted on the |eft-hand side of the Palette tab or
set automatically with the Auto button at the bottom of the tab. Interpolate colors option can be checked
to introduce intermediate colors to the output image.

False color value on the drop-down list of the palette presets allows to visualize combined results of
particular 3 vegetation indices tackled as false RGB colors.
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4 Note

« If you change the index expression for selected output band on the Transform tab, do not forget
to adjust Palette settings for visualization purposes: click Update button on the Palette tab to
have the histogram of the index values updated, set the range of the meaningful values, chose
the proper color palette.

« If you would like to inspect values of a different vegetation index, not the one already shown,
you need to set the corresponding formula in the selected band of the Output Band list on the
Transformtab of the Raster Calculator dialog.

* If you would like to see original multispectral orthomosaic, with no index calculation applied,
uncheck Enable transform option on the Transformtab of the Raster Calculator dialog and click
Apply/OK button. If theinput images havethree channelsmarked asR, G, B, then the orthomosaic
will be visualized as an RGB image (or false RGB). Otherwise, the spectral data from the first
channel will be visualized in gray scale.

Prescription maps generation

The prescription map is generated based on the orthomosaic with calculated index (NDV1). Normalized
Difference Vegetation Index (NDV1) adimensionless index that describes the difference between visible
and near-infrared reflectance of vegetation cover. NDVI is calculated by the following formula:

NDVI = (NIR - RED)/(NIR + RED)

where

NIR - reflectance in the near-infrared region of the spectrum

RED - reflectance in the red region of the spectrum

Select Generate Prescription Map command on the Orthomosaic submenu from the Tools menu.

First specify the area with the boundary shape in a vector layer (if there is no shape layer in the project,
orthomosaic is used in its entirety). Make sure that the selected area has been transformed according to
the specified rule (raster transform operation is performed and NDV| is calculated). The histogram of the
index values for the first transformed channel is used for visual analysis and serves as a ground base for
setting the number of classes and choosing the method of clusterization. The number of classes set by the
user corresponds to the number of zones marked on the histogram.

In Metashape available 2 clusterization methods: Jenks natural breaks and Equal intervals clustering:

- when using the Jenks natural breaks clustering method, the histogram splitting occurs automatically as
the method prescribes;

- when using the Equal intervals clustering method, the histogram is split into equal intervalsfrom the min
index value to the max index value. Min and Max index values are calculated automatically.

Then a grid with a defined sell sizeis applied to the raster. The index valuesin the grid cell are averaged
and each cell is assigned to a class depending on the cell index value.

After theclusterizationiscompleted the cellsthat fall into the same cluster are combinedin aseparate class.
The clusters are written into avector layer named Prescription. The resulting layer contains severa groups
of polygons (MultiPolygon): each polygon corresponds to a separate cluster and each group corresponds
to a separate class. The attributes of each class include the average value of the index (zonal_mean) and
its ordinal number starting from 1 (class_id) as well asthe value for prescribed rate.
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Generate Prescription Map A
Parameters
Boundary shape layer: Mone
Cell size {m): 1
Vegetation dasses
Classes: 4 Jenks natural breaks Q
. . 0.257 0.503 . 0.715 .
SN S S S S — MR- —
] 0.1 0.2 0.3 0.4 0.5 0.6 0.7 0.8 0.9
. Zonal mean Area (ha) Rate (kg/ha)
1 |0.132549 20.2335 100
2 0331366 14,9904 100
3 0.624177 27.5218 100
4 0810672 28.6274 100

Total amount (ka): 913731

"Generate Presctiption Map" dialog window
The following parameters can be adjusted:

Boundary shape layer
Layer with polygon for which the Prescription map will be generated (if there are no shape layer, the
whole orthomosaic will be used).

Céll size (m)
Sets cell sizein meters.

Classes
Specifies the number of classes.

Methodsfor clusterization
Jenks natural breaks and Equal intervals clustering

Histogram displays the index histogram and the division into zones.
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The table includes Zonal mean index values, Area (ha) and Rate(kg/ha) for each class (indicated by
the class number in table lines). The values in the table can be changed manually if needed.

Total amount (kg)
Setstotal amount of fertilizer in kilograms. The valuefor the Total amount can be changed if required.

To change the fertilizer consumption select Prescription map on the Workspace pane and choose
Prescription map properties... command from the context menu. In the Fertilizers table set the desired
value for Rate or for the Total amount.

To export Prescription mapin Shapefileformat sel ect Prescription map on the Workspace pane and choose
Export Layers... command from the context menu.

Modified visible range cameras

Modified visible range cameras provide data in the form of three channel imagery, but those channels
do not contain standard R, G, B spectrum range information due to some physical manipulation done on
the sensor. For example, a Colored Infrared (CIR) cameraby MAVinci records Red+NIR datain the first
channel, Green+NIR datain the second channel, and NIR datain the third one.

Modified visible range cameras are used for vegetation monitoring along with multispectral cameras. To
cal culate vegetation indices with M etashape the data captured with a modified camera should be calibrated
first. This means we need to get pure R, G, NIR values to apply vegetation index formula. To perform
the calibration, one needs calibration matrix data. In this context, a calibration matrix is amatrix of linear
transformation of source light intensity values in each channel into absolute values of intensity.

In case of CIR cameraby MAVinci, calibration matrix can be calculated based on the histograms for the
following relations: NIR/R, NIR/G. Calibration matrix spectrum values will be equal to the values of the
cut offs (kr, kg) of the corresponding histograms. C ={(kg, 0, -1), (0, kg, -1), (0, 0, 1)} . Then the vector of
the absolute intensity values for R, G, NIR spectrum bands, scaled according to NIR intensity value, can
be calculated as X,=C* X, where C [3x3]- CIR calibration matrix, Xg [3x1]- vector of the source values
of the intensity for each band.

M etashape offers dialog to manually input values of the calibration matrix - see Color Matrix section of
the CIR Calibration tab in the Raster Calculator dialog. (Thetab isavailable for 3 bandsimagery only. If
the project deals with multispectral imagery, thereis no need to calibrate the data.) One can either printin
the values, or select the values with sliders on the histograms. For a CIR cameraby MAVinci, calibration
matrix values can be set automatically with the Auto button.

Once the calibration matrix values are set, click Apply button for Metashape to perform the calibration.
After that you can proceed to Transform and Palette tabs of the Raster Calculator to calculate vegetation
indices as described in the section above. Metashape will use calibrated values as Input Bands on the
Transformtab.

Index based contour lines

M etashape enables to cal culate contour lines based on the calculated index values.

To calculate contour lines based on vegetation index data

1. Select Generate Contours... command from the orthomosaic icon context menu on the Workspace
pane, while index datais shown in the Ortho view.

2.  Select Orthomosaic as the source for the contours cal cul ation.

3. Adjust the min/max value and the interval parameters for the task.
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4. Press OK button to calculate index values.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

6. When the procedure is finished, a shape layer with "contours' label will be added to the project file

structure shown on the Wor kspace pane. The contour lines will be shown over the index data on the
Ortho tab.

Powerlines detection

Metashape supports automatic powerlines detection. The algorithm uses aligned images to detect
powerlines. Detected powerlineswill be saved as shapes (3D polylines) in one or more shape layers. Read
more about shape properties in Shapes section.

£ Note

« The shape layer with the powerlines can be used together with the Plan Mission tool to indicate
the danger zone for adrone flight.

Detect Powerlines
1. Select the Detect Powerlines command from the Tools menu.
2. Choose parameters in Detect Powerlines dialog box.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Detect Powerlines parameters

Detect Powerlines

General

LIse model for visibility checks

Min altitude from DEM {m):

Advanced
Tolerance (m): 0.01
Maximum number of vertices per line: 100

Lok ] cancel

"Detect Powerlines' dialog
The following parameters can be changed in the Detect Powerlines dialog window:
Use moddl for visibility checks

Helps to reconstruct more powerlines in scenes with difficult geometry where wires are occluded by
the model in images.
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Min altitude from DEM (m)
To exclude road marking or, for example, fences, we recommend setting this parameter, which
requiresto generate DEM as an additional preliminary step.

Additionally the following advanced parameters can be adjusted.

Tolerance (m)
Specify the tolerance for the maximum deviation in meters from the mathematically calculated ideal
wire model.

Maximum number of vertices per line
During drawing powerlines, alarge number of vertices can be created intheline. Itispossibleto limit
the number of vertices by specifying the desired maximum number of vertices per line. Thevalue "0"
can be set to avoid the number of vertices to be limited.

Stereoscopic measurements and vectorization

Metashape supports performing measurements and vectorization in stereo mode on stereo pairs
(overlapping photos).

M easur ements and vectorization
4  Note
* The Snhapping tool in Metashape will help you to do vectorization. The following snapping types

areavailable: Axis, Vertex and Edge. To use snapping mode, click Axis Snap, Vertex Snap, Edge
Snap on the toolbar and press Shift button when you start drawing shapes.

L To measure distance click € Ruler toolbar button, hold right mouse button and left click on the first
point, than move 3D cursor to the next point and left click onit.

2 To draw point, click *" Draw Point toolbar button and left click on the point of your interest.
To draw polyline click Draw Palyline toolbar button, left click on the first point, than move 3D
cursor to the next point, and left click on it. Perform double left click to finish the polyline.

4. =

To draw polygon click "/ Draw Pol ygon toolbar button, left click on the first point, than move 3D
cursor to the next point, and left click on it. Perform double | eft click to finish the polygon.
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Using masks

Overview

Masks are used in Metashape to specify the areas on the photos which can otherwise be confusing to
the program or lead to incorrect reconstruction results. Masks can be applied at the following stages of
processing:

» Matching of the images

* Building Depth Maps

* Building Mesh from the depth maps source with the strict volumetric masks option applied
* Building Texture

* Building Tiled Model

* Building Orthomosaic

* Building Panorama

Alignment of the photos
Masked areas can be excluded during feature point detection. Thus, the objects on the masked parts
of the photos are not taken into account while estimating camera positions. This is important in the
setups, where the object of interest is not static with respect to the scene, like when using aturn table
to capture the photos.

Masking may be also useful when the object of interest occupies only a small part of the photo. In
this case a small number of useful matches can be filtered out mistakenly as a noise among a much
greater number of matches between background objects.
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Building point cloud

While building point cloud, masked areas are not used in the depth maps computation process.
Masking can be used to reduce the resulting point cloud complexity, by eliminating the areas on the
photos that are not of interest.

Masked areas are always excluded from processing during point cloud and texture generation stages,
including Tiled Model generation process.

Let'stake for instance a set of photos of some object. Along with an object itself on each photo some
background areas are present. These areas may be useful for more precise camera positioning, so
it is better to use them while aligning the photos. However, impact of these areas at the building
point cloud is exactly opposite: the resulting model will contain object of interest and its background.
Background geometry will "consume" some part of mesh polygons that could be otherwise used for
modeling the main object.

Setting the masks for such background areas allows to avoid this problem and increases the precision
and quality of geometry reconstruction.

Building orthomosaic

During building orthomosaic process, masked areas on the photos are not used for building
orthomosaic.

Building texture atlas

During texture atlas generation (for single mesh model and tiled model), masked areas on the photos
are not used for texturing. Masking areas on the photosthat are occluded by outliers or obstacles helps
to prevent the "ghosting” effect on the resulting texture atlas.

Loading masks

Masks can be loaded from external sources, as well as generated automatically from background images
if such datais available. M etashape supports |oading masks from the following sources:

» From aphachannel of the source photos.

» From separate images.

» Generated from background photos based on background differencing technique.

» Based on reconstructed 3D model.

Toimport masks

1

2.

Select Import Masks... command from the File menu.
In the Import Mask dialog select suitable parameters. Click OK button when done.

When generating masks from separate or background images, the folder selection dialog will appear.
Browse to the folder containing corresponding images and select it.

The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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Import Masks
Parameters

Method: From Alpha
Operation: Replacement

Filename template: mask.jp

Tolerance: 163 H

Apply to

(]

All cameras Entire workspace

Selected cameras Current photo

ok ] Cancel

"Import Masks" dialog
The following parameters can be specified during mask import:

Method
Specifies the source of the mask data.

From Alpha - load masks from alpha channel of the source photos.
From File - load masks from separate images.

From Background - generate masks from background photos.
From Model - generate masks based on reconstructed model.

Operation
Specifies the action to be done in case a second mask is imported for the photo.

Replacement - new mask will be loaded and stored instead of the original one.

Union - two masks will be united and stored.

I nter section - the intersection of the two masks will be stored as a new mask for the photo.
Difference - only the difference between two masks will be stored as a new mask for the photo.

Filename template (not used in From alpha mode)
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:

{filename} - file name of the source photo without extension.
{fileext} - extension of the source photo.

{camera} - cameralabel.

{frame} - frame number.

{filenum} - sequential number of the mask being imported.
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For example, {filename} _mask.png template can be used if masks are available in PNG format and
have a_mask suffix.

Tolerance (From Background method only)
Specifies the tolerance threshold used for background differencing. Tolerance value should be set
according to the color separation between foreground and background pixels. For larger separation
higher tolerance values can be used.

Apply to
Specifies whether masks should be imported for the currently opened photo, active chunk or entire
Workspace.
All camer as - load masks for active chunk.
Entire workspace - load masks for all chunks in the project.

Selected camer as - load mask for the currently checked cameras (if any).

Current photo - load mask for the currently opened photo (if any).

Generate masks

The Generate masks tool allows to create masks from the mesh model. Due to the nature of the shooting,
not the whole object may be placed in focus, which will lead to blurred areas in the pictures. The texture
will be more blurry than possible if built texture uses the images data from defocus areas. The tool alows
to exclude such areas prior to the texture blending procedure by applying the masks automatically to out
of focus areas.

To generate mask
1. Select Generate Masks command from the Mesh submenu from the Tools menu.
2. Inthe Generate Masks dialog select suitable parameters. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Generate Masks
Parameters
Operation: Replacement
Mask defocus areas
Force model coverage

Blur threshold 3.00

Apply to

All cameras Entire workspace

LS|

Lo ] cancel |
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"Generate Masks' dialog
The following parameters can be specified in Generate Masks dialog:

Operation
Specifies the action to be done in case a second mask is imported for the photo.

Replacement - new mask will be loaded and stored instead of the original one.

Union - two masks will be united and stored.

I nter section - the intersection of the two masks will be stored as a new mask for the photo.
Difference - only the difference between two masks will be stored as a new mask for the photo.

Mask defocus areas
Enabled applying masksto the areasthat are out of focus based on the depth information of each point.

Fix coverage (for Replace and Union oper ations only)
Allows to avoid blind spots on the model surface when generating masks.

Blur threshold
The Blur threshold parameter defines the allowed blur radius on a photo in pixels. In most cases, we
recommend using the 2 or 3 pixels.

Apply to
Specifies whether masks should be created for the currently opened photo, active chunk or entire
Workspace.
All camer as - generate masks for active chunk.
Entire wor kspace - generate masks for all chunks in the project.

Selected camer as - generate mask for the currently checked cameras (if any).

Current photo - generate mask for the currently opened photo (if any).

Editing masks

Modification of the current mask is performed by adding or subtracting selections. A selection is created
with one of the supported selection tools and is not incorporated in the current mask until it ismerged with
amask using Add Selection or Subtract Selection operations.

To edit the mask

1. Open the photo to be masked by double clicking on its name on the Workspace / Photos pane. The
photo will be opened in the main window. The existing mask will be displayed as a shaded region
on the photo.

2. Select the desired selection tool and generate a selection.

Selection to subtract the selection from the mask. #* | Invert Selection button allows to invert current
selection prior to adding or subtracting it from the mask.
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The following tools can be used for creating selections:

-1
L—41 Rectangle selection tool
Rectangle selection tool isused to select large areas or to clean up the mask after other selection tools

were applied.

% Intelligent scissorstool
Intelligent scissorsis used to generate a selection by specifying its boundary. The boundary isformed
by selecting a sequence of vertices with a mouse, which are automatically connected with segments.
The segments can be formed either by straight lines, or by curved contours snapped to the object
boundaries. To enable snapping, hold Ctrl key while selecting the next vertex. To complete the
selection, the boundary should be closed by clicking on the first boundary vertex.

% ntelligent paint tool
Intelligent paint tool is used to "paint" a selection by the mouse, continuously adding small image
regions, bounded by object boundaries.

M agic wand tool
Magic Wand tool is used to select uniform areas of the image. To make a selection with a Magic
Wand tool, click inside the region to be selected.
The range of pixel colors selected by Magic Wand is controlled by the tolerance value. At lower

tolerance values the tool selects fewer colors similar to the pixel you click with the Magic Wand tool.
Higher value broadens the range of colors selected.

4 Note

« To add new areato the current selection hold the Ctrl key during selection of additional area.

» To subtract a part from the current selection hold the Shift key during selection of the area to
be subtracted.

» To reset mask selection on the current photo press Esc key.
A mask can beinverted using Invert Mask command from the Edit menu. The command is active in Photo
view only. Alternatively, you can invert masks either for selected cameras or for all cameras in a chunk

using Invert Masks... command from a photo context menu on the Photos pane.

The masks are generated individually for each image. If some object should be masked out, it should be
masked out on all photos, where that object appears.

Exporting masks

Created masks can be also saved for external editing or storage.

To export masks
1. Select Export Masks... command from the File menu.
2. Inthe Export Mask dialog select suitable parameters. Click OK button when done.

3.  Browseto the folder where the masks should be saved and select it.
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4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Export Masks

Parameters

File type: Single channel mask image

Filename template: mask.jpa

Apply to
All cameras Entire workspace
Selected cameras Current photo

ok |
"Export Masks" dialog
The following parameters can be specified during mask export:

Export masksfor
Specifies whether masks should be exported for the currently opened photo, active chunk or entire
Workspace.

Current photo - save mask for the currently opened photo (if any).
Active chunk - save masks for active chunk.
Entire workspace - save masks for all chunksin the project.

Filetype
Specifies the type of generated files.

Single channel mask image - generates single channel black and white mask images.

Image with alpha channel - generates color images from source photos combined with mask data
in alphachannel.

Mask file names
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:

{filename} - file name of the source photo without extension.
{fileext} - extension of the source photo.

{camera} - cameralabel.

{frame} - frame number.

{filenum} - sequential number of the mask being exported.

For example, {filename} _mask.png template can be used to export masksin PNG format with_mask
suffix.
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4 Note

* Whenimporting/exporting mask for the current photo only, Metashape will prompt for the actual
image instead of image folder. Mask file names parameter will not be used in this case.

Editing point cloud

The following point cloud editing tools are available in Metashape:

Automatic filtering based on specified criterion (tie points only)

Automatic filtering based on applied masks (point cloud only)

Automatic filtering based on points colors (point cloud only)

Automatic filtering by class (point cloud only)

Automatic filtering by selection (point cloud only)

Automatic filtering by confidence (point cloud only)

Reducing number of pointsin point cloud by setting tie point per photo limit (tie points only)
Reducing number of point cloud points by setting up point spacing value

Colorize point point cloud

Manual points removal

4 Note

 Point cloud editing operation can be undone/redone using Undo/Redo command from the Edit
menu.

Filtering points based on specified criterion

In some cases it may be useful to find out where the points with high reprojection error are located within
thetie point cloud, or remove points representing high amount of noise. Point cloud filtering helpsto select
such points, which usually are supposed to be removed.

M etashape supports the following criteriafor point cloud filtering:

Reprojection error

Maximum reprojection error is calculated in normalized units for all images where tie point was
measured.

max; [X'i - Xi| / s
where

X'j - coordinates of the point projection according to adjusted orientation parameters on the i-th image
in pixels,

Xij - measured point projection coordinates on the i-th image in pixels,
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s - the scale of the image that was used for measuring the coordinates of the corresponding projection
on thei-th image.

High reprojection error usualy indicates poor localization accuracy of the corresponding point
projections at the point matching step. It is also typical for false matches. Removing such points can
improve accuracy of the subseguent optimization step.

Reconstruction uncertainty

Ratio of the largest semi-axisto the smallest semi-axis of the error ellipse of the triangulated 3D point
coordinates. The error ellipse corresponds to the uncertainty of the point triangulation alone without
taking into account propagation of uncertainties from interior and exterior orientation parameters.

sart(ky / ks)

where

k; - largest eigenvalue of the tie-point covariance matrix,
k3 - smallest eigenvalue of the tie-point covariance matrix

High reconstruction uncertainty is typical for points, reconstructed from nearby photos with small
baseline. Such points can noticeably deviate from the object surface, introducing noise in the point
cloud. While removal of such points should not affect the accuracy of optimization, it may be useful
to remove them before building geometry in Point Cloud mode or for better visual appearance of the
point cloud.

I mage count

Number of images where the tie point was measured.

M etashape reconstruct all the points that are visible at |east on two photos. However, points that are
visible only on two photos are likely to be located with poor accuracy. Image count filtering enables
to remove such unreliable points from the cloud.

Projection Accuracy

Average image scale that was used for measuring coordinates of the projections of the tie-point.
sum;s/n
where

5 - the scale of theimage that was used for measuring the coordinates of the corresponding projection
on thei-th image,

n - number of images where tie-point was measured

Thiscriterion alowsto filter out points which projections were relatively poorer localized dueto their
bigger size.

Toremove points based on specified criterion

1

Switch to Point Cloud view mode using a& Point Cloud toolbar button.
Select Gradual Selection... command from the Model menu.

In the Gradual Selection dialog box specify the criterion to be used for filtering. Adjust the threshold
level using the slider. The selection changes while dragging the slider. Click OK button to finalize
the selection.
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To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points based on applied masks

To remove points based on applied masks

1

Switch to Point Cloud view mode using === Point Cloud toolbar button.
Choose Select Masked Points... command from the Point Cloud submenu of the Tools menu.

In the Select Masked Points dialog box indicate the photos whose masks to be taken into account.
Adjust the edge softness level using the dlider. Click OK button to run the selection procedure.

To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points based on points colors

Toremove points based on points colors

1

Switch to Point Cloud view mode using === Point Cloud toolbar button.
Choose Select Points by Color... command from the Point Cloud submenu of the Tools menu.

In the Select Paints by Color dialog box the color to be used as the criterion. Adjust the tolerance
level using the dlider. Click OK button to run the selection procedure.

To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points by class

To select objects of the same type in Point Cloud, use filter by classtool. Choose only the class interested
to display this pointsin the Model view.

Filter by class

1.

Switch to Point Cloud view mode using a2 Point Cloud toolbar button.
Choose Filter By Class... command from the Point Cloud submenu of the Tools menu.

In the Select Point Classes dialog box choose classes to be used as the filter. Click OK button to run
the selection procedure.

The result of the filtering will be shown in the Model view.

Select Reset filter command from the Point Cloud submenu of the Tools menu to cancel filtering
by classes
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Filtering points by return

M etashape supports LiDAR point cloud filtering by return value. To perform such filtering the point cloud
should be imported as laser scan data and this information should be stored in the LIDAR metadata.

Filter by return

1

Switch to Laser Scans view mode using LBl show Laser Scanstoolbar button.
Choose Filter By Return... command from the Point Cloud submenu of the Tools menu.

In the Select Point Returns dialog box choose returns (Single return, First return, Intermediate return,
Last return) to be used as the filter. Click OK button to run the selection procedure.

The result of the filtering will be shown in the Model view.

Select Reset filter command from the Point Cloud submenu of the Tools menu to cancel filtering
by returns.

Filtering points by selection

Filter by selection

1

Switch to Point Cloud view mode using === Point Cloudtoolbar button.

1 o, -
Select pointsto befilter . - iRectangle Selection, “--Circle Sdlection or I':-_g Free-Form Selection tools.
Choose Filter By Selection... command from the Point Cloud submenu of the Tools menu.
The result of the filtering will be shown in the Model view.

Select Reset filter command from the Point Cloud submenu of the Tools menu to cancd filtering
by classes

Filtering points by confidence

M etashape supports point cloud filtering by confidence value. To perform such filtering Calculate point
confidence option should be enabled in the Build Point Cloud dialog before the point cloud of interest
is generated.

Filter by confidence

1

Switch to Point Cloud view mode using =52 Point Cloud Confidence toolbar button.
Choose Filter by Confidence... command from the Point Cloud submenu of the Tools menu.

In the Select Confidence Range dialog box choose min and max value to be used as the filter. The
values define the number of depth maps involved in the point generation.

Click OK button to run the selection procedure.
The result of the filtering will be shown in the Model view.

Select Reset filter command from the Point Cloud submenu of the Tools menu to cancel filtering by
confidence.
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Tie point per photo limit

Filter

Tiepoint limit parameter could be adjusted before Align photos procedure. The number indicatesthe upper
limit for matching points for every image. Using zero value doesn't apply any tie-point filtering.

The number of tie points can also be reduced after the alignment process with Tie Points - Thin Point
Cloud command available from Tools menu. Asaresultstie point cloud will be thinned, yet the alignment
will be kept unchanged.

point cloud

In Metashape it is possible to reduce the number of the point cloud points by setting the point spacing
parameter manually which defines the regular grid step.

Tofilter point point cloud

1. Select Filter point cloud command from the Point Cloud submenu of the Tools menu.
2. IntheFilter Point Cloud dialog box specify Point spacing in meters to be used.

3. Click OK button to run the selection procedure.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4 Note

* In the confirmation dialog box click Yes button if a new point cloud instance with result
calculation should be created in the active chunk. If No button is pressed the point cloud filtering
result will overwrite the active point point cloud instance.

Colorize Point Cloud

M etashape supports the option to colorize point clouds with the colors from the images or orthomosaic.

To colorize point cloud

1. Select an active Point Cloud in the Workspace pane.

2. Choose Colorize Point Cloud... command from the Point Cloud submenu of the Tools menu.
3. Inthe Colorize Point Cloud dialog box select Source data from Orthomosaic orlmages option.

4. Click on the OK button to start the procedure. The progress dialog box will appear displaying the
current processing status.

Manual points removal

Incorrect points can be also removed manually.

Toremove pointsfrom a point cloud manually

Switch to Tie Point Cloud view mode using a2 Point Cloud toolbar button or to Point Cloud view

mode using Point Cloud toolbar button.
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2 Select points to be removed using - Rectangle Selection, _? Circle Sdlection or “.% Free-Form

Selection tools. To add new points to the current selection hold the Ctrl key during selection of
additional points. To remove some points from the current selection hold the Shift key during
selection of pointsto be removed.

To delete selected points click the X Delete Selection toolbar button or select Delete Selection

command from the Edit menu. To crop selection to the selected points click the ﬁ Crop Selection
toolbar button or select Crop Selection command from the Edit menu.

Deleting points via Crop Selection or Delete Selection tools simply invalidates them, i.e. the points will
still be stored in the project and they can be restored (all deleted points). If all the deleted points need to
be deleted without the possibility of recovery, then use Compact Point Cloud command from the Point
Cloud submenu of the Tools menu, and then save the project.

Classifying point cloud

M etashape allows not only to generate and visualize point cloud but also to classify the points within it.
There are two options: automatic division of all the points into two classes - ground points and the rest,
and manual selection of agroup of points to be placed in a certain class from the standard list known for
LIDAR data. Point cloud classification opens way to customize Build Mesh step: you can choose what
type of objects within the scene you would like to be reconstructed and indicate the corresponding point
classasasource datafor mesh generation. For example, if you build mesh or DEM based on ground points
only, it will be possible to export DTM (as opposed to DSM) at the next step.

Automatic classification of ground points

For the user to avoid extramanual work M etashape offersfeature for automatic detection of ground points.
Classification can be performed based on a photogrammetric point cloud or aerial laser scan data.

To classify ground points automatically

1. Select Classify Ground Points... command from the Point Cloud submenu of the Tools menu.

2. Inthe Classify Ground Points dialog box select the parameters for the classification procedure.

3. Click OK button to run the classification procedure.

Automatic classification procedure consists of two steps. At the first step the point cloud is divided into
cells of acertain size. In each cell the lowest point is detected. Triangulation of these points givesthe first
approximation of the terrain model.

Additionally, at this step Metashape filters out some noise points to be handled as L ow Points class.

At the second step new point is added to the ground class, providing that it satisfies two conditions: it lies
within a certain distance from the terrain model and that the angle between terrain model and the line to
connect this new point with a point from a ground class is less than a certain angle. The second step is
repeated while there still are points to be checked.

For aerial laser scan data, the ability to use return value during classification process is available. There

is also a possihility keep existing ground points during classification process. Enable the corresponding
parameter in the Classify Ground Points dialog box.
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Classify Ground Points

Classes
From: Any dass
Toe Ground + Low Points

Keep existing ground points

Parameters

Max angle (=): 15.0 =
Max distance (m): 1

Max terrain slope (deag): 1.0 H

Cell size {m): 50

Erosion radius (m): ]

Return number: Any Return

Lok ] Cancel

"Classify Ground Points* dialog
The following parameters control automatic ground points classification procedure

Max angle (deg)
Determines one of the conditionsto be checked whiletesting apoint asaground one, i.e. setslimitation
for an angle between terrain model and the line to connect the point in question with a point from a
ground class. For nearly flat terrain it isrecommended to use default value of 15 deg for the parameter.
It is reasonable to set a higher value, if the terrain contains steep slopes.

Max distance (m)
Determines one of the conditionsto be checked whiletesting apoint asaground one, i.e. setslimitation
for a distance between the point in question and terrain model. In fact, this parameter determines the
assumption for the maximum variation of the ground elevation at atime.

Cell size (m)
Determines the size of the cells for point cloud to be divided into as a preparatory step in ground
points classification procedure. Cell size should be indicated with respect to the size of the largest
area within the scene that does not contain any ground points, e. g. building or point forest.

Erosion radius (m)
Determines the indentation (in meters) from unclassified points to create an additional area around
the object, it is useful when classifying houses and trees to exclude the remaining "stumps' when
building DTM.

Return number
Determines which return layer to use during classification (Any Return, First Return or Last Return).
Usually for laser scans, the first returned is the most significant return and will be associated with the
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highest feature in the landscape (trees, buildings and so on). It is possible to specify to use First return
or Last return. Use the Any Return parameter to perform classification at all return levels.

Automatic point cloud multi-class classification

M etashape allowsfor semantic classification of point cloudsto solvethetask of higher-level interpretation
of the reconstructed data. Using the machine |earning techniques M etashape enabl es automatic point cloud
classification to any combination of the following classes. Ground, High V egetation, Building, Road, Car
and Man-made.

To start the automatic multi-class classification
1. Select Classify Points... command from the Point Cloud submenu of the Tools menu.

2. Inthe Classify Points dialog box select the source point class for the classification procedure in the
"From" field.

3. Select thetarget classes from thelist in "To" field.

4. Define Confidence parameter in O - 1 range. Higher value of the parameter means that the point
which class cannot be reliably assigned, will remain unclassified.

5. Click OK button to run the classification procedure.

Classifty Points

Classes
From: Any class

L2 Ground

High Vegetaticn
Building
Rnﬂl‘l RI IF'FHr'P

Confidence: 0.00

Lok ] Cancel

"Classify Points" dialog
£ Note

e |If you are not satisfied with the automatic multi-class classification results or would like
to contribute and improve the classificator, please send the manually labeled point clouds
according to the guidelines published on the following page to support@agisoft.com: http://
www.agi soft.com/support/tips-tricks/

Manual classification of point cloud

M etashape allowsto associateall the pointswithin the point cloud with acertain standard class (seeLIDAR
data classification). This provides possibility to diversify export of the processing results with respect to
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different types of objects within the scene, e. g. DTM for ground, mesh for buildings and point cloud for
vegetation.

Toassign aclassto agroup of points

1 Switch to Point Cloud view mode using using Point Cloud toolbar button.

2. . . LT P .
Select points to be placed to a certain class using .- Rectangle Selection, -+ Circle Selection or

~._§ Free-Form Selection tools. To add new points to the current selection hold the Ctrl key during
selection of additional points. To remove some points from the current selection hold the Shift key
during selection of points to be removed.

3. Select Assign Class... command from the Point Cloud submenu of the Tools menu.

4. Inthe Assign Class dialog box select the source point data for the classification procedure and the
targeted class to be assigned to the selected points. Click OK button to run classification procedure.

Point cloud classification can be reset with Reset Classification command from Tools - Point Cloud menu.

Editing model geometry

The following mesh editing tools are available in Metashape:
» Decimation tool

* Photoconsistent mesh refinement tool

* Close holes tool

» Smooth tool

» Colorize vertices

» Automatic filtering based on specified criterion

e Manual polygon removal

* Fixing mesh topology

More complex editing can be done in the externa 3D editing tools. M etashape allows to export mesh and
then import it back for this purpose.

[ Note

 For polygon removal operations such as manual removal and connected component filtering it
is possible to undo the last mesh editing operation. There are Undo/Redo commands in the Edit
menu.

* Please note that Undo/Redo commands are not supported for mesh decimation and this operation
cannot be undone.

Decimation tool

Decimation is atool used to decrease the geometric resolution of the model by replacing high resolution
mesh with a lower resolution one, which is still capable of representing the object geometry with high
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accuracy. Metashape tendsto produce 3D model s with excessive geometry resolution, so mesh decimation
isusually a desirable step after geometry computation.

Highly detailed models may contain hundreds of thousands of polygons. While it is acceptable to work
with such a complex modelsin 3D editor tools, in most conventional tools like Adobe Reader or Google
Earth high complexity of 3D models may noticeably decrease application performance. High complexity
also results in longer time required to build texture and to export model in PDF file format.

In some casesit isdesirable to keep as much geometry details as possiblelikeit is needed for scientific and
archive purposes. However, if there are no special requirementsit is recommended to decimate the model
down to 100 000 - 200 000 polygons for exporting in PDF, and to 100 000 or even less for displaying in
Google Earth and aike toals.

To decimate 3D mode
1. Select Decimate Mesh... command from the Tools menu.

2. Inthe Decimate Mesh dialog box specify the target number of polygons, which should remain in the
final model. Click on the OK button to start decimation.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

[ Note

» Textureatlasisdiscarded during decimation process. Y ou will have to rebuild texture atlas after
decimation is complete.

Photoconsistent mesh refinement tool

Metashape allows to refine aready reconstructed mesh with respect to camera photos. This is iterative
process that can further recover details on surface. For example it can recover basrelief or ditch.

Torefine mesh

1. Check the model - it will be refined with respect to camera photos. Y ou can duplicate it with right
click on the model and selecting Duplicate... to refine the copy of model.

2. Select Refine Mesh... command from the Tools menu.

3. Inthe Refine Mesh... dialog box specify the target quality of refinement, number of iterations and
smoothness. Click on the OK button to start refinement.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

Refinement parameters

Quality
Specifies the desired refinement quality. Higher quality settings can be used to obtain more detailed
and accurate geometry, but they require longer time for processing. Interpretation of the quality
parameters hereis similar to that of accuracy settings given in Building point cloud section.

Iterations
Number of refinement iterations. In some cases additional iterations are able to recover more details,
but it will lead to proportional slow down.
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Smoothness
Smaller smoothness parameter |eadsto better features recovering but also it can increase noise. Bigger
smoothness parameter leads to better noise suppression, but can smooth out features too. Changing
smoothness value can help to balance between noise suppression and features recovering.

Colorize model vertices

In Metashape the mesh model vertices can be colorized using images, tie points or point cloud points
colors, or orthomosaic data.

To colorize model vertices

1. Select Colorize Vertices command in Mesh submenu from the Tools menu.
2. Inthe Colorize Model dialog box select source data for the operation.

3. Click on the OK button to start the procedure.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

Close holes tool

Close Holes tool provides possibility to repair your model if the reconstruction procedure resulted in a
mesh with several holes, due to insufficient image overlap for example.

Some tasks require a continuous surface disregarding the fact of information shortage. It is necessary to
generate a close model, for instance, to fulfill volume measurement task with Metashape.

Close holes tool enables to close void areas on the model substituting photogrammetric reconstruction
with extrapolation data. It is possible to control an acceptable level of accuracy indicating the maximum
size of aholeto be covered with extrapolated data.

To close holesin a 3D model

1. Select Close Holes... command in Mesh submenu from the Tools menu.

2. Inthe Close Holes dialog box indicate the maximum size of a hole to be covered with the slider.
3. Click on the OK button to start the procedure.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

4 Note

* Thedlider alowsto set the size of aholein relation to the size of the whole model surface.

Smooth tool

The Smooth tool alows you to make the model smoother and remove irregularities on the surface. Some
tasks require a sleek surface disregarding of details or real object more smooth than mesh in Metashape.
Y ou can apply the tool to the entire mesh or only to the selected area.
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4 Note

» To apply smoothing to a specific area, you must first select it and then apply the tool.

To smooth mesh
1. Select Smooth mesh... command in Mesh submenu of Tools menu.

2. In the Smooth mesh dialog box set the Srength parameter using slider. Y ou can aso enable check
box Apply to selected faces.

3. Click OK when done. To cancel processing click Cancel button.

4 Note

» Fix borders option can be applied to the models with the open edges, it allows to preserve the
position of the mesh vertices along the open edges when using smoothing.

Polygon filtering on specified criterion

In some cases reconstructed geometry may contain the cloud of small isolated mesh fragments surrounding
the "main" model or big unwanted polygons. Mesh filtering based on different criteria helps to select
polygons, which usually are supposed to be removed.

M etashape supports the following criteria for face filtering:

Connected component size
This filtering criteria alows to select isolated fragments with a certain number of polygons. The
number of polygonsin all isolated components to be selected is set with a dider and is indicated in
relation to the number of polygons in the whole model. The components are ranged in size, so that
the selection proceeds from the smallest component to the largest one.

Polygon size
This filtering criteria allows to select polygons up to a certain size. The size of the polygons to be
selected is set with a dider and isindicated in relation to the size of the whole model. This function
can be useful, for example, in case the geometry was reconstructed with the extrapolation and there
isaneed to remove extra polygons automatically added by Metashape to fill the gaps; these polygons
are often of alarger size than therest.

Vertex confidence
This filtering criteria allows to select polygons using confidence value. This parameters available
only if during build model use Depth map as Source data. The value is displayed as a percentage and
corresponds to the percentage of confidence from the maximum value of all confidence.

Toremove small isolated mesh fragments
1. Select Gradual Selection... command from the Model menu.
2. Inthe Gradual Selection dialog box select Connected component size criterion.

3. Select the size of isolated components to be removed using the dlider. Size of the largest component
is taken for 100%. Y ou can observe how the selection changes while dragging the dlider. Click OK
button to finalize the selection.

4. To remove the selected components use Delete Selection command from the Edit menu or click

X Delete Selection toolbar button (or simply press Del button on the keyboard).

139



Editing

Toremovelarge polygons

1

2.

Select Gradual Selection... command from the Model menu.

In the Gradual Selection dialog box select Polygon size criterion.

Select the size of polygons to be removed using the slider. Size of the largest polygon is taken for
100%. Y ou can observe how the selection changes while dragging the dider. Click OK button to

finalize the selection.

To remove the selected components use Delete Selection command from the Edit menu or click

X Delete Salection toolbar button (or simply press Del button on the keyboard).

Note that Metashape always selects the fragments starting from the smallest ones. If the model contains
only one component the selection will be empty.

Manual face removal

Unnecessary and excessive sections of model geometry can be also removed manually.

Toremovepart of the mesh polygons manually

1.

a T,
Select rectangle, circle or free-form selection tool using . - iRectangle Selection, --~Circle Selection

or 'l_‘: Free-Form Sdlection toolbar buttons.

Make the selection using the mouse. To add new polygons to the current selection hold the Ctrl key
during selection of additional polygons. To remove some polygons from the current selection hold
the Shift key during selection of polygonsto be excluded.

To delete selected polygons click the pat Delete Sdlection toolbar button or use Delete Selection

command from the Edit menu. To crop sel ection to the sel ected polygons click thet{- Crop Selection
toolbar button or use Crop Selection command from the Edit menu.

Togrow or shrink current selection

1.

To grow current selection press PageUp key in the selection mode. To grow selection by even alarger
amount, press PageUp while holding Shift key pressed.

To shrink current selection press PageDown key in the selection mode. To shrink selection by even
alarger amount, press PageDown while holding Shift key pressed.

Fixing mesh topology

Metashape is capable of basic mesh topology fixing.

To fix mesh topology

1.

2.

Select View Mesh Satistics... command from the Tools menu.

In the Mesh Satistics dialog box you can inspect mesh parameters. If there are any topological
problems, Fix Topology button will be active and can be clicked to solve the problems.
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3.

The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

Editing mesh in the external program

To export mesh for editing in the external program

1

2.

Select Export Model... command from the File menu.

In the Save As dialog box, specify the desired mesh format in the Save as type combo box. Select the
file name to be used for the model and click Save button.

In the opened dialog box specify additional parameters specific to the selected file format. Click OK
button when done.

Toimport edited mesh

1. Select Import Mesh... command from the File menu.
2. Inthe Open diaog box, browse to the file with the edited model and click Open.
4  Note

« Metashape supports loading models in Wavefront OBJ, 3DS, STL, COLLADA, Stanford PLY,
Alembic ABC, Autodesk FBX, Autodesk DXF, OpenCTM and U3D file formats only. Please
make sure to select one of these file formats when exporting model from the external 3D editor.

« Please be aware that it isimportant to keep reference information for the model if any.

Shapes

Shapes are used to indicate boundaries either for export or for measurement procedures. Shapes can be
drawn over DEM or Orthomosaic aswell as over model using buttons from the Ortho/Model view toolbar.
Alternatively, shapes can be loaded from external files (SHP, KML, KMZ, DXF, GeoJSON formats are
supported) using Import Shapes... command of Import... submenu available from the File menu. Shapes
created in Metashape can be exported using Export Shapes... command of Export... submenu available
from the File menu.

Drawing shapes

To draw a shape on DEM/Orthomosaic/M odel

1

Open the surface on which you want to draw (DEM, Orthomosaic or Model). Double clicking on
DEM, Orthomosaic or Model label on the Workspace pane.

=

Select “*" Draw Point /™ Draw Polyline/ " Draw Polygon instrument from the toolbar.

Draw a point/polyline/polygon on the DEM/orthomosai c/model with a cursor. By default the shape
vertex will be put on the available surface, however, in Metashape is it possible to draw the shapes
on a given plane (for example, at a certain height). To set up the drawing plane, select polyline or
polygon shape with three or more vertices or three markers placed in 3D. Then right click on the
selection and choose Set Drawing Plane command from the context menu. To reset Drawing Plane
select the corresponding command from the context menu.
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4. Doubleclick on thelast point to indicate the end of a polyline. To complete a polygon, place the end
point over the starting one.

> Oncethe shapeisdrawn, ashape label " will be added to the chunk data structure on the Wor kspace

pane. All shapes drawn on the same model (and on the corresponding DEM and orthomosaic) will
be shown under the same label on the Workspace pane.

6. The program will switch to a navigation mode once a shape is compl eted.

4 Note

« To movethe shapein Ortho view, select the shape (use selection tools or click left mouse button
on the shape in the navigation mode), after that press down Ctrl + Alt and left mouse button and
shift the shape to the new location.

The snapping tools in Metashape help with vectorization. The following snapping types are available:
Axis, Vertex and Edge. To use snapping mode, click Axis Shap, Vertex Shap, Edge Shap on the toolbar
and press Shift on the keyboard when drawing shapes.

4 Note

« If Vertex Shap is enabled and several vertices start from the same point, then they will all move.
To move only one vertex, disable Vertex Snhap on the toolbar after that select one vertex and shift
to the new place.

Drawing shapesin 3D (on the model) solves issues with building basements and other features which are
not visible on the orthomosaic. However, drawing on amodel might not be accurate enough. For this case
M etashape offers possibility to draw a shape on source photos and automatically reconstruct it in 3D.

To automatically reconstruct a shapein 3D
1. Enable Attach markers option available in Markers submenu of Tools menu.

2. Open aphoto in Photo view double clicking on the photo thumbnail in the Photo pane.

Select “%" Draw Point / A Draw Polyline/ '/ Draw Polygon instrument from the toolbar.
4. Draw apoint/polyline/polygon on the photo with a cursor.

5. Doubleclick on the last point to indicate the end of a polyline. To complete apolygon, place the end
point over the starting one. All the vertices will be indicated with markers.

6. Switch to Model view to see that the shape has been reconstructed in 3D automatically.

7. Torefinethe position of the shape, filter photos by shape using the corresponding command from the
shape context menu. The shape must be selected - to select a shape double click onit.

8. Inspect al the relevant photos to refine markers-vertices positions where necessary. The position of
the shape in 3D will automatically be refined.

After a shape has been drawn, it can be edited using Insert Vertex / Delete Vertex commands from the
context menu. Delete Vertex command is active only for avertex context menu. To get accessto the vertex
context menu, select the shape with a double click first, and then select the vertex with adouble click on
it. To change position of avertex, drag and drop it to a selected position with the cursor. Positions of the
markers-vertices cannot be changed in the Model view.
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Shapes alow to measure distances both on DEM and 3D model and to measure coordinates, surface
areas and volumes on 3D model. Please refer to Performing measurements on 3D model, Performing
measurements on DEM sections of the Manual for details.

Shapes added to the particular chunk of the project can be organized into layers. Thefirst layer isgenerated
automatically on creation of the first shape and is placed into the Shapes folder on the project tree. This
layer is meant to serve as a background thus named Layer [Default]. It is originally set as default one to
store all the shapes.

To create a new layer use Create Shape Layer command from the context menu of the Shape folder on
the Workspace pane. A layer can be set as default one using Set as default command from the context
menu of the layer name on the Workspace pane. A newly created layer can be renamed with a relevant
command from the context menu.

Export Layers... command from the context menu of alayer allows to save shapes from the layer in one
of the supported export formats available: SHP, DXF, KML, KMZ, GeoJSON, GeoPackage.

A shape can be labeled and saved to a certain layer using Properties... command from the context menu
of the shape in the Model/Ortho view.

Shape properties

The style of the shape layer can be defined in Metashape. It is possible to assing the label, border color, fill
color and fill style (for polygons) and transparency for the layer. Attribute table customization is available
from the shape properties dialog for each shape, where an attribute and its value can be specified.

4 Note

» Polygon fill styleisapplied only in Ortho view mode.

To set propertiesfor a shape

1. Right-clink on the selected shape in the Model, Ortho or Photo view mode.

2. Select Properties... command from the context menu.

3. Assigntheshapeto an existing layer fromthelist or create anew one by clicking on Add Layer button.
4. Populate the attribute table for the shape.

5. Click OK if to complete the settings.

It is possible to modify the style of the shape layer in the Metashape from the shape Properties pane. To
open the Properties pane, select Properties command from the View menu. Properties (Label, Description
and Layer) for the selected shape will appear in this pane. To customize the layer style for this shape,
doubleclick onthe Layer line and click on the Edit layer button. Parameters can be modified in the opened
Shape layer properties dialog.

Orthomosaic and panorama seamlines editing

M etashape software offers various blending options at orthomosai c and panorama generation step for the
user to adjust processing to their data and task. However, in some projects moving objects can cause
artefacts which interfere with visual quality of the orthomosaic and panorama. The same problem may
result from oblique aerial imagery processing if the areaof interest contains high buildingsor if the user has
captured facade from too oblique positions. To eliminate mentioned artefacts M etashape offers seamline

143



Editing

editing tool. The functionality allows to choose manually the image or images to texture the indicated part
of the orthomosaic/panorama from. Thus, the final orthomosaic and panorama can be improved visually
according to the user's expectations. Automatic seamlines can be turned on for inspection in the Ortho

=]
view with pressing the =1 Show Seamlines button from the Ortho view toolbar.

To edit orthomosaic or panorama seamlines
1 Draw a polygon on the orthomosai c/panorama using " Draw Polygon instrument to indicate the
areato be retextured.

2. Select Assign Images... command from the context menu of the selected polygon.

3. In the Assign Images dialog box select the image to texture the area inside the polygon from.
Orthomaosai ¢/panorama preview on the Ortho tab allows to evaluate the results of the selection. Click
OK button to finalize the image selection process.

4 Click '_“JII'! Update Orthomosai ¢ button from the Ortho view toolbar to apply the changes.

Assign Images dialog allows to activate multiple selection option. If the Allow multiple selection optionis
checked, it is possible to assign several images to texture the area inside the polygon from. However, in
this case there is no possibility to preview the resulting orthomosaic or panorama. It is necessary to click

F‘:[ﬂ Update Orthomosaic button from the Ortho view toolbar to apply the changes and see the results. Until
the changes are applied, the area of interest will be marked with a net of blue color to indicate that some
edits are waiting for enforcement. Blending method selected at build orthomosaic/panorama step will be
implemented at orthomosai c/panorama editing step.Assign Images dialog, alternatively, allowsto exclude
selected images from texturing the area of interest. Check Exclude selected images option to follow this
way. Please note that in this case preview illustrates the image to be excluded, i.d. the results one should

expect after applying the changes are not shown. Click 'Tﬂ Update Orthomosaic button from the Ortho
view toolbar to apply the changes.If the Assign image operation should be repeated several times, it is

recommended to use - Draw Patch tool available from the Ortho menu or with a corresponding Tool bar
button of the Ortho view menu. In this case it will still be required to draw polygons as in the procedure
above, but the best fit image will be assigned automatically, being selected with respect to the first drawn
vertex of the patch.

DEM editing tools

M etashape software offersvarious DEM editing tools (Fill and Create Breakline). The functionality allows
for example to edit the edges of roofs, or add surface in the areas with holes (water bodies, forest areas

and so on).
Fill DEM
1 -

Draw a polygon on the DEM using " Draw Polygon instrument to indicate the area, that should
be edited.

2. Select Fill... command from the context menu of the selected polygon.

3. Specify the filling method (Constant, Best fit plane, IDW interpolation and Natural Neighbour
interpolation filling) and parameters for this method in the Fill DEM dialog window.

4. To apply al the changes click Update on the Toolbar or Update DEM command from the DEM
submenu of the Tools menu.
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4 Note

 Fill DEM tool appliesonly to polygons.

Fill DEM parameters

Fil DEM

General

Filling method: Constant

Fill elevation (m): 145,251

Exdude nested polygons

Lo ] concel |

"Fill DEM" dialog

In Metashape available the following Fill methods: Constant filling, Plane best fit filling, IDW
interpolation and Natural Neighbour interpolation filling.

Constant filling method
The surface will be created according to the level set in the Fill elevation (m): field. The value of the
constant can be entered from the keyboard or selected on the DEM with the cursor (for the purpose
use Pick button and click on the DEM outside the polygon). Enable Exclude nested polygons option
to fill the surface with one height, but exclude some area (also draw a polygon around the object that
isto be excluded before using the Fill DEM toal).

Best fit planefilling method
The best fit plane is calculated basing on the vertices of the drawn polygon in this method. Best-fit
plane filling can be helpful when the object is not flat, for example when sloped roof surface should
be edited. If Sample edges is enabled then the entire face and the edges will be taken into account
when calculating the best fit plane.

IDW interpolation
Inverse distance weighting(IDW) interpolation method that determines the value of pixels using a
linearly weighted combination of aset of pointsor pixels. Weight istheinversefunction of the distance
from known points or pixels, raised to the power. In Metashape the power value by default is 2, it
can be changed in the Fill DEM dialog window. If the power valueis greater then 2, the points closer
to the query location will have more influence and the resulting surface will be more detailed, lesser
value results in more homogeneous surface.

Neighbour interpolation filling
The Natural neighbor method of spatial interpolation isdevel oped by Robin Sibson. Thisinterpolation
method finds the subset of input samples closest to the requested point and applies weights based on
proportional regions to them to interpolate the value.

Create Breakline

Create Breakline tool uses the algorithm that approximates right and left neighborhoods of the polyline/
polygon with planes. This tool helps to correct the roof edges while saving time on manual tracing of
the interior and exterior of the roof followed by filling the corresponding polygons with constant filling
method.
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Create Breakline

Draw a polygon or polyline on the DEM using " Draw Polygon instrument to indicate the area,
that should be edited.

2. Select Create Breakline command from the context menu of the selected polygon.

3. To apply al the changes click Update on the Toolbar or Update DEM command from the DEM
submenu of the Tools menu.

To undo the changes, select Edit DEM > Delete Patch command from the shape context menu. The Delete
Patch command only works before the changes are applied to the DEM. If the DEM was updated, then it
will be impossible to cancel the application of patches to the DEM. To undo changes after the DEM was
updated it is necessary to re-build the DEM and start the editing again.

Configure custom basemap

Metashape supports custom basemap. The functionality allows to use custom basemaps. The list of
connected maps will be displayed in the Basemap List dialog box.

4 Note

e Only XYZ tile servicesin Web Mercator projection are supported.

Add custom basemap

1. Click Customize... button in the Basemap drop-down list from thetoolbar in the Ortho or Model view.
2. Click Add... button on the Basemap List dialog window.

3. Specify Titleand URL for the custom basemap in the Add Basemap dial og window.

4. Click OK buttonin the Add Basemap dial og window. The added basemap will display in the basemap
list.

5. To edit and remove basemap use corresponding buttons (Edit, Remove) in the Basemap List dialog
window.

6. Select the added basemap layer from the basemap list to be displayed in the Ortho or Model view.
The following parameters can be changed in the Add Basemap dialog window:

Title
Indicates the name that will be displayed in the drop-down list in the interface.

URL
The basemap URL that has been entered. URL template supports the following tokens: {x}, {y}, {Z}
- tile column, row and zoom level; {af}, {1-4} - alist of subdomains to iterate through.

Max zoom
The parameter that sets the detalization of the basemap display. |.e. it is possible to adjust the number
of approximation levels.

HTTP Headers
This option alows to set headersiif the service providing tiles requiresiit.
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In Metashapeit is possible to save the basemap list in the Agisoft Basemap List (*.xml) format, and import
it into the project using the corresponding buttons in the Basemap List dialog window (bottom right corner
of the dialog window).

Editing textures

Remove lighting

Metashape can delight texture automatically. Generally, removing shadows and recovering lighting-
neutral color while preserving texture features isimpossible - at least because of ambiguity between dark
texture produced by shadows on surface and dark texture produced by dark regions of the surface. But in
practice in many cases heuristics based on some assumptions can provide good results.

Texture delighting tool smooths out dark and light sides of object model and can additionally light up
surface areas that were found to be too dark with respect to ambient occlusion map.

1. Open project with textured model. In case the external model should be delit, the empty project or new
chunk can be created, add new chunk selecting Add Chunk command from the Workspace context
menu and then import textured mesh using Import Model command in the Import submenu of File
menu.

2. Duplicatemodel. To be ableto compare delighted texture with the original one afterwards, you should
preliminary duplicate the model and then delight only the second one. To duplicate the model, right
click on Workspace 3D Model and select Duplicate.

3. Select Remove lighting command from the Mesh submenu of the Tools menu.

In the Remove lighting dialog box select the kind of parameters to be performed. Options include: color
mode, presets and ambient occlusion. Click OK button when done.

Color mode
You can use two types color mode: Single color and Multi color. Use Single color if the model is
homogeneous and use Multi color if scene presents a combination of the colors.

Presets
Preset configures advanced parameters for some specia cases.

Aggressive (for rocks)
Preset, it is adjusted for delighting of rocks, but still sometimes can lead to artefacts.

Ambient occlusion map
Optionally, you can load into M etashape ambient occlusion texture map and the tool will try to recover
ambient occlusion dark areas on the model.

Resize texture

M etashape supports texture resizing. Select Resize texture command from the Mesh submenu in the Tools
menu to change the size of the texture.

In the Resize texture dialog box set the diffuse map size in pix. Click OK button when done.

Diffuse map size (pix)
Y ou can set the parameters for resizing texture in order to upscale or downscale it.
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Using chunks

When working with typical datasets, automation of general processing workflow allowsto perform routine
operations efficiently. Metashape alows to assign several processing steps to be run one by one without
user intervention thanks to Batch Processing feature. Manual user intervention can be minimized even
further dueto 'multiple chunk project' concept, each chunk to include onetypical dataset. For aproject with
several chunks of the same nature, common operations available in Batch Processing dialog are applied to
each selected chunk individualy, thus allowing to set several data setsfor automatic processing following
predefined workflow pattern.

In addition, multiple chunk project could be useful when it turns out to be hard or even impossible to
generate a 3D model of the whole scene in one go. This could happen, for instance, if the total amount
of photographs is too large to be processed at a time. To overcome this difficulty Metashape offers a
possibility to split the set of photos into several separate chunks within the same project. Alignment of
photos, building point cloud, building mesh, and forming texture atlas operations can be performed for
each chunk separately and then resulting 3D models can be combined together.

Working with chunks is not more difficult than using Metashape following the general workflow. In fact,
in Metashape always exists at |east one active chunk and all the 3D model processing workflow operations
are applied to this chunk.

To work with several chunks you need to know how to create chunks and how to combine resulting 3D
models from separate chunks into one model.

Creating a chunk

To create new chunk click on the & Add Chunk toolbar button on the Workspace pane or select Add
Chunk command from the Workspace context menu (available by right-clicking on the root element on
the Workspace pane).

After the chunk is created you may load photos in it, align them, generate point cloud, generate mesh
surface model, build texture atlas, export the models at any stage and so on. The models in the chunks
are not linked with each other.

Thelist of all the chunks created in the current project is displayed in the Workspace pane along with flags
reflecting their status.

The following flags can appear next to the chunk name:

R (Referenced)
Indicates that 3D model in the chunk was referenced. Also will appear when two or more chunks are
aligned with each other. See information on how to reference the model in Coordinate system.

S (Scaled)
Indicates that 3D model in the chunk was scaled based on scale bars information only, with no
reference coordinates data being present. See information on scale bar placement in Optimization
section.

T (Transformed)
Indicates that 3D model has been modified manually with at least one of the following instruments:

[ 1Y . . P, .
“I# Rotate object, & Move object or ““& Scale object.
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To move photos from one chunk to another simply select themin thelist of photos on the Wor kspace pane,
and then drag and drop to the target chunk.

4 Note

» Chunk can contain several instances of the same object (point clouds, 3D model, etc).

Working with chunks

All operations within the chunk are carried out following the common workflow: loading photographs,
aligning them, generating point cloud, building mesh, building texture atlas, exporting 3D model and so on.

Note that all these operations are applied to the active chunk. When anew chunk is created it is activated

automatically. Save project operation savesthe content of all chunks. To save selected chunks as aseparate
project use Save Chunks command from the chunk context menu.

To set another chunk as active
1. Right-click on the chunk title on the Workspace pane.

2. Select Set Active command from the context menu.

To remove chunk
1. Right-click on the chunk title on the Workspace pane.
2. Select Remove Chunks command from the context menu.

To rearrange the order of chunksin the Workspace pane ssimply drag and drop the chunksin the pane.

Aligning chunks

After the "partia" 3D models are built in several chunks they can be merged together. Before merging
chunks they need to be aligned.

To align separate chunks
1. Select Align Chunks command from the Workflow menu.

2. Inthe Align Chunks dialog box select chunks to be aligned, indicate reference chunk with a double-
click. Set desired alignment options. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.
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Aligning chunks parameters

Align Chunks

Chunk 1 (221 cameras, 11 markers, 435,468 poi...
Chunk 2 (221 cameras, 10 markers, 392,772 ...

General

Method: Point based

Fix scale

Image Matching

Accuracy: High
Key point limit: 40,000
Apply masks to: lone

Generic preselection

Lok ] Cancel

"Align Chunks" dialog

Thefollowing parameters control the chunksalignment procedure and can be modified in the Align Chunks
diaog box:

Method
Defines the chunks alignment method. Point based method aligns chunks by matching photos across
al the chunks. Marker based method uses markers as common points for different chunks. The
details on using markers are available in the Coordinate system section. Camera based method is
used to align chunks based on estimated camera locations. Corresponding cameras should have the
same label.

Accuracy (Point based alignment only)
Higher accuracy setting hel psto obtain moreaccurate chunk alignment results. L ower accuracy setting
can be used to get the rough chunk alignment in the shorter time.

Point limit (Point based alignment only)
The number indicates upper limit of feature points on every image to be taken into account during
Point based chunks alignment.

Fix scale
Option is to be enabled in case the scales of the models in different chunks were set precisely and
should be left unchanged during chunks alignment process.

Preselect image pairs (Point based alignment only)
The alignment process of many chunks may take a long time. A significant portion of thistime is
spent for matching of detected features across the photos. Image pair preselection option can speed
up this process by selection of a subset of image pairs to be matched.
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Apply mask to (Point based alignment only)

If apply mask to key points option is selected, areas previously masked on the photos are excluded
from feature detection procedure. Apply mask to tie points option means that certain tie points are
excluded from alignment procedure. Effectively thisimpliesthat if some areais masked at least on a
single photo, relevant key points on the rest of the photos picturing the same areawill be also ignored
during alignment procedure (atie point is a set of key points which have been matched as projections
of the same 3D point on different images). This can be useful to be able to suppress background in
turntable shooting scenario with only one mask. For additional information on the usage of masks
please refer to the Using masks section.

4 Note

¢ Chunk alignment can be performed only for chunks containing aligned photos.

» Thereis no need to perform chunk alignment for georeferenced chunks, as they are already in
the same coordinate frame.

Merging chunks

After dignment is complete the separate chunks can be merged into a single chunk.

4 Note

* Werecommend processing all theimagesin asingle chunk to provide better accuracy and quality
of thefinal results than the chunking method (separate processing of the sub-sets of the complete
photos set and merging them).

To merge chunks

1

2.

Select Merge Chunks command from the Workflow menu.

In the Merge Chunks dialog box select chunks to be merged and the desired merging options. Click
OK button when done.

M etashape will merge the separate chunksinto one. The merged chunk will be displayed in the project
content list on Workspace pane.
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Merge chunks parameters
Merge Chunks

Chunk 1 (813 cameras, 7 markers, 4,748,556 points)...
Chunk 2 (1035 cameras, 10 markers, 5,940,318 poin...

Assets
Depth maps Models
Point douds Laser scans
DEMs Tiled models

Orthomosaics

Parameters
Mer

rge tie points Merge assets

Merge markers

Lo ] cancel |

"Merge Chunks' dialog

Thefollowing parameters control the chunks merging procedure and can be modified in the Merge Chunks
diaog box:

Depth maps
Definesif depth maps from the selected chunks should be merged / copied to the resulting chunk.

Models
Definesif models from the selected chunks should be merged / copied to the resulting chunk.

Point clouds
Definesif point clouds from the selected chunks should be merged / copied to the resulting chunk.

Laser scans
Definesif laser scans from the selected chunks should be merged / copied to the resulting chunk.

DEMs
Definesif DEMs from the selected chunks should be merged / copied to the resulting chunk.

Orthomosaics
Definesif orthomosaics from the selected chunks should be merged / copied to the resulting chunk.
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Tiled models
Definesif tiled models from the selected chunks should be merged / copied to the resulting chunk.

Merge markers
Defines if markers from the selected chunks are merged (only markers with the same labels would
be merged).

Mergetie points
Defines if the projections of the tie points for corresponding features should be merged. Since tie
points merging operation assumes re-matching of the features from different chunks, the operation
may be time consuming. Thus it is recommended to disable tie points merging, unlessit is required
by the task specifics.

Merge assets
Defines, if the processing results selected in the Assets section should be merged to a single asset
of the same type. Selecting Merge Assets option would merge the active assets of the selected types
from the selected chunks to a single asset of the same type in the merged chunk. In case the option
is unchecked, all the assets of the selected types from the source chunks will be copied individually
to the merged chunk.

Chunks merging result (i.e. images, point clouds and geometry) will be stored in the new chunk and it may
be treated as an ordinary chunk (e.g. the models can be textured and/or exported).

£ Note

« Merging operations will be applied only to the active assets. Disabled (inactive) assets will not
be transferred to the merged chunk, unless Merge Assets option is unchecked. In the latter case
all the assets (both active and inactive) will be copied asindependent assets to the merged chunk.
All assets of Laser Scansand Tiled Model type will be copied to the merge chunk independently,
regardless of the Merge Assets option selection.

Batch processing

M etashape allows to perform general workflow operations with multiple chunks automatically. It isuseful
when dealing with alarge number of chunks to be processed.

Batch processing can be applied to all chunks in the Workspace, to unprocessed chunks only, or to the
chunks selected by the user. Each operation chosen in the Batch processing dialog will be applied to every
selected chunk before processing will move on to the next step.

General Workflow Import/Export Miscellaneous

Align Photos Import Cameras Align Chunks

Build DEM Import Markers Cadlibrate Colors

Build Mesh Import Masks Calibrate Reflectance

Build Orthomosaic Import Shapes Classify Ground Points

Build Panorama Export Cameras Classify Points

Build Point Cloud Export DEM Close Holes

Build Texture Export Model Colorize Model

Build Tiled Model Export Orthomosaic Colorize Point Cloud
Export Point Cloud Convert Images
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General Workflow Import/Export Miscellaneous

Export Texture Decimate Mesh

Export Tiled Model Detect Markers

Generate Report Generate Masks
Generate Prescription Map
Load Project
L ocate Reflectance Panels
Merge Chunks
Optimize Alignment
Refine Mesh
Remove Lighting
Reset Region
Run Script
Save Project
Smooth Model

To start batch processing
1. Select Batch Process... command from the Workflow menu.
2. Click Add to add the desired processing stages.

3. Inthe Add Job dialog select the kind of operation to be performed, the list of chunks it should be
applied to, and desired processing parameters. Click OK button when done.

4. Repeat the previous steps to add other processing steps as required.
5. Arrange jobs by clicking Up and Down arrows at the right of the Batch Process... dialog box.
6. Click OK button to start processing.

7. Theprogressdialog box will appear displaying thelist and status of batch jobs and current operation
progress. To cancel processing click the Cancel button.
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Batch Process X

Order  Job Type Applies To

1 Align Photos All Chunks
2 Build Point Cloud All Chunks

3 Build DEM All Chunks
4 Build Orthomos... All Chunks
5 Build Mesh All Chunks
&  Build Texture All Chunks

Export Orthom...  All Chunks

- =]

Save project after each step
"Batch Process" dialog

When the batch process includesimport/export features that are applied to multiple chunksit isreasonable
to use the following templates in the Path field of the import/export jobs:

« {filename} - filename (without extension),

{fileext} - file extension,

» {camera} - cameralabel,

{frame} - frameindex,

{chunklabél} - chunk label,

{imagefolder} - folder containing images of an active chunk,

{projectfolder} - path to the folder containing current project,
» {projectname} - current project filename,

» {projectpath} - absolute path to the current project.

The list of tasks for batch processing can be exported to XML structured file using ﬂ Save button in the

Batch processing dialog and imported in a different project using ' Load button.

4D processing

Overview

M etashape supports reconstruction of dynamic scenes captured by aset of statically mounted synchronized
cameras. For this purpose multiple image frames captured at different time moments can be loaded for
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each camera location, forming a multiframe chunk. In fact norma chunks capturing a static scene are
multiframe chunks with only a single frame |oaded. Navigation through the frame sequenceis performed
using Timeline pane.

Although aseparate static chunk can be used to process photosfor each time moment, aggregate multiframe
chunks implementation has several advantages:

» Coordinate systems for individual frames are guaranteed to match. There is no need to align chunksto
each other after processing.

* Each processing step can be applied to the entire sequence, with a user selectable framerange. Thereis
no need to use batch processing, which simplifies the workflow.

» Accuracy of photo alignment is better due to the joint processing of photos from the entire sequence.
» Markers can be tracked automatically through the sequence.
* Intuitive interface makes navigation through the sequence pretty simple and fast.

Multiframe chunks can be al so efficient (with some limitations) for processing of disordered photo sets of
the same object or even different objects, provided that cameras remain static throughout the sequence.

Managing multiframe chunks

Multiframe layout is formed at the moment of adding photos to the chunk. It will reflect the data layout
used to store image files. Therefore it is necessary to organize files on the disk appropriately in advance.
The following data layouts can be used with Metashape:

a. All framesfrom corresponding cameraare contained in a separate subfolder. The number of subfolders
is equal to the number of cameras.

b. Corresponding framesfrom all cameras are contained in aseparate subfolder. The number of subfolders
is equa to the number of frames.

c. All frames from corresponding camera are contained in a separate multilayer image. The number of
multilayer imagesis equal to the number of cameras.

d. Corresponding frames from all cameras are contained in a separate multilayer image. The number of
multilayer imagesis equal to the number of frames.

Once the data is properly organized, it can be loaded into Metashape to form a multiframe chunk. The
exact procedure will depend on whether the multifolder layout (variants a and b) or multilayer (variants
¢ and d) layout is used.

To create a chunk from multifolder layout

L Select & Add Folder... command from the Wor kflow menu.

2. Inthe Add Folder dialog box browse to the parent folder containing subfolders with images. Then
click Select Folder button.

3. Inthe Add Photos dialog select Dynamic scene (4D) data layout. For layout a) above select Create
camera from each subfolder. For layout b) select Create frame from each subfolder.

4. Created multiframe chunk will appear on the Workspace pane.
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To create a chunk from multilayer images

L Select Add Photos... command from the Workflow menu or click @ Add Photos toolbar button.

2. Inthe Add Photos dialog box browse to the folder containing multilayer images and select files to
be processed. Then click Open button.

3. Inthe Add Photos dialog select the suitable data layout. For layout c) above select Create camera
from each multilayer file. For layout d) select Create frame from each multilayer file.

4. Created multiframe chunk will appear on the Workspace pane.

It isrecommended to inspect the loaded frame sequence for errors. This can be done by scrolling the frame
selector in the Timeline pane and inspecting thumbnails in the Photos pane during scrolling.

In case each frame should be processed completely separately, it is possible to split them using Split
frames... command from the chunk context menu.

Frames can be added from one chunk to another. To do that right-click on the chunk’s label in the
Workspace pane and select Add > Add frames command. In the Add Frames dialog select chunk where
from the frames will be added and click OK button.

After multiframe chunk is created, it can be processed in the same way as normal chunks. For multiframe

chunks additional processing parameters allowing to select the range of frames to be processed will be
provided where appropriate.

Tracking markers

Metashape allows to automatically track marker projections through the frames sequence, provided that
object position doesn't change significantly between frames. This greatly simplifies the task of labeling of
amoving point if the number of framesislarge.

Totrack markersthrough the frame sequence

1. Scroll frame selector inthe Timeline paneto the 1st frame. Add markersfor the 1st frame as described
in the Coordinate system section.

2. Select Track Markers... command from the Markers submenu of the Tools menu.

3. Adjust the starting and ending frameindicesif necessary. Default val ues correspond to tracking from
the current frame to the end of sequence. Click OK button to start tracking.

Check tracked marker locations. Automatically tracked markers will be indicated with “:b icons. In
case of a placement error at some frame, adjust the wrong marker location within the frame where

the failure occurred. Once the marker location is refined by user, the marker icon will changeto HIJ

5. Restart tracking from that frame using Track Markers... command again.

4 Note

 |f the ending frame index is smaller than the starting index, tracking will be performed in the
backwards direction.
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« Automatic marker tracking is likely to fail in case when structured light is used to add texture
details to the object surface, as the light pattern will not be static with respect to the moving
object surface.

Python scripting
Python scripting in Metashape

M etashape supports Python API, using Python 3.9 as a scripting engine.
Python commands and scripts can be executed in Metashape through one of the following options:
1. Metashape Console pane can serve as Python rich console.

2 Click Lé# Run Script button on Console pane toolbar or use£# Run Script... command from the Tools

menu to run a Python script.
From command-line using -r argument.

On Windows:
metashape.exe -r <scriptname.py>

On Linux:
Jmetashape.sh -r <scriptname.py>

On macOS:
/M etashapePro.app/ContentsM acOS/M etashapePro -r <scriptname.py>

From autorun folder.

for Windows: C:/Users/<user>/AppData/L ocal/Agisoft/M etashape Pro/scripts/

for Linux: /home/<user>/.local/share/Agisoft/M etashape Pro/scripts/

for macOS: /Users/<user>/Library/Application Support/Agisoft/Metashape Pro/scripts/
on any OS (for all users): <installation folder>/scripts/

For details on Metashape functionality accessible through Python scripts please refer to Python AP
Reference document available on Agisoft official website (http://www.agisoft.com/downloads/user-
manuals/).

The collection of the sample Python scriptsis available on Agisoft GitHub repository: https://github.com/
agisoft-1lc/metashape-scripts.

Stand-alone Python module
M etashape can be used as Python 3 package for stand-alone Python module devel opment.

To configur e development environment

1. Download Metashape Python 3 module for your platform from Agisoft web-site: https:/
www.agi soft.com/downloads/installer/
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2. Install Metashape Python 3 module

3. Import Metashape Python 3 module and start development: import M etashape

Java API

Metashape Java API allows to integrate photogrammetric processing engine into applications devel oped
using Java programming language. It comes in the form of software library and need to be downloaded
separately from Downl oads section of Agisoft website.

To configure development environment
1. Download Metashape JavaAPI from Agisoft web-site: https://www.agisoft.com/downloads/installer/
2. Unpack downloaded archive and copy libs and jniLibs folders to your project directory.

3. Addjarsfrom thelibs folder to your classpath.

¢ Important
Java garbage collection system may not release memory associated with Metashape objects in a
timely manner as it doesn't know memory consumption of underlying native objects. To prevent
excessive memory consumptionit ishighly recommended to call del ete() method manually for each
object obtained using Metashape Java APl when it is no longer needed.

For details on Metashape Java APl functionality please refer to theincluded javadoc package. Also please
take alook at examples available in the samples directory to get started.
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Chapter 8. Distributed processing

Local network processing

Overview

Agisoft Metashape can be configured to run on a computer cluster where processing is distributed on
several computer nodes connected to alocal network. In such configuration multiple M etashape instances
running on different processing nodes can work on the same task in parallel, effectively reducing the total
processing time needed.

Processing tasks are divided between the nodes on a chunk by chunk or frame by frame basis (when
possible). In addition a more fine grained distribution can be optionally enabled for image matching and
alignment, generation of point clouds, tiled models, DEMs and orthomosaics, as well as mesh generation
from depth maps, in which case processing of individual chunks/frameswill befurther subdivided between
several processing nodes.

Communication between processing nodes, server and clients is performed using TCP connections. In
addition, shared network storage accessible for al processing nodes and clients is used for storing the
source data and intermediate processing results.

Cluster components

Server

—mi Processing Node 1
TCP TCcp
Master Processing Node 2
Server

Processing Node N
Network Storage

The server node coordinates operation of all processing nodes, maintaining a task queue for al projects
scheduled for processing. The clients can connect to the server to start new processing tasks or monitor
progress of existing ones.
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The server itself doesn't perform any processing and can easily run on slow hardware. The server
component is critical for operation of the cluster, and is not fault tolerant. Measures should be taken to
ensure continuous operation of the server node.

The server node accepts TCP connections from processing nodes and clients. Additional slave serverscan
be connected to the master server to perform replication of processing queue for additional fault tolerance
in critical environments.

Processing nodes

Processing nodes perform actual calculations, and thus need to be run on fast hardware. Each processing
node connects to the server on startup and waits for atask to be assigned. Once the task is available, the
node starts processing, informing the server about the progress. When processing is finished, the results
are stored on shared network storage, and the server isinformed about completion. Then a node switches
to the next task when it becomes available.

Processing nodes can be added or removed from the cluster as needed. Abnormal shutdown of processing
node doesn't cause cluster failurein most cases. Nevertheless, it is highly recommended to stop particular
nodes using Agisoft Network Monitor before disconnecting them from the cluster.

Clients

Clients can connect to the server nodeto control cluster operation or to monitor its status. New tasks can be
submitted for processing using Agisoft Metashape software configured as a network client, while cluster
monitoring is performed using Agisoft Network Monitor. Multiple clients can be connected to the server
node simultaneously.

Cluster setup

Before proceeding to the following steps please make sure that shared network storage is accessible from
all processing and client nodes using the same absol ute path. It should be either mounted to the same folder
on al nodes (Linux), or should have the same UNC network path (Windows). In case such configuration
isnot possible (for example in mixed Windows/Linux cluster), a path prefix can be specified on each node
to compensate for the differences.

Starting server

It is recommended to configure server with a static IP address, not dynamically assigned one. This IP
address will be needed for each processing node and client.

The server process can be started by executing M etashape with the following command line arguments:
metashape --server --host <ip>[:port]

--server parameter specifies that Metashape should be started in a server mode.

--host <hostname>[:port] parameter specifies the network interface to be used for communication with
clientsand processing nodes. In case port valueis omitted, the default port 5840 is used. The host parameter
can be specified multiple time, in which case the server will listen for connections on multiple interfaces.

--master <hostname>[:port] parameter switches the server to slave mode and starts replication of the
specified master server. In case port value is omitted, the default port 5840 is used.

Example:
metashape --server --host 10.0.1.1
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In this case Metashape will use 10.0.1.1 interface for both clients and processing nodes with default port
value.

Starting network nodes

The processing node can be started by executing M etashape with the following command line arguments:
metashape --node --host <ip>[:port] [--root prefix]

--node parameter specifies that Metashape should be started as a processing node.

--host <hostname>[:port] parameter specifies IP of the server to connect. In case port value is omitted,
the default port 5840 is used. The host parameter can be specified multiple times, in which case the node
will automatically connect to the next server in the list if the previous one becomes unavailable. Thisis
useful when using slave servers.

--root <path> parameter can be used to specify network storage mount point or prefix path in case it is
not the same across network.

--priority <priority> parameter can be used to specify the priority of the node. Higher number means
higher priority.

--capability {cpu, gpu, any} parameter can be used to specify whether the node should work on CPU-
only tasks, GPU-supported tasks only or will receive any tasks.

--gpu_mask <mask> parameter set GPU device mask for GPU-supported tasks.

--cpu_enable {0,1} parameter can be used to enable or disable CPU during the GPU-supported tasks.
--absolute paths{0,1} parameter can be used to set the absol ute paths option.

--timestamp parameter can be used to append timestamps to the output messages.

--auto-submit parameter can be used to enable automatic crash report submission.

--email <address> parameter specifies email address to be included in the crash reports.

--comment <text> parameter specifies optional comment to be included in the crash reports.

Example:
metashape --node --host 10.0.1.1 --r oot /mnt/datasets

This command will start processing node using 10.0.1.1 as a server |P with default port 5840.

Checking cluster status

Start Agisoft Network Monitor application. In the host name field enter server IP used for client
connections (10.0.1.1 in our example). Modify port values in case non-default port was specified. Click
Connect button when done.

A list of available network nodes currently connected to the server will be displayed in the bottom part of
the window. Please make sure that all started processing nodes are listed. Agisoft Network Monitor for
each node allowsto modify the node priority, capability, CPU enable flag, GPU mask and to pause/resume
the node. The priority for the tasks can be a so atered and tasks themselves can be paused, resumed and
aborted via Agisoft Network Monitor.

Thetop part lists tasks currently being processed (finished tasks are removed from the list as soon as they
are completed). The task list will be empty if no processing was started yet.
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Starting network processing
1. Configure Agisoft Metashape for network processing.
Start Agisoft Metashape on any computer connected to the cluster network.

Open Preferences dialog using Preferences... command from the Tools menu. On the Network tab
make sure Enable network processing option is turned on, and specify the server IP used for client
connection in the Host name field. In case non-default port was configured on a server, modify the
port value accordingly.

In case you are going to process afew single-frame chunks with large number of photos, please make
sure that Enable fine-level task subdivision option is turned on in the Advanced tab of Preferences
dialog. The subdivision will be automatically applied when possible to all the supported operations
(Match Photos, Align Cameras, Build Depth Maps, Build Mesh from Depth Maps, Build Point Cloud,
Build Tiled Model, Build DEM, Build Orthomosaic, Classify Points). In case you are going to process
alarge number of small chunks, or chunks with large number of frames, fine-level task subdivision
can be disabled, therefore each chunk or frame will be processed on the single node only without any
further internal distribution applied.

Press OK button when done.
2. Prepare project for network processing.

Open the project fileto be processed. Make surethat the project is saved in M etashape Project (*.psx)
format. Processing of projectsin Metashape Archive (*.psz) format isnot supported in network mode.

¥ Important

Please make sure that source images are located on shared network storage and not on alocal
hard drive. Otherwise processing nodes will be unable to load them.

3. Start processing.

Start processing using corresponding command from the Workflow menu, or using Batch Process
command to execute a command sequence. A network progress dialog should appear displaying
current progress.

4. Wait for processing to complete.

You can disconnect from the server at any time using Disconnect button in the Network Progress
dialog in case you need to work on other projects. Processing will continue in the background.

To see processing status after you have disconnected from the server simply open corresponding .psx
project on the network storage. Alternatively you can use Agisoft Network Monitor to see processing
status for all projects being processed.

5. Inspect processing results.

After processing is finished, click Close button to close Network Progress dialog. The project with
processing results will be displayed in M etashape window.

Access to the network processing server via the web interface

It isalso possible to connect to the network processing server viathe web interface. To open web interface
specify host name and port number in the following format - 100.101.0.1:5555 (host name:port number)
in the address bar and press Enter on the keyboard.
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The web interface displays the same information as the Agisoft Network Monitor. The same options are
also availablewhen working with tasks and nodesviatheweb interface. Thelist of available network nodes
currently connected to the server are displayed in the bottom part of the window. Use context menu (click
the right mouse button on the section to be configured) to modify the priority, capability, CPU enable,
GPU mask and to pause/resume the node and so on.

The optionsthat were launched in the Agisoft Network Monitor viathe File menu (Export Batches, Import

Batches, Set Master Server, Reset Master Server, Scheduling Mode, Preferences) will not be available in
the web interface.

Cluster administration

Adding processing nodes

New processing nodes can be added by starting Agisoft M etashape on additional computersin the network
node mode, as outlined in the Starting network nodes section above.

Removing processing nodes

Aborting or disconnecting processing node during cluster operation is not absolutely safe, and can lead to
project corruption if performed during final project update at the end of processing. Although the chances
of this situation are relatively low, we strongly recommend against such approach. To safely disconnect
processing node from the cluster you need to stop processing on this node using Agisoft Network Monitor
first.

1. Start Agisoft Network Monitor. Make sure the server IPis properly configured in the host namefield
and click Connect button.

2. In the bottom list of network nodes identify the node to be removed. From the node menu select
Pause command to stop the node after it finishes current job, or Stop command to abort processing
immediately.

3. Wait until the Batch # and Progress items for a selected node become empty. This indicates that the
node has finished processing. The status of the node should be Paused.

4.  Now you can safely disconnect the node by aborting M etashape process.
Using server replication

In case of abnormal termination of the server node processing queue will be lost, and all incompl ete tasks
will need to be restarted from the beginning. To avoid such problem it is possible to set up one or more
dave servers, that will be automatically synchronized with a master server. In case of a master server
failure, it will be possible to resume processing by switching to the one of the available slave servers.

Here is an example setup of a cluster with a server replication:

metashape --server --host 10.0.1.1

metashape --server --host 10.0.2.1 --master 10.0.1.1

metashape --node --host 10.0.1.1 --host 10.0.2.1 --root /mnt/datasets

These commands will start amaster server at 10.0.1.1 interface and aslave server on 10.0.2.1 interface. In

addition a node will be configured to look for an active master server at 10.0.1.1 and 10.0.2.1 addresses.
In case of amaster server failure the node will automatically reconnect to another master server.
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¥ Important

¢ In case of a master server failure, slave servers will not switch to a master state automatically.
An operator will need to switch one of the slave servers to a master state manually using Reset
Master Server command from the Agisoft Network Monitor File menu and connect remaining
dlave servers to a new master. In the unattended environment this can be automated using a
Python or Java API.

» Before switching to a new master server please make sure that original master server is disabled
and will not be unexpectedly restored (due to a temporary network failure for example).
Simultaneous operation of two master serverswill result in inconsistent project state and further
processing will fail.

Installing server and nodes as a Windows service
It is possible to configure server and nodes to run as a service on Windows. In thislog in.
The following command line parameters are used to manage Windows service settings:
--service {install,remove,start,stop} parameter can be used to configure Windows service.

--ser vice-name <name> optional parameter for Windows service name. Required when multiple services
needs to be installed on the same computer.

Examples:

metashape --service install --node --host 10.0.1.1 --r oot /mnt/datasets
metashape --service install --server --host 10.0.1.1

metashape --service start

metashape --service stop

metashape --service remove

4 Note

¢ These commands must be executed from Administrators Command Prompt as they require
elevated privileges.

Cloud processing

Overview

Agisoft Metashape presents cloud processing option integrated into the application user interface for
those who are interested in high quality outputs for big datasets, without need to invest into hardware
infrastructure.

Starting cloud processing

Cloud processing option is only accessible for those Metashape license owners who have registered on
Agisoft Cloud page: https://cloud.agisoft.com/. Personal account page provides information about current
subscription plan, storage space and processing hours available, projects published in the cloud, invoices
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and personal data. Having completed the registration and having chosen the appropriate payment plan,
one should input Agisoft Cloud account credential s to the Network tab of Preferences dialog in Metashape
application.

Setting up cloud processing in M etashape
1. Select Preferences command from the Tools menu.

2. Input your Agisoft account credentials to the Network tab in Preferences dialog.

3. Check thebox for Enable cloud processing optionto turnit on. Check that Enable network processing
option isturned off.

4. Click OK button when done.

Once the cloud processing option is enabled, each time the processing operation is run in Metashape a
confirmation dialog will appear, asking if the operation should be executed locally or in the cloud. If
the cloud processing option is selected in the dialog, the project data and related source imagery will be
upl oaded/synchronized with the datain your personal Agisoft Cloud account. To monitor the status of the
project, you can use Project tab on the personal account page.

Do not disable Internet connection nor shut down the computer when upl oading processisin progress. Y ou
can disconnect, however, once the processing has been started according to the indication in the program
interface and in the web interface of your personal account.

Next time you open a local project for which a processing operation in Agisoft Cloud is finished the
updated project files will be downloaded from the cloud and synchronized with your local project copy.

Download project from the cloud

To download project from the cloud
1. Select Download Project... command from the Cloud submenu of the File menu.
2. Select the project to be downloaded from the list.

3. Click OK to start the download process.

Visualize project results

To make cloud project available for visualization in web interface, it is necessary to publish it, first.
Publication is a process of preparing processing results for 3D visualization in web interface. The
publication is only available for georeferenced PSX projects. Each publication takes up storage space.

When processing a new project in Agisoft Cloud for the first time, you may check Publish results option
in the Schedule processing in the cloud Metashape dialog. If Publish results option is checked on during
the first processing of the current project in Agisoft Cloud, results of further processing iterations for the
same project will be published automatically.

Furthermore, it is possible to publish project via Agisoft Cloud web interface.
When the project is published, use View button to inspect project results.
To unpublish the project (i.e. disable the possibility to view the project processing results online) use

Unpublish button on the projects page of your personal account. The Unpublish button is available when
the project is selected from the list.
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Upload project into the cloud

If the cloud processing option is enabled and properly configured (valid email and password are input to
the Network tab of Preferences dialog) in Metashape, each time the processing operation in run in Agisoft
Cloud, a synchronization procedure will be started and the source imagery together with the project file
directory will be uploaded to your Agisoft Cloud account.

Optionaly, it is possible to upload project to Agisoft Cloud from Metashape user interface manualy,
without running any processing operation.

To upload project into the cloud
1. Select Upload Project... command from Cloud submenu of the File menu.

2. Click Yes button to confirm the operation and start the upload process.

Download photos from the cloud

To download photos from the cloud
1. In Metashape user interface open the project which the photos should be downloaded for.
2. Select Download Photos... command from the Cloud submenu of the File menu.

3. Inthe Download Photos dialog specify the target folder for the images and select the images to be
downloaded from the list.

4. Click OK to start the download process.

4 Note
« Cloud processing is supported only for projects saved in Metashape Project (*.psx) format.

< All the files related to a certain project can be removed to free the disk space available for the
subscription plan from your personal account in Agisoft Cloud web interface.

« Some operations do not support processing in the cloud (for example, no of the export operations
are supported). If the Batch Process task sent to the Cloud includes such operations, the warning
message will be displayed and the batch processing task list should be adjusted before sending
it to the Agisoft Cloud again.

Share cloud project

In Agisoft Cloud the following project sharing methods are available: share aproject with alink and share
aproject viaemail. Each project by default isin private mode. When private mode is activated, only the
owner of the project has access to view project visualization in the web interface and download it via
M etashape desktop application.

To shareproject with alink

1. Click onthe Share button on the project visualization page or select Share option in the project menu
on My Projects page.

2. Inthe Share pop-up window select Anyone with the link can view option from the dropdown menu,
copy the link and close the pop-up window.
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When share with a link option is activated, each person who has the link will be able to view project
visualization in web interface without need to create an account on Agisoft Cloud.

In caseit is needed to securely share the project with a person or anumber of people, it is possibleto share
published or unpublished projects by including someone's email into the sharing list. When share viaemail
option is activated, invited users will have access to view the project visualization in web interface and
download its copy via Metashape desktop application.

To securely share project via email

1. Click the Share button on the project visualization page or select Share option in the project menu
on My Projects page.

2. Inthe Share pop-up window select Invited people can view and download option from the dropdown

menu, insert email of the person who you want to grant the access to the project to and click the Invite
button. Then close the pop-up window.

[{ Note

» Those who have an account on Agisoft Cloud will be notified by email and granted the access
to view the project visualization in web interface and download its copy via M etashape desktop
application.

» Those who have no account on Agisoft Cloud will be invited via email to create an account to

be able to view the project visualization in web interface and download its copy via Metashape
desktop application.

To turn off sharing and switch the project to the private mode

1. Click Share button on the project visualization page or select Share option in the project menu on
My Projectspage.

2. Inthe Share pop-up window select Turn off sharing option in the project menu on My Projects page.
To closethe accessto the project to a certain person

1. Click the Share button on the project visualization page or select Share option in the project menu
on My Projectspage.

2. Delete email of aperson who you want the access to the project be closed to by clicking the Delete
button represented as a cross mark. Then close the pop-up window.
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Appendix A. Graphical user interface
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General view of application window

Model view

Model view tab is used for displaying 3D data as well as for mesh and point cloud editing. The view of
the model depends on the current processing stage and is also controlled by mode selection buttons on
the Metashape toolbar.

Model can be shown as a dense cloud, with class indication or without, or as a mesh in shaded, solid,
wireframe or textured mode. Along with the model the results of photo alignment can be displayed. These
include tie point cloud and camera positions visualized data. Additionally tiled textured model can be
displayed and navigated in the model view.

M etashape supports the following tools for navigation in the 3D view:

Tool K eyboard modifier
Rotation Tool Default

Pan Tool Ctrl key pressed
Zooming Tool Shift key pressed

All navigation tools are accessible in the navigation mode only. To enter the navigation mode click the

L'ET Navigation toolbar button.
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Metashape offers two different navigation modes. Object navigation and Terrain navigation. Switching
between the navigation modes can be performed from the Navigation Mode submenu of the View menu.
Object navigation mode allows for 3-axis rotation control, while Terrain navigation mode restricts control
to 2-axisrotation only, z-axis being kept vertical all the time.

In Object navigation mode the rotation with mouse can be performed while left mouse button is pressed,
whereas holding right mouse button allows for model tilt. In Terrain navigation mode mouse buttons
functionality isinverted and left button is responsible for tilt, whereas right button for rotation.

4 Note

e Zooming into the model can be also controlled by the mouse wheel.

Ortho view

Ortho view is used for the display of 2D processing results data: digital elevation model, full resolution
orthomosaic, raster transformed orthomosaic as well as shapes data. Switching between DEM and
orthomosaic can be performed using the corresponding button on the toolbar or by double-clicking on the
respective icon on the Workspace pane, providing that both products have been generated.

Orthomosai ¢ can be displayed in the original colors or in colors according to the palette set for vegetation
index values visualization.

Additional instruments allow to draw points, polylines and polygons on the orthomosaic and/or digital
elevation model to perform point, linear, profile and volume measurements. Also polygonal shapes are
allowed to be set up as inner or outer boundaries, that will be used for the definition of the area to be
exported. Using polygonal shapes allows to create custom seamlines on the orthomosaic, which can be
useful for some projects enabling to eliminate blending artefacts.

Switching to Ortho view mode changes the contents of the Toolbar, presenting related instruments and
hiding irrelevant buttons.

Photo view

Photo view tab is used for displaying individual images as well as corresponding depth maps in semi-
transparent representation, markers, shapes and masks on them.

In the Photo view tab it is allowed to create markers, refine their projections, draw shapes and adjust
positions of shape vertices and to draw masks on the images. Additionally in Photo view tab it is possible
to display the residuals for the tie points and markers providing that the corresponding camerais aligned.

Photo view isvisible only if any image is opened. To open an image in Photo view mode double-click on
the label of the corresponding camera on the Workspace, Reference or Photos pane.

For multicamera systems which have several sensors assigned to the same layer Photo view tab will be
vertically split into corresponding number of sub-frames.

Switching to Photo view mode changes the contents of the Toolbar, presenting related instruments and
hiding irrelevant buttons.

Workspace pane

On the Workspace pane al elements comprising the current project are displayed. These elements can
include:
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 List of chunksin the project

* List of images and image groupsin each chunk

* List of laser scans and laser scan groups in each chunk
» Componentsin each chunk

* List of markers and marker groups in each chunk
 List of scale barsand scale bar groupsin each chunk

* List of shape layersin each chunk

 Tiepointsin each chunk

» Depth mapsin each chunk

+ 3D modelsin each chunk

* Tiled modelsin each chunk

* Point cloudsin each chunk

+ Digital elevation modelsin each chunk

» Orthomosaicsin each chunk

* Panoramasin each chunk

» Cameratracksin each chunk

Buttons located on the Workspace pane toolbar allow to:
* Add chunk

* Add photos

* Add marker

* Create scale bar

» Enable or disable certain cameras or chunks for processing at further stages.
* Removeitems

Each element in the list is linked with the context menu providing quick access to some common
operations.

Photos pane

Photos pane displaysthelist of photos/ masks/ depth mapsin the active chunk in the form of thumbnails.
Buttons located on the Photos pane toolbar allow to:
» Enable/ disable certain cameras

¢ Remove cameras
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* Rotate selected photos clockwise / counterclockwise (for display purposes only)

» Reset current photo filtering option

Switch between images / masks / depth maps thumbnails

* Increase/ decreaseicons size or display detailed information on photosincluding EXIF data

Console pane

Console paneis used for:

 Displaying auxiliary information

 Displaying error messages

* Python commands input

Buttons located on the Console pane toolbar allow:

e Savelog (inHTML, XHTML or Plain Text format)
* Clear log

* Execute Python script

Reference pane

Reference pane is designed for:

 Displaying and editing cameraand / or marker coordinates
 Displaying and editing scale bars lengths

» Displaying and editing camera orientation angles

» Displaying estimation errors

» Displaying and editing accuracy parameters for camera/marker coordinates, camera angles and scale
bar lengths

Buttons located on the pane toolbar allow:
» Import / export reference coordinates and import reference data from EXIF meta data
» Convert reference coordinates from one system to the other

» Optimize camera alignment and update data

Switch between source coordinates, estimated coordinates, errors and variance values

» Specify the coordinate system and measurement accuracy to be assumed through Settings dialog

Shape Properties pane

Properties pane is designed for:
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 Displaying and editing labels for selected shapes

 Displaying and editing description for selected shapes

 Displaying and editing existing attribute values for selected shapes

» Adding new attributes for the selected shape

» Assigning shape layer to the selected shapes

* Editing label and style for shape layer assigned to the selected shapes
Buttons located on the pane toolbar allow:

o Add attribute

» Remove attribute

Jobs pane

Jobs pane is designed for:

» Monitoring the processing status for active and background projects
 Organizing the background processing queue

 Switching between the projects

Buttons located on the pane toolbar allow:

 Start / pause/ cancel the selected tasks

* Clear the processing tasks history

» Change the order of the tasks in the processing queue

4 Note

« You can switch between projects by right-clicking on the project name.

Timeline pane
Timeline pane is designed for:
» Working with multi-frame chunks
Buttons located on the pane toolbar allow:
* Add/ remove frames from chunk
» Play / stop frame sequence

 Adjust frame rate through Settings dialog

Animation pane
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Animation pane is designed for:

Creating anew cameratrack from pre-sets(Horizontal, Vertical) with the given number of the keyframes
Loading cameratrack from external file in supported formats (Autodesk FBX, Camera Path)
Exporting camera track

Playing the viewpoint camera movement according to the track

Rendering the frame sequence to the form of the separate images for the keyframes

Rendering the frame sequence to the form of the video file

Appending current viewpoint to the cameratrack

Removing keyframes from the camera track

Changing the selected keyframes positions in current camera track sequence and updating selection
viewpoint

Setting the cameratrack parameters (label, duration, field of view, loop cameratrack)

Buttons located on the pane toolbar allow:

Create new track

Load cameratrack

Save camera track

Start / stop the animation according to the camera track
Capture video file

Append current viewpoint to the active cameratrack
Remove selected keyframes from the active camera track
Move selected keyframes up

Move selected keyframes down

Update selected keyframe to the current viewpoint

Change cameratrack settings

4 Note

« To open any pane select a corresponding command from the View menu.

e Todisplay the track path, select Show animation in Show/Hide items submenu from the Model
menul.

« You can adjust the position of the viewpoint in Model view by dragging the left mouse button
to display it visually.
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Menu commands

FileMenu
EI New Creates an empty M etashape project.
Open... Opens Metashape project file.
Append... Appends existing Metashape project file to the

HSave

Save As...
Upload Project...

Download Project...

Download Photos...

Export Point Cloud...

Export Model...

Export Tiled Modd...

Export Orthomosaic...

Export DEM...

Generate Report...
Export Cameras...
Export Markers...

Export Reference
Export Masks...
Export Shapes...

Export Texture...

Export Orthophotos...

Convert Images...

Render Images...
Import Cameras...

Import Markers...

current one.
Saves Metashape project file.

Saves Metashape project file with a new name.
Uploads current project to Agisoft Cloud.

Downloads project from the list of the projects
currently available in Agisoft Cloud.

Downloads images from Agisoft Cloud for the
current project.

Savestie point cloud or point cloud.
Saves 3D model.

Saves atiled model as hierarchical tiles.
Exports generated orthomosaic.

Exports generated digital elevation model.

Generates Agisoft Metashape processing report in
PDF and HTML formats.

Exports camera positions, orientation data and tie
points measurements.

Exports marker projections/ estimated marker
locations.

Exports reference.

Exports masks.

Exports shapes from the selected layers.
Exports model texture.

Exports orthorectified images corresponding to
individual cameras.

Exports the images corresponding to the original
camerawith distortion or color correction applied.

Generates lenticular images for the current scene.
Imports camera positions and orientation data.

Imports marker projections.
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FileMenu

Import Reference

Import Masks...
Import Shapes...

Import Trajectory...
Import Point Cloud...
Import Model....
Import Texture...

Import Tiled Model...

Import Orthomosaic...

Import DEM...

Import Depth Images...

Import Video...

Upload Data...

Exit

Edit Menu

)
e

Undo

Redo

AXis Snap
Vertex Snap
Edge Snap
2D Snap

I Add selection

| Subtract selection

! Invert Selection

Invert Selection

Grow Selection

Imports reference data.

Imports masks or creates mask from model or
background.

Imports shapes to be used for editing or
measurements.

Imports trajectory to be used for laser scans.
Imports pointsin aform of the point cloud.
Imports polygona mesh model.

Imports texture and appliesit to the current model.
Imports tiled model.

Imports orthomosaic.

Imports digital elevation model.

Imports images with depth maps.

Imports video in aform of frame sequence and
saves the extracted frames as images.

Uploads generated products (points, textured mesh
models, tiled models, orthomosaics or digital
elevation models) to one of the supported web-
Sites.

Closes the application window.

Undo the last editing operation.

Redo the previously undone editing operation.
Enable or disable snap to axis direction.

Enable or disable snap to shape vertices.

Enable or disable snap to shape edges.

Enable or disable snap to 2D coordinate.

Adds current selection to the mask.

Subtracts current selection from the mask.

Inverts current selection for the photo.

Inverts current selection of faces/ points/ cameras.

Grows current selection of mesh faces.
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Edit Menu

Shrink Selection
Reset Selection

X Delete Selection

tf- Crop Selection
Invert Mask

% Reset Mask

ﬁt Rotate Right

I Rotate Left

View Menu

#, Zoom In

=L Zoom Out

*3* Reset View
Capture View

5 Workspace
© Timeline
@ Animation
”Q:' Reference
& Properties
Photos
El Console
i Jobs

Toolbar
Full Screen
Workflow Menu

Add Photos...

@ Add Folder...

Align Photos...

Shrinks current selection of mesh faces.
Reset current selection.

Removes selected faces from the mesh or selected
points from the point cloud.

Crops selected faces/ points.
Inverts mask for the current photo.
Resets mask for the current photo.
Rotates the photo clockwise.

Rotates the photo counterclockwise.

Increases magnification in the active view mode.
Decreases magnification in the active view mode.

Resets the viewport to display the complete model
or photo.

Saves screenshot of current view of the project
(Model/Ortho/Photo)

Shows or hides Workspace pane.
Shows or hides Timeline pane.

Shows or hides Animation pane.
Shows or hides Reference pane.
Shows or hides shape Properties pane.
Shows or hides Photos pane.

Shows or hides Console pane.

Shows or hides Jobs pane.

Shows or hides Toolbar.

Switches to or from Full Screen mode.

L oads additional photos to be processed by
Metashape.

L oads additional photos from folders to be
processed by M etashape.

Estimates camera positions and tie point cloud.
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Workflow Menu
Build Mesh...

Build Texture...

Build Tiled Modé!...

Build Point Cloud...

Build DEM...

Build Orthomosaic...

Build Panorama...
Align Chunks...
Merge Chunks...

Batch Process...

Model Menu

“I' Navigation

r—-

L-. Rectangle Selection

..+ Circle Selection

';_ﬂ Free-Form Selection

Visible Selection

Gradual selection...

¥ Draw Point
A Draw Polyline

'_J Draw Polygon

& Ruler

F= calculate Profile
& Move Object

Fh.': Scale Object

ﬁa Rotate Object

Reset Transform

Generates polygonal mesh model.

Generates texture map for the mesh model.
Generates tiled textured model.

Generates point cloud.

Generates digital elevation model.

Generates orthomosaic.

Generates panorama.

Aligns multiple chunks.

Merges multiple chunks into the single chunk.

Opens Batch Process dialog box.

Switches to navigation mode.

Rectangle selection tool for the elements of the
Model view.

Circle selection tool for the elements of the Model
view.

Free-form selection tool for the elements of the
Model view.

Tool allowsto limit the selection depth, so that
only the area of the mesh that isvisiblein the
Model view would be selected.

Selects faces / points based on the specified
criterion.

Switches to the 3D point drawing tool.
Switches to the 3D polyline drawing tool.
Switches to the 3D polygon drawing tool.

Switches to 3D coordinate and linear distance
measurement tool.

Switches to the point cloud profile calculation tool.
Switches to object movement tool.

Switches to object scaling tool.

Switches to object rotation tool.

Resets the transformations applied to the object.
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Model Menu

EE Update Transform
0§D Move Region
Resize Region
22’ Rotate Region

Reset Region

':3' Show Basemap

82 show Cameras

Show Slave Cameras

Show Thumbnails

LB Show Laser Scans

Show Trajectory

= Show Shapes
”Q:' Show Markers
E[] Show Labels
Show Images

D Lock Image

LI Show Region
ER Show Animation
Show Trackball

@ Show Info

D Show Grid

= Show Aligned Chunks

Show All
Hide All

oo __| .
oo Tie Points - Colors

23 Tie Points - Variance

Update the transformations to the object.
Switches to volume movement tool.
Switches to volume resize tool.
Switches to volume rotation tool.

Resets the transformations applied to the volume to
default.

Displays or hides Basemap.

Displays or hides camera positions estimated
during image alignment.

Displays or hides slave camera positions.

Displays or hides image thumbnailsin the camera
placeholders.

Displays or hides laser scanning point cloud.
Displays or hides shooting trajectory for alaser
scan.

Displays or hides shapes.

Displays or hides marker positions.
Displays or hides item labels.

Switches stereographic image overlay mode on/
off.

Locks current image in stereographic image
overlay mode.

Displays or hides region selector.
Displays or hides animation track.
Displays or hides the trackball.

Displays or hides the auxiliary on-screen
information.

Displays or hides the grid.

Displays all enabled aligned chunks in project
workspace.

Displays all elements at the sametime.

Hides all elements.

Displaystie point cloud reconstructed during photo
alignment.

Displaystie point cloud colored by variance.
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Model Menu
Point Cloud - Solid
Point Cloud - Colors

#1 Point Cloud - Classes

Point Cloud - Intensity

Point Cloud - Elevation

Point Cloud - Return

Point Cloud - Scan Angle

Point Cloud - Source ID

Point Cloud - Confidence
4> Model - shaded

4 Model - Solid
<l> Model - Wireframe

{,- Model - Confidence

~.a'f Model - Textured

K% Tiled Model - Textured

4 Tiled Model - Solid

ki Tiled Model - Wireframe
% DEM
Orthomosaic

Diffuse Map

Normal Map

Occlusion Map

Perspective/Orthographic
Stereo Mode

Single-Sided Rendering

Displays point cloud in the solid mode.

Displays colored point cloud.

Displays point cloud colored according to the point
classes.

Displays point cloud intensity.

Displays point cloud colored according to the

elevation value.

Displays point cloud according to the return
information.

Displays point cloud according to the scan angle
information.

Displays point cloud according to the source ID
information.

Displays point cloud colored according to the
confidence values.

Displays 3D model in the shaded mode with
vertices colored with interpolated colors.

Displays 3D model in the solid mode.
Displays 3D model in the wireframe mode.

Displays 3D model with vertices colored according
to the confidence values.

Displays 3D model in the textured mode.
Displaystiled model with applied texture.

Displaystiled model without texture in the solid
model.

Displaystiled model in the wireframe mode.
Displays digital elevation model.

Displays orthomosaic.

Displays diffuse map for the textured mode.
Displays normal map for the textured mode.
Displays occlusion map for the textured mode.

Switches visualization view between Perspective
and Orthographic.

Enables or disables stereo view mode according to
the parameters specified in Preferences dialog.

Enables or disables Single - Sided Rendering
Mode. The option allows to neglect on parts of
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Model Menu

Predefined views

Navigation Mode

Photo Menu
. Navigation
L Rectangle Selection
& Intelligent Scissors
% Intelligent Paint
"5, Magic Wand
" Draw Point
A Draw Polyline
; Draw Polygon

& Ruler
Open Next Photo
Open Previous Photo
Go To Next Marker
Go To Previous Marker

Show Masks
Show Depth Maps

Show Intensity

% show Shapes
% show Markers
Show Marker Residuals

= Show Labels

the surface (Point cloud, Mesh, Tiled model)
where normals are counter directed to the targeted
projection plane.

Switches viewport to one of the predefined views.

Switches between Object and Terrain navigation
modes for the Model view window. Object
navigation mode allows for 3-axis rotation control,
while Terrain navigation mode restricts control to
2-axisrotation only, z-axis being kept vertical all
thetime.

Switches to navigation mode.

Rectangle selection toal.

Intelligent Scissors selection tool.
Intelligent Paint selection tool.

Magic Wand selection tool.

Switches to the 3D point drawing tool.
Switches to the 3D polyline drawing tool.
Switches to the 3D polygon drawing tool.

Switches to 3D coordinate and linear distance
measurement tool.

Opens next photo from the list in the Photos pane.

Opens previous photo from the list in the Photos
pane.

Zooms to the next marker projection on the opened
photo.

Zooms to the previous marker projection on the
opened photo.

Turns mask shading on or off.
Displays or hides the depth maps overlay.

Displays or hides intensity map overlay for the
laser scans.

Displays or hides shapes.
Displays or hides markers.
Displays or hides the residuals of each marker.

Displays or hides item labels.
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Photo Menu

ao Show Points

Show Point Residuals

Show All

Hide All

OrthoMenu

“I' Navigation

..+ Circle Selection

';_g Free-Form Selection

s Draw Point
A Draw Palyline
@ Draw Polygon
&) Draw Patch

= Draw Rectangle

5‘9 Ruler

':3' Show Basemap
=
=] Show Seamlines

82 show Cameras

"37 Show Markers

2 Show Shapes

E0 Show Labels
Show All
Hide All

% DEM

Orthomosaic

r=1
L-. Rectangle Selection

Displays or hides tie point projections used for the
camera alignment.

Displays or hides the residual s of each point.
Displays all elements at the same time.

Hides all elements.

Switches to navigation mode.

Rectangle selection tool for the elements of the
Ortho view.

Circle selection tool for the elements of the Ortho
view.

Free-form selection tool for the elements of the
Ortho view.

Switches to the 2D point drawing tool.
Switches to the 2D polyline drawing tool.
Switches to the 2D polygon drawing tool.
Switches to the patch drawing tool.
Switches to the 2D rectangle drawing tool.

Switches to coordinate and linear distance
measurement tool.

Displays or hides basemap (map and satellite).
Displays or hides orthomosaic seamlines.

Displays or hides camera positions according
to the estimated location for aligned cameras or
reference coordinates for not aligned cameras.

Displays or hides marker positions.
Displays or hides shapes.

Displays or hides item labels.
Displays all elements at the same time.
Hides all elements.

Switches to the digital elevation model display
mode.

Switches to the orthomosaic display mode.
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Ortho Menu

[#] Hillshading

ToolsMenu
Detect Markers...
Detect Fiducials...
Print Markers...

Track Markers...
Attach Markers
Refine Markers
Build Tie Points...

Thin Tie Points...
View Matches...

Filter Point Cloud...
Colorize Point Cloud...
Invert Point Normals...
Classify Ground Points...
Classify Paints...

Assign Class...

Reset Classification...
Select Points by Masks...

Select Points by Coalor...
Select Points by Shapes...

Filter by Class

Filter by Return

Enables or disables hillshading mode of digital
elevation mode visualization.

Creates markers from coded targets on photos.
Detects fiducia marks on the images.
Generates printable PDF file with coded targets.

Tracks marker locations across the frame
sequence.

Enables or disables the mode where every newly
drawn shape has markers attached to its vertices.

Enables or disables automatic marker projection
refinement based on the image content.

Builds tie point cloud based on the estimated
camera parameters available.

Thinstie point cloud by reducing the number of
projections on the individual photosto the given
limit.

Displays View Matches dialog for visual
representation of the common tie points between
the image pairs.

Decimates the point cloud according to the user-
defined point spacing distance.

Applies colorsto the point cloud points basing on
source images or orthomosaic.

Inverts normals for the selected points of the point
cloud.

Classifies point cloud based on the user defined
Settings.

Automatically classifies point cloud to the
supported classes.

Assigns classto the selected points.

Resets assigned classes for the selected point
classes.

Selects points according to the masks of the
selected images.

Selects points according to the color and tolerance.
Selects points according to the selected shapes.

Filters the pointsin the point cloud according to
the selected classes.

Filtersthe pointsin the LiDAR point cloud
according to return value.
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ToolsMenu

Filter by Confidence
Filter by Selection

Reset Filter

Compact Point Cloud...
Restore Point Cloud...
Update Point Cloud...

Mask Selection
Unmask Selection
Crop Mask by Selection
Reset Mask

Refine Mesh...
Decimate Mesh...
Smooth Mesh...

Close Holes...

Colorize Vertices...

Resize Texture...
Remove Lighting...
Generate Masks...
View Mesh Statistics...

View Mesh UVs...

Measure Areaand Volume...

Filter By Selection

Reset Filter
'TID Update DEM

Transform DEM...

S .
% & Update Orthomosaic

Filters the pointsin the point cloud according to
the calculated confidence value.

Filters the pointsin the point cloud according to
the selected points.

Resets all applied point cloud filters.

Permanently removes all deleted points from the
point cloud.

Restores all deleted points of the point cloud that
were once marked as removed.

Updates statistics of the point cloud, including
point numbers and assigned classes.

Mask selected trajectory positions.

Unmask selected trajectory positions.

Crop trgjectory mask by selection.

Reset tragjectory mask.

Starts photoconsistent mesh refinement operation.
Decimates mesh to the target face count.
Smooths mesh.

Closes holes on the model surface.

Applies colors to the mesh vertices basing on
source images, orthomosaic or point cloud.

Starts resize texture operation for mesh.

Starts the delighting operation for mesh texture.
Starts generate masks based on the built mesh.
Collects and displays mesh statistics.

Displays mesh UV mapping.

Displays surface area and volume of the polygonal
model.

Filters the faces of the polygona model according
to the selected points.

Resets al applied mesh filters.
Applies al the manual editsto the DEM.

Displays digital elevation model transformation
dialog.

Applies all the manual edits to the orthomosaic.
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ToolsMenu

Reset Orthomosaic
X Remove Orthophotos

Generate Seamlines

Generate Prescription Map

Cadlibrate Camera...
Show Chessboard...
82 Camera Calibration...

rd Optimize Cameras...

Calibrate Reflectance...

Cdlibrate Colors...

Set Primary Channel...

& s Brightness...

% Set Ragter Transform...

Generate Contours...

Plan Mission...

Reduce Overlap...

Detect Powerlines

Survey Statigtics...
4F Run Script...
"% Preferences...

Help Menu

%7 Contents

Resets all applied edits to default orthomosaic
stitching.

Removes individualy orthorectified images from
the project contents.

Creates the shape layer with the polygonal shapes
as copies of the orthomosaic patches.

Creates the shape layer with the prescription map
information based on the orthomosaic index.

Displays lens calibration dialog.
Displays the calibration board on screen.
Displays camera calibration dialog box.

Starts the optimization of exterior and interior
parameters of the aligned cameras.

Displays reflectance calibration dialog for precise
radiometric calibration of multispectral data based
on reflectance panel and sun sensor data.

Displays the color correction dialog for the
brightness and white balance compensation of the
images.

Displays the primary channel selection dialog.

Adjustsimage brightness and contrast for more
convenient display.

Displays Raster Calculator dialog for NDVI and
other vegetation indices calculation.

Generates contours based on DEM according
to the elevation levels or based on Orthomosaic
according to the vegetation index values.

Creates mission plan based on available mesh
model.

Reduces the number of enabled camerasin the
active project to optimize the coverage in case of
excessive overlap.

Starts image based powerlines detection operation.
Displaysthe survey statistics dialog in aform of
interactive report.

Displays Run Script dialog box for Python script
execution.

Displays preferences dialog box.

Displays help contents.
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Help Menu

Check for Updates...

Activate Product...

@’ About Metashape...

Toolbar buttons

General commands
El New
Open

mSave

3D view commands

“} Undo

™ Redo

“I' Navigation

L Rectangle Selection

(_J Circle Selection

'\3 Free-Form Selection
Reset Selection

% Move region

Resize region

82’ Rotate Region
Reset Region

& Move Object

i.': Scale Object

@b Rotate Object
Reset Transform

'Tlﬂ Update Transform

A Draw Polyline

Checks if Metashape update is available for
download.

Displaysthe activation dialog for activation /
deactivation of the product using the activation

key.
Displays program information, version number and
copyright.

Creates a new Metashape project file.
Opens a Metashape project file.

Saves a Metashape project file.

Undo the last editing operation.

Redo the previously undone editing operation.
Navigation tool.

Rectangle selection tool.

Circle selection tool.

Free-form selection tool.

Resets current selection.

Volume translation tool.

Volume resize tool.

Volume rotation tool.

Resets region according to the actual point cloud.
Model translation tool.

Model resize tool.

Model rotation tool.

Resets all transformations applied to the model.
Update transformations parameters for the model.

Switches to the 3D polyline drawing tool.
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3D view commands
" Draw Polygon
¥ Draw Point

& Ruler

[ calculate Profile
:’{ Delete Selection

tf- Crop Selection

3D view settings

#, Zoom In

=L Zoom Out

*34 Reset View

88 Tie Points- Colors

33 Tie Points - Variance
Point Cloud - Solid
Point Cloud - Colors

#1 Point Cloud - Classes

Point Cloud - Intensity

Point Cloud - Elevation

Paoint Cloud - Return

Point Cloud - Scan Angle

Point Cloud - Source ID

Point Cloud - Confidence
4> Model - Shaded

4> Modd - solid
<l> Model - Wireframe

{»' Model - Confidence

Switches to the 3D polygon drawing tool.
Switches to the 3D point drawing tool.
3D coordinate and linear distance measurement

tool.
Profile measurement tool.

Removes selected faces/ points.

Crops selected faces/ points.

Increases magnification.
Decreases magnification.
Resets model view.

Displaystie point cloud reconstructed during
image alignment.

Displaystie point cloud colored by variance.
Displays point cloud in the solid mode.
Displays colored point cloud.

Displays point cloud colored according to the point
classes.

Displays point cloud intensity.
Displays point cloud colored according to the
elevation value.

Displays point cloud according to the return
information.

Displays point cloud according to the scan angle
information.

Displays point cloud according to the source ID
information.

Displays point cloud colored according to the
confidence values.

Displays 3D modél in the shaded mode with
vertices colored with interpolated colors.

Displays 3D model in the solid mode.
Displays 3D mode in the wireframe mode.

Displays 3D model with vertices colored according
to the confidence values.
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3D view settings

& Model - Textured
Diffuse Map
Normal Map
Occlusion Map
Displacement Map
Matcap Settings...

H¥ Tiled Model - Textured

¥ Tiled Model - Solid

Tiled Model - Wireframe
% DEM

Orthomosaic

':3' Show Basemap

82 show Cameras
Show Thumbnails
Show Local Axes

I.,'EI Show Laser Scans

Solid View

ColorsView

Classes View

Intensity View

Elevation View
Return View
Scan ID View
Confidence View

Scan Angle View

Displays 3D modé in the textured mode.
Displays diffuse map for the textured mode.
Displays normal map for the textured mode.
Displays occlusion map for the textured mode.
Displays displacement map for the textured mode.
Open dialog to select matcap source.
Displaystiled model with the applied texture.
Displaystiled model in the solid mode.
Displaystiled model in the wireframe mode.
Displays digital elevation model.

Displays orthomosaic.

Displays or hides basemap (Map or Satellite).
Displays or hides camera positions, reconstructed

during image alignment.

Displays or hides image thumbnailsin the camera
placeholders.

Displays or hides local camera coordinate system
axes.

Displays or hides laser scanning point cloud.

Displays laser scanning point cloud in the solid
mode.

Displays colored laser scanning point cloud.

Displays laser scanning point cloud colored
according to the point classes.

Displays laser scanning point cloud intensity.

Displays laser scanning point cloud colored
according to the elevation value.

Displays laser scanning point cloud according to
the return information.

Displays laser scanning point cloud according to
the source ID information.

Displays laser scanning point cloud colored
according to the confidence values.

Display laser scans colored by scan angle.
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3D view settings

Show Trajectory
Solid View
Elevation View
Time View

= Show Shapes

% show Markers

Show Images

D Lock Images

£ Show Aligned Chunks

Photo view commands
“} Undo
™ Redo
* Navigation
Ll Rectangle Selection
& Intelligent Scissors
% Intelligent Paint
M agic Wand
S Magic Wand Settings
Reset Selection
A Draw Polyline
@ Draw Polygon
¥ Draw Point
AXis Snap
Vertex Snap
Edge Snap

2D Snap

Displays or hides shooting trajectory for alaser
scan.

Displays shooting trajectory for alaser scan in the
solid mode.

Displays shooting trajectory for alaser scan
colored according to the elevation value.

Displays shooting trajectory for alaser scan
colored according to the time value.

Displays or hides 3D shapes.

Displays or hides positions of markers placed on
the model.

Displays or hides stereographic image overlay.

Locks current image in stereographic image
overlay mode.

Displays or hides enabled aligned chunks.

Undo the last mask editing operation.

Redo the previously undone mask editing
operation.

Switches to the navigation mode.
Rectangle selection tool.

Intelligent scissorstoal.

Intelligent paint tool.

Magic wand toal.

Changing the parameters of the magic wand.
Resets current selection.

Switches to the 3D polyline drawing tool.
Switches to the 3D polygon drawing tool.
Switches to the 3D point drawing tool.
Enable or disable snap to axis direction.
Enable or disable snap to shape vertices.
Enable or disable snap to shape edges.

Enable or disable snap to 2D coordinate.
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Photo view commands

& Ruler

¥ Place Fiducial

I Add Selection

“| Subtract Selection

Invert Selection

& s Brightness

Zl\ Rotate Right

s Rotate L eft

® Zoom In

=L Zoom Out

*34 Reset View
Show Masks

™ show Depth Maps
Show Intensity

= show Shapes
|]ﬂ:' Show Markers

Show Marker Residuals

aa Show Points

Show Point Residuals

Ortho view commands

“I' Navigation

P Rectangle Selection

. Circle Selection

'13 Free-Form Selection
Reset Selection

A Draw Polyline

3D coordinate and linear distance measurement
tool.

Fiducial placement tool.

Adds current selection to the mask.
Subtracts current selection from the mask.
Inverts current selection.

Adjustsimage brightness and contrast for more
convenient display.

Rotates the image clockwise.

Rotates the image counterclockwise.

Increases magnification.

Decreases magnification.

Resets the viewport to display the whole image.
Enables or disables the mask shading overlay.

Enables or disables the depth map overlay of the
selected level.

Displays or hides intensity map overlay for laser
scans.

Displays or hides shapes on the current image.
Displays or hides marker projections.

Displays or hides residuals related to marker
projections.

Displays or hides tie point projections.

Displays or hides residuals related to tie point
projections.

Switches to the navigation mode.
Rectangle selection tool.

Circle selection tool.

Free-form selection tool.

Resets current selection.

Switches to the polyline drawing tool.
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Ortho view commands
; Draw Polygon
&) Draw Patch
= Draw Rectangle
s Draw Point
AXis Snap
Vertex Snap
Edge Snap

6‘9 Ruler

% DEM - Elevation
v DEM - Slope
;ﬁ.,- DEM - Aspect
[ Hillshading

Orthomosaic

& s Brightness
9 et Raster Transform

3 Update DEM
EE Update Orthomosaic

%, Zoom In

=L Zoom Out

*34 Reset View

':3' Show Basemap

=]
=1 Show Seamlines

82 show Cameras

|]ﬂ:' Show Markers

= show Shapes

Switches to the polygon drawing tool.
Switches to the patch drawing tool.
Switches to the rectangle drawing tool.
Switches to the point drawing tool.
Enable or disable snap to axis direction.
Enable or disable snap to shape vertices.
Enable or disable snap to shape edges.
2D linear distance measurement tool.

Switches to the digital elevation model display
mode colored by elevation.

Switches to the digital elevation model display
mode colored by slope.

Switches to the digital elevation model display
mode colored by aspect.

Enables or disables hillshading mode of digital
€elevation mode visualization.

Switches to the orthomosaic display mode.

Adjustsimage brightness and contrast for more
convenient display.

Displays Raster Calculator dialog for NDVI and
other vegetation indices calculation.

Applies al the manual edits to the DEM.
Applies al the manual edits to the orthomosaic.

Increases the magnification of theimage in the
Ortho view.

Decreases the magnification of theimagein the
Ortho view.

Resets the viewport to display the complete
orthomosaic or DEM.

Displays or hides basemap in aform of satellite or
vector map.

Displays or hides orthomosaic seamlines.

Displays or hides camera positions according
to the estimated location for aligned cameras or
reference coordinates for not aligned cameras.

Displays or hides marker positions.

Displays or hides shapes.
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Graphical user interface

Hot keys

For convenient operation in the Metashapeit is possible to use Hot keys. Below isalist of default hot keys
that can be customized in the Preferences dialog. Select the Customize button at the Shortcuts menu item.

General
Create new project Ctrl +N
Save project Ctrl +S
Open project Ctrl +O
Run Script Ctrl +R
Full Screen F11
Model View

Undo (only for Delete, Assign Class/ Classify Ctrl +Z
Ground Points,Masking and Close Holes

operations)

Redo (only for Delete, Assign Class/ Classify Ctrl +Y
Ground Points,Masking and Close Holes

operations)

Switch between navigation and any other Space
previously selected mode

Zoom In Ctrl + +
Zoom Out Ctrl + -
Reset view 0
Switch to stereoview mode 9
Switch between orthographic and perspective view 5
modes

Change the angle for perspective view Ctrl + mouse wheel
Assign dense cloud class (only if some pointsare  Ctrl + Shift + C
selected)

Predefined Views

Top 7
Bottom Ctrl +7
Right 3

Left Ctrl +3
Front 1

Back Ctrl +1
Rotate View

Rotate Up

Rotate Down 2
Rotate L eft
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Rotate View

Rotate Right 6
Photo View

Next photo (according to Photos pane order) Page Up

Previous photo (according to Photos pane order)  Page Down

Go to the next marker on the same photo Tab

Go to the previous marker on the same photo Shift + Tab

Navigation mode \%

Selection Tools

Rectangle selection M

Intelligent scissors L

Intelligent paint P

Magic wand wW

Add selection Ctrl + Shift + A
Subtract selection Ctrl + Shift+S
Invert selection Ctrl + Shift + |

193



Images

Input formats

JPEG (*.jpg.*.jpeg)

JPEG 2000 (*.jp2, *.j2k)

JPEG XL (*.jxI)

TIFF (*.tif, *.tiff)

PNG (*.png)

BMP (*.bmp)

OpenEXR (*.exr)

TARGA (*.tga)

Portable Bit Map (*.pgm, *.ppm)
Digital Negative (*.dng)
Multi-Picture Object (*.mpo)
Norpix Sequence (*.seq)
AscTec Thermal Images (*.ara)

Camera calibration

Import formats

Agisoft Camera Calibration (*.xml)
Australis Camera Parameters (*.txt)
Australisv.7 Camera Parameters (*.txt)
PhotoModeler Camera Calibration (*.ini)
3DM CalibCam Camera Parameters (*.txt)
Ca Cam Camera Calibration (*.cal)
Inpho Camera Calibration (*.txt)

USGS Camera Calibration (*.txt)

Pix4D Camera Calibration (*.cam)
OpenCV Camera Calibration (*.xml)
Photomod Camera Calibration (* .x-cam)
Z/| Distortion Grid (*.dat)

Camera flight log

Input for mat
Agisoft XML (*xml)

Appendix B. Supported formats

Undistort formats
JPEG (*.jpg,* .jpeg)
JPEG 2000 (*.jp2, *.j2k)
JPEG XL (*.jxI)

TIFF (*.tif, * tiff)

PNG (*.png)

BMP (*.bmp)
OpenEXR (*.exr)

Export formats

Agisoft Camera Calibration (*.xml)
Australis Camera Parameters (*.txt)
Australisv.7 Camera Parameters (*.txt)
PhotoModeler Camera Calibration (*.ini)
3DM CalibCam Camera Parameters (*.txt)
Ca Cam Camera Calibration (*.cal)
Inpho Camera Calibration (*.txt)

USGS Camera Calibration (*.txt)

Pix4D Camera Calibration (*.cam)
OpenCV Camera Calibration (*.xml)
Photomod Camera Calibration (* .x-cam)
Z/| Distortion Grid (*.dat)

STMap (*.tif, *.exr)

Estimated positions
Agisoft XML (*xml)
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GCP

Input format

Character-separated values (*.txt, *.csv)
EXIF meta data

MAVinci CSV (*.cov)
TopoAxistelemetry (*.tel)

C-Astral Bramor log (*.log)
APM/PixHawk Log (*.log)

locations

Input for mat
Character-separated values (*.txt, *.csv)
Agisoft XML (*.xml)

Estimated positions
Character-separated values (* .txt)

Estimated positions
Character-separated values (* .txt)
Agisoft XML (*.xml)

Interior and exterior camera orientation
parameters

Import camera positions
Agisoft XML (*.xml)

Autodesk FBX (*.fbx)

Alembic (*.abc)

Realviz RZML (*.rzml)

Inpho Project File (*.prj)

BINGO (*.dat)

Blocks Exchange (*.xml)
N-View Match (*.nvm)

PATB Camera Orientation (*.ori)
VisionMap Detailed Report (*.txt)
Bundler (*.out)

Tie points

Import tie points
Bundler (*.out)

Export camera positions

Agisoft XML (*.xml)

Autodesk FBX (*.fbx)

Alembic (*.abc)

Realviz RZML (*.rzml)

Inpho Project File (*.prj)

BINGO Project (*.dat)

Blocks Exchange (*.xml)

N-View Match (*.nvm)

PATB Project (*.pro)

Boujou (*.txt)

Maya ASCII (*.ma)

CHAN files (*.chan)

ORIMA (*.txt)

AeroSys Exterior Orientation (*.orn)
Summit Evolution Project (*.smtxml)
Omega Phi Kappa (* .txt)

Export tie points
Bundler (*.out)
BINGO (*.dat)
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Import tie points

Import formats
Wavefront OBJ (*.obj)
Stanford PLY (*.ply)
ASPRSLAS (*.las)

LAZ (*.l1az)

ASTM E57 (*.€57)

ASCII PTS (*.pts, *.pts.gz)
Point Cloud Data (*.pcd)
PTX format (*.ptx)

Mesh model

Import mesh

Wavefront OBJ (*.obj)
3DS models (*.3ds)
COLLADA (*.dae)
Stanford PLY (*.ply)
Alembic (*.abc)

STL models (*.stl)
OpenCTM models (*.ctm)
Universal 3D models (*.u3d)
Autodesk FBX (*.fbx)
Autodesk DXF (*.dxf)

Export tie points

ORIMA (*.txt)

PATB (*.pth)

Summit Evolution Project (*.smtxml)
Blocks Exchange (*.xml)

Tie point cloud / Point cloud

Export formats
Wavefront OBJ (*.obj)
Stanford PLY (*.ply)
ASPRSLAS (*.las)
LAZ (*.laz)

ASTM E57 (*.e57)
ASCII PTS (*.pts)

Point Cloud Data (*.pcd)
XYZ Point Cloud (*.txt)
Cesium 3D Tiles (*.zip)
Scene Layer Package (*.slpk)
Universal 3D (*.u3d)
Autodesk DXF (*.dxf)
potree (*.zip)

Agisoft OC3 (*.oc3)
Topcon CL3 (*.cl3)
Adobe 3D PDF (*.pdf)

Export mesh

Wavefront OBJ (*.obj)

3DS models (*.3ds)
COLLADA (*.dae)

Stanford PLY (*.ply)

Alembic (*.abc)

STL models (*.stl)

VRML models (*.wrl)
Universal 3D models (*.u3d)
Autodesk FBX (*.fbx)
Autodesk DXF Polyline (*.dxf)
Autodesk DXF 3DFace (*.dxf)
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Import mesh

Texture maps

Import texture

JPEG (*.jpg, *.jpeg)

JPEG 2000 (*.jp2, *.j2k)

JPEG XL (*.jxI)

PNG (*.png)

TIFF (*.tif, * tiff)

BMP (*.bmp)

OpenEXR (*.exr)

TARGA (*.tga)

Portable Bit Map (*.pgm, *.ppm)
Digital negative (*.dng)
Multi-Picture Object (*.mpo)
Norpix Sequence File (*.seq)
AscTec Thermal Images (*.ara)

Orthomosaic

Import orthomosaic

GeoTIFF Raster Data (* .tif)
GeoPackage (*.gpkg)

KML files (*.kml, *.kmz)

MBTiles (*.mbtiles)

Tiled Map Service Tiles (*.xml, *.zip)

Export mesh

Binary gITF (*.glb)

X3D models (*.x3d)
OpenSceneGraph Binary (*.osgb)
OpenSceneGraph Text (*.osgt)
Google Earth KMZ (* .kmz)
LandXML (*.xml)

Adobe PDF (*.pdf)

Export texture
JPEG (*.jpg)
JPEG 2000 (*.jp2)
JPEG XL (*.jxI)
PNG (*.png)
TIFF (*.tif)

BMP (*.bmp)
OpenEXR (*.exr)
TARGA (*.tga)

Export orthomosaic
GeoTIFF Raster Data (* .tif)
GeoPackage (*.gpkg)
Google KMZ (*.kmz)
MBTiles (*.mbtiles)

Tiled Map Service Tiles (*.zip)
Google Map Tiles (*.zip)
World Wind Tiles (*.zip)
JPEG (*.jpg)

JPEG 2000 (*.jp2)

JPG XL (*.jxI)

PNG (*.png)

BMP (*.bmp)
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Digital elevation model (DSM/DTM)

Import DEM
GeoTIFF elevation (*.tif)

Tiled models

Import tiled model
Agisoft Tiled Model (*.tls)

Depth Images

Import Depth Images
Dynamic Depth images (*.jpg, *.jpeg)

Shapes and contours

Import shapes
Shape Files (*.shp)
DXF Files (*.dxf)
KML files (*.kml)

Export DEM

GeoTIFF elevation (*.tif)
JPEG (*.jpg)

JPEG 2000 (*.jp2)

JPEG XL (*.jxI)

PNG (*.png)

BMP (*.bmp)

GeoPackage (*.gpkg)
MBTiles (*.mbtiles)

Tile Map Service Tiles (*.zip)
Google Map Tiles (*.zip)
Google KMZ (*.kmz)

World Wind Tiles (*.zip)
Arc/Info ASCII Grid (*.asc)
Band interleaved file format (*.hil)
XYZ (* xyz)

Export tiled model

Agisoft Tiled Modédl (*.tls)
Agisoft Tile Archive (*.zip)
Cesium 3D Tiles (*.zip)

Scene Layer Package (*.slpk)
PhotoMesh Layer (*.zip)
OpenSceneGraph Binary (*.zip)
OpenSceneGraph Text (*.zip)

Export shapes/contours
Shape Files (*.shp)

DXF Files (*.dxf)

KML Files (*.kml)
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Import shapes

KMZ files (*.kmz)
GeoJSON files (*.geojson)
GeoPackage files (*.gpkg)
Survey Points (*.txt)

Trajectory

Import Trajectory

Character-separated values (*.txt, *.

* XyZz)

SBET (*.out, *.sbet)
SOL (*.sol)
TerraScan (*.trj)

Video

Import video
AVI (*.avi)

Flash video (* .flv)
MOV (*.mov)
MPEG-4 (*.mp4)
WMV (*.wmv)

Csv, *.trjt,

Export shapes/contours
KMZ Files (*.kmz)
GeoJSON files (*.geojson)
GeoPackage files (*.gpkg)
Survey Points (*.txt)

Export video
AVI (*.avi)

199



Appendix C. Metashape Preferences

M etashape settings are available in the Metashape Preferences dialog window. The following settings are
availablein the Metashape Preferences dialog window: General, GPU, Network, Appearance, Navigation,
Advanced. All the parameters that are used to configure the program are described in this appendix.

General tab

Metashape Preferences

General GPU Metwork  Appearance  Mavigation  Advanced

User Interface

Language: English

Default view: Point Cloud

Theme: Light

Shortcuts:
Stereoscopic Display

Mode: Anaglyph

Parallzx: L0 H
Measurements

Latitude flongitude format: Decimal degrees

Units: Metre

se derived units

Miscellaneous

Check for updates on program startup
Write log to file:

Ci\Jsers\og. tt

oK Apply
General tab

The following settings are available in the Metashape Preferences (General tab) dialog window:

200



Metashape Preferences

User Interface
Language - the GUI language can be selected from the available list: English, Chinese, French,
German, Italian, Japanese, Portuguese, Russian, Spanish.

Default view - the representation of the project can be selected. This parameter indicates how the
project isfirst represented when opened in Metashape. The available options are: Point cloud, Dense
cloud , Tiled model or Model.

Theme - the GUI appearance. The available options are Dark, Light and Classic. The theme set by
default in Metashape Professional edition is Light.

Shortcuts for the menu and GUI commands can be adjusted via Customize... button.

Stereoscopic Display
Mode - allows to select the stereo mode. M etashape supports Anaglyph, Hardware, Vertical Split and
Horizontal Split stereo modes.

Parallax - the value is used for the stereoscopic mode (Anaglyph or Hardware) of Model view. The
value is changed from 0O (the stereo effect will not be observed, because the parallax value will be
0) to 2.

M easur ements
L atitude/longitude format - units of measurement for displaying values for latitude and longitude
(decimal degrees or degrees, minutes, seconds).

Units - the preferable Units, that will be used in the project for all measurements (coordinate system
units, meter, foot, foot (US survey)).

Use derived units - allows to enable or disable using derived units in the project. If this option is
disabled, meters will be used in the report and in measurements. If this option enable then km, cm,
mm, etc. can be used in measurements and in the report (if the scale of the results is appropriate).

Miscellaneous
Check for updates on program startup - alows to enable the option to receive notifications about
the release of new Metashape version.

Writelog tofile - indicate the path to the Metashape log file. The file contains information about the
processing of the project. Log file can be shared with Agisoft support team in case any problem arises
during the data processing in Metashape.
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GPU tab

Metashape Preferences

Gerneral GPU Metwork  Appearance  Mavigation  Advanced

GPU devices:

AMD Radeon (TM) Pro WX 7100 Graphics (Ellesmere) (36 co...  OpenCL
GeForce GTX 1080 Ti (28 compute units @ 1382 MHz, 11264 ...  CUDA

Mote: GPU acceleration is supported for image matching, depth maps generation, mesh and DEM
generation based on depth maps, texture blending and mesh refinement.

Warning: When using dedicated GPUs please turn off integrated GPUs and CPU for optimal
performance.

Use CPU when performing GPL accelerated processing

Cancel Apply
GPU tab
The following settings are available in the Metashape Preferences (GPU tab) dialog window:

GPU devices
Thelist of al detected GPU devicesis presented.

Use CPU when performing GPU acceler ated processing
The option to use CPU.
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Network tab

Metashape Preferences

Gereral GPU  Metwork  Appearance  Mavigation — Advanced

Local Metwork

Enable network processing

Host name: Port number:
191,168.0.2 5840

Root:
Vidatasets

Cloud

Enable doud processing

Password:
BEEEERREEEEEE

Create and manage your personal doud account at

Praoxy Server

Enable proxy server

Use system proxy settings
Host name: Port number;

a0

Metwork and doud processing is supported for projects in PSX format only.
oK Apply
Network tab
The following settings are available in the Metashape Preferences (Network tab) dialog window:

L ocal Network
Enable network processing - allowsto use network processing.

Host name - specify the server IP used for client connection

Port number - modify the port value. In case non-default port was configured on a server.
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Root - allows to modify root for local network.

Cloud
Enable cloud processing - allows to turn on cloud processing at Agisoft Cloud.

Email - specify email for Agisoft Cloud processing.
Password - specify password for Agisoft Cloud account.

Proxy Server
Enable proxy server - allowsto turn on using proxy server.

Use system proxy settings - enable using system proxy settings.
Host name - specify host name.

Port number - specify port number.
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Appearance tab (Model View)

Metashape Preferences X

Gerneral GPU  Metwork  Appearance  Mavigation — Advanced

Model View General
Ortho View Background color: EffF Select...
Photo View Text color: m Select...
Model color: #8030b0 Selecte..
Interpolation: Bilinear
Trackball size: 30%
Paint size: 2
Variance scale: 0,00
Default view: Crthographic
Default shape color; #elelel Select...

Stereo Cursor

Cursor type:

Cursor color: Fececer Select...
Cursor size: 100 px

Cursor thickness: 10 px

Grid

Color: m Select...
Transparency: 34% I
Line count: 40

Cancel [T
Appearance tab (Model View)

Thefollowing settings are available in the Metashape Preferences (Model View on Appearancetab) dialog
window:

General
Background color - allowsto set the color for background for Model view.
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Text color - alowsto set the color for Label in Model view.
Modél color - alowsto specify the color for 3D model in the solid modein Model view.

I nter polation - allowsto choose theinterpol ation method to be used when displaying images (Nearest
neighbor or Bilinear).

Trackball size - allowsto specify the size of the trackball that it will be displayed in the Model view.
Thevaluevariesfrom 0% to 100%. When using 100%, the trackball will be displayed at thefull height
of the Model view. If set 0% - the trackball doesn't display in the Model view.

Point size - alows to set the size of the point for tie point cloud and dense point cloud to display
in the Model view.

Variance scale - allows to set the scale value for displaying the variance in the Model view.
Default view - allows to select the view of the model when it is opened: Perspective or Orthographic.

Default shape color - allows to set the color that will be displayed when opening or creating a layer
with shapesin Modd view.

Stereo Cursor
Cursor type - allows to set the cursor type (crosshair, crosshair with point, point, circle with point).

Cursor color - alows to choose the color for cursor.
Cursor size - allowsto set the cursor sizein pixels.
Cursor thickness - allows to set the cursor thicknessin pixels.

Grid
Color - allowsto specify the color for grid in Model view.

Transparency - alows to set the transparency in percent. The transparency value varies from 0%
to 100%. The higher the value, the more transparent the grid will be (0% - not transparent, 100% -
maximum transparency).

Line count - allowsto set line counts.
Cell size - dllowsto set the cell sizein pixels or meters.

Plane - allows to set the plane for grid (XY, XZ or YZ). The grid will be created in the plane that
selected and will be parallel to the location of the axes in the project.

Region
Color - allowsto set the color for region (bounding box).

Base color - allows to set base colors for region (bounding box).

Transparency - allows to set the transparency in percent. The transparency value varies from 0% to
100%. The higher the value, the more transparent the region will be (0% - not transparent, 100% -
maximum transparency).

Camera Track
Color - allows to specify the color for cameratrack.

Thickness - allows to set the thicknessin pixels.
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Drawing Plane
Color - allowsto set the color for drawing plane.

Transparency - allows to set the transparency in percent. The transparency value varies from 0% to
100%. The higher the value, the more transparent the drawing plane will be (0% - not transparent,
100% - maximum transparency).

Point Cloud Bounding Box
Color - allowsto set the color for point cloud bounding box.

Appearance tab (Ortho View)

Metashape Preferences

Gerneral GPU  Metwork  Appearance  Mavigation — Advanced

Model View General

Ortho View Background color: # Select...

Photo View Text color: m Select...
Interpolation: Mearest neighbaor

Show shape labels
DEM
DEM palette: B H Default

Hillshading

Light source azimuth: 315

Light source altitude: 45

Seamlines
Color: m Select...
Thickness: 1px

Appearance tab (Ortho View)
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Thefollowing settings are available in the Metashape Preferences (Ortho View on Appearance tab) dialog
window:

General
Background color - allowsto set the color for background for Ortho view.

Text color - allowsto set the color for Label in Ortho view.

I nter polation - allows to select the interpolation method to be used when displaying images (Nearest
neighbor, Bicubic or Bilinear).

Show shape labels - allows to enable/disable show shape labels in the Ortho view.

DEM
DEM palette - allows to set the palette for DEM (Default, Grayscale, Custom). Use the Edit Palette
button (next to the drop-down list) to edit palette colors.

Hillshading
Light source azimuth - allows to set the light source azimuth for hillshading (from 0 to 360).

Light sour ce altitude - allows to set the source altitude (from O to 360).
Seamlines
Color - dlowsto set the color for seamlines. Colors can be chosen from Basic colors or set the color

manually.

Thickness - allows to set the thickness in pixels (from 1 pixel to 3 pixels). The parameter changes
the thickness for seamlinesin Ortho view.
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Appearance tab (Photo View)

Metashape Preferences X

General GPU Metwork  Appearance  Mavigation  Advanced

Model View General
Ortho View Background color: # Select...
Photo View Text color: m Select...
Interpolation: Mearest neighbor
Residuals scale: 10.00

Marker crosshair:

Show shape labels

Masks

Fill colar: m Select...
Border color: ET Select...
Transparency: 50% H

cancel IR

Appearance tab (Photo View)

Thefollowing settings are available in the Metashape Preferences (Photo View on Appearance tab) dialog
window:

General
Background color - allows to set the color for background for Photo view. It may be useful to set a
contrasting background when creating a mask manually to see the edges of the images.

Text color - allowsto select the color for Label in Photo view.
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I nter polation - allows to select the interpolation method to be used when displaying images (Nearest
neighbor, Bicubic or Bilinear).

Residuals scale - allows to set residuals scale for tie pointsin Photo View.

Marker crosshair - allows to set the type for marker crosshair (cursor, circle with crosshair, circle
with paint).

Show shape labels - allows to enable/disable show shape labels in the Photo view.

Masks
Fill color - allowsto set the color for masks.

Border color - allows to set the color for the mask border. By default, the white color will be used.

Transparency - alows to set the transparency in percent. The transparency value varies from 0%
to 100%. The higher the value, the more transparent the mask will be (0% - not transparent, 100%
- maximum transparency).
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Navigation tab

Metashape Preferences

General GPU Metwork Appearance  Mavigation — Advanced

Controllers
Enable HID-compliant controller

Enable Stealth Z-Mouse controller

Enable Stealth 5-Mouse controller COM1

Controller Settings

Controller:

Sensitivity: Invert axes:
Translation: 0,01 X
Rotation: 0.01

= : E :

Button Function

Apply
Navigation tab

The following settings are available in the Metashape Preferences (Navigation tab) dialog window:

Controllers
Enable HI D-compliant controller - allows to enable or disable using HID-compliant controller.

Enable Stealth Z-Mouse controller - allowsto enable or disable using Z-mouse controller.

Enable Stealth S-M ouse controller - allowsto enable or disable using S-mouse controller. Available
controllers will be displayed in the drop down list.
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Controller Settings
Controller - alows to enable controller from the drop-down list. To update the list of available
controllers, click the Update button next to the drop-down list.

Trandation - allows to set the translation for controller (Sensitivity, Invert axes). The Sensitivity
value varies from 0 to 100. To apply this value to a specific axis, enable the checkbox for the
corresponding axis in the Invert axes section.

Rotation - allows to set the rotation for controller (Sensitivity, Invert axes). The Sensitivity value
variesfrom 0to 100. To apply thisvalue to a specific axis, enable the checkbox for the corresponding
axisin the Invert axes section.

Table (Button and Function)
Inthe Controller Settings section set functionsfor controller buttons: to assign anew function, double-
click on the corresponding line and select preferable function from the drop-down list. If the function
isnot set for the button, the value None will be displayed in the Function section.
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Advanced tab

Metashape Preferences p 4

Gereral GPU  Metwork  Appearance  Mavigation  Advanced
Project Files
</ Keep key points
/" Keep depth maps
Store absolute image paths
Export / Impart
Strip file extensions from camera labels
+/ Load camera calibration from XMP meta data
/' Load camera orientation angles from XMP meta data
/' Load camera location accuracy from XMP meta data
/" Load GPS/INS offset from ¥MP meta data
Load thumnbnails from EXIF meta data

/' Load satelite RPC data from auxiliary TXT files

Miscellaneous

+/ Enable finedevel task subdivision

-/ Enable VBO support

+/" Enable mipmap generation

-/ Enable rich Python consale

/" Copy last shape description for new shapes

Max basemap cache size: 100ME Clear

Cancel
Advanced tab
The following settings are available in the Metashape Preferences (Advanced tab) dialog window:

Project Files
Keep key points - allows to enable option for saving key pointsinto project.
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K eep depth maps - allows to enable option for saving depth maps for the project. This option helps
save processing timein cases when the dense point cloud needsto be re-built (for apart of the project)
after itsinitial generation or when both mesh and dense cloud are based on the same quality depth

maps.

Stor e absolute image paths - allows to enable option for saving absolute image paths. Recommend
enable this parameter if project is not moved to another folder or computer.

Export/Import
Strip file extensions from camera labels - allows to enable option for delete file extensions from
camera labels during load photos into project.

Load camera calibration from XMP meta data - alows to enable option for automatic loading
camera calibration data from XMP.

Load camera orientation angles from XMP meta data - alows to enable option for automatic
loading of rotation angles elements of exterior orientation from XMP.

Load camera location accuracy from XMP meta data - allows to enable option for automatic
loading location accuracy value from XMP file.

Load GPS/INS offset from XM P meta data - alows to enable option for automatic loading GPS/
INS offset from XMP meta data.

L oad thumbnailsfrom EXIF meta data - allowsto enable option for automatic |oading thumbnails
from EXIF meta data.

Load satellite RPC data from auxiliary TXT files - allows to enable option for automatic loading
satellite RPC data from auxiliary TXT files.

Miscellaneous
Enable fine-level task subdivision - option allows for internal splitting of some tasks to sub-jobs,
thus reducing the memory consumption during processing of large datasets. The tasks that support
fine-level distribution are: Match Photos, Align Cameras, Build Depth Maps, Build Dense Cloud,
Build Tiled Model, Build DEM, Build Orthomosaic and Classify Points

Enable VBO support - allows to turn on parameter for speed up the navigation in the Model view
for dense point clouds and high polygonal meshes.

Enable mipmap generation - allows to enable parameter to display the texture using mipmap.
Enablerich Python console - allows to enable using rich Python console.

Copy last shape description for new shapes - alows to copy last shape description when creating
anew shape.

Max basemap cache size - setting max cache size for basemap in megabyte.

Tweaks... - button for creating tweaks. It is suggested to use this button only if it was recommended
by the Agisoft technical support team.

Cleanup Projects... - button for cleanup projects.

Reset All Settings - button for reset all settings.
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Appendix D. Camera models

Agisoft Metashape supports several parametric lensdistortion models. Specific model which approximates
best a real distortion field must be selected before processing. All models assume a central projection
camera. Non-linear distortions are modeled using Brown's distortion model.

A cameramodel specifiesthe transformation from point coordinatesin the local camera coordinate system
to the pixel coordinatesin the image frame.

Thelocal camera coordinate system has origin at the camera projection center. The Z axis points towards
the viewing direction, X axis pointsto theright, Y axis points down.

The image coordinate system has origin in the middle of the top-left pixel (with coordinates (0.5, 0.5)).
The X axisin the image coordinate system points to theright, Y axis points down. Image coordinates are
measured in pixels.
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Image and camera coordinate systems

Equations used to project a points in the local camera coordinate system to the image plane are provided
below for each supported camera model.

The following definitions are used in the equations:

(X,Y, Z) - point coordinatesin the local camera coordinate system,

(u, v) - projected point coordinates in the image coordinate system (in pixels),
f - focal length (in pixels),

Cx, Cy - principal point offset (in pixels),
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Cameramodels

K1, Ko, K3, Ky4 - radial distortion coefficients (dimensionless),
Py, P, - tangential distortion coefficients (dimensionless),
B, B> - affinity and non-orthogonality (skew) coefficients (in pixels),

w, h - image width and height (in pixels).

Frame cameras

X=Xz

y=Y/Z

r = sqrt(x + y?)

X' = X(L+ Kqr? + Kor® + Kar® + Kar®) + (P(r2+2x) + 2Pxxy)
Y =YL+ Kar?+ Kor + Kar® + Kar®) + (Por*+2y%) + 2Pyxy)
u=w*05+¢c+xf+xB1+yB>

v=h*05+c, +yf

Fisheye cameras

Xo=X1Z

Yo=Y /Z

o = SArt(xo” + Yo’)

X=Xg* tan'lrol ro

y=Yo* tan'ro/ 1o

r = sgrt(x? + y?)

X' = X(1 + Kqr? + Kor* + Kar® + Kar®) + (P1(r2+2x%) + 2P,xy)
Y' =YL+ Kar? + Kor* + Kar® + Kar®) + (Po(r+2y?) + 2P1xy)
u=w*05+c+xT+xB;+yB>y

v=h*05+c, +yf

Spherical cameras (equirectangular projection)

u=w* 05+f* tan(X / Z)
v=h*05+f* tan’ (Y / sort(X? + Z?))
where:

f=w/(2* pi)
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Cameramodels

4 Note

» Spherica (equirectangular) camera model doesn't support distortions. All distortions should be
corrected before loading images in Metashape.

* In case you are capturing panoramas with a rotated frame/fisheye camera, we recommend to
process original images in Metashape using camera station function instead of stitching them in
external software.

Spherical cameras (cylindrical projection)
u=w* 05+f* tan’{(X / Z)
v=h*05+f*Y/syt(X?+Z?
where:
f=w/(2* pi)
4 Note

» Spherica (cylindrical) camera model doesn't support distortions. All distortions should be
corrected before loading images in Metashape.

* In case you are capturing panoramas with a rotated frame/fisheye camera, we recommend to
process original images in Metashape using camera station function instead of stitching them in
external software.

217



Appendix E. What do some error
messages in Metashape mean?

In some caseswarning or error messages may be displayed after unexpected termination of the processing
operation in Metashape. Below isthelist of some messageswhich could be encountered and our comments
on the possible origins of the issue together with the recommendations for resolving the problem.

Empty extent - Bounding box ismisplaced during Build Tiled Model or Build Orthomosaic operation
and doesn't contain any information or all the cameras for the related area are disabled.

Empty camera list - no cameras are pointing to the area of the orthomosaic generation.

Empty frame path - the selected operation (for example, import DEM) requires the project to be
saved in PSX format.

Empty surface - Bounding box is misplaced during Build Mesh operation and doesn't contain any
information.

Index Overflow - usually such amessage is observed when the Arbitrary mesh generation method is
used based on avery big dense point cloud. To reduce the number of points you can use Filter Dense
Cloud option in the Tools menu or shrink the bounding box to the smaller volume using Resize Region
instruments in the Model view mode.

Null point cloud - missing point cloud for the operation based on it (like mesh generation or
classification).

Null model - missing mesh model for the operation based on it (like mesh decimation).

Null tie points - missing tie point cloud for the operation based on it (like mesh generation).

Media resource couldn't beresolved - indicates that some video codecs are missing in the system,
SO we can suggest to install "K-lite Codec pack” or similar in order to guarantee the Import Video
operation. Note that you do not need to install any auxiliary utilities in addition to the codecs
themselves.

Some photos failed to align - the message indicates that some images were not aligned as a result
of the adjustment process. This may be due to poor image quality or insufficient overlap. We can
recommend you try to select images in the Workspace pane and select Align Selected Cameras
command from the context menu.

Zero resolution - Bounding box is misplaced prior to the Build Dense Cloud operation and doesn't
contain any information (almost no tie points are present in the bounding box and therefore no depth
maps can be generated).
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