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1. Presentation of the study 

1.1. Work environment 
 

Metashape =  https://www.agisoft.com/downloads/installer/  

QGIS =  https://qgis.org/fr/site/forusers/download.html  

Open Metashape (Figure 1) and go into Tools>Preferences> GPU (check your GPU devices to use 
them) then still in Preferences go to General > Language (choose the one you need). 

At this point, you should save your project: File > Save as… Give your project a name, ensuring that the 
‘save as type’ box is ‘PhotoScan project (*.psx)’ (or *.psz if using an older version of PhotoScan). 

 

 

To know: 

1. Save your project regularly to prevent data loss. 
2. Adjust parameters based on project specifics. 
3. Remember that the quality of results depends on the input data quality and appropriate 

settings in Metashape. 
4. Metashape documentation here: https://www.agisoft.com/pdf/metashape-pro_1_5_en.pdf  

or here in French: https://www.agisoft.com/pdf/manuals_other/metashape_pro_fr_1_5.pdf  

 

 

Figure 1 : Agisoft Metashape Pro environnment 

https://www.agisoft.com/downloads/installer/
https://qgis.org/fr/site/forusers/download.html
https://www.agisoft.com/pdf/metashape-pro_1_5_en.pdf
https://www.agisoft.com/pdf/manuals_other/metashape_pro_fr_1_5.pdf


4 
 

1.2. Goal of this practical work 
 

The Syndicat Rivière Ain Aval Affluents (SR3A) has deposited several cubic meters of sediment on the 
banks of the Ain, south of the village of Varambon, in order to compensate for a decrease in sediment 
inputs into the river. However, it is impossible to get hold of the document where the volume that was 
deposited was noted… 

We ask you to find a way to estimate as accurately as possible the volume of sediments depot for the 
syndicat (Figure 2). Look at the picture of the terrain (Figure 3). 

Look where is it, on Google Earth: https://earth.google.com/earth/d/1oszw_eheioh4IBu_iL-
ml504gMGBc7IU?usp=sharing  

  

Figure 3 : Area of study 

Figure 2 : Scheme of the study 

https://earth.google.com/earth/d/1oszw_eheioh4IBu_iL-ml504gMGBc7IU?usp=sharing
https://earth.google.com/earth/d/1oszw_eheioh4IBu_iL-ml504gMGBc7IU?usp=sharing
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1.3. Data acquisition  
Capture Aerial or Ground Photos 

Images have been captured with good coverage and sufficient overlap (70% overlap). Usually, we use 
an overlap of 70% in longitudinal and 70% in lateral. 

Before the flight, the height is adjusted according to the camera parameters to get the spatial 
resolution you need for your project. 

Collect GCP on the field 

On-site, well-distributed Ground Controlling Points (GCP) are flashed. Record precise coordinates for 
each point (here it has been used GNSS Trimble R12). I advise you to import your points coordinates 
into a GIS as QGIS. Then choose which points will be used as GCP among all points and which will be 
used as check points.   



6 
 

2. Build tie cloud (nuage de points homologues) 
Explanation below (Figure 4)(1) 

 

2.1. Import photos 
Go to Workflow > Add Photos… or Add Folder…. You can choose to either add a selection of photos or 
add an entire folder. Select the folder where the photos are stored and all of them will be brought 
together. Alternatively, drag the image files directly into the Workspace pane.  

If you have images with EXIF information you need to push the button indicates to collect coordinates 
information for each image (Figure 5). Even though there is no EXIF information you could still have 
the coordinates in the image.  

“EXIF stands for ‘Exchangeable Image File’ or data exchange file. EXIF is a set of information relating to 
each photo and presented in a standardized format. This data is generated by the camera when 
shooting, automatically. They are stored in the image file for JPG, TIFF and RAW formats.” 
(https://www.nikonpassion.com/qu-est-ce-que-donnees-exif-comment-lire-utiliser/ ). 

Figure 4 :Differences between DSM and DTM (CDEMA, 2014) 

Figure 5 :On the left-up screen informations from camera acquisition for each image 
and on the right bottom screen information about each picture 

https://www.nikonpassion.com/qu-est-ce-que-donnees-exif-comment-lire-utiliser/
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When you import your images and the coordinates are not found by the software even though you 
have the coordinates into a file like .txt file there is a way to catch up the coordinates.  

First of all, if you have a file with name of each image you need to add the extension format of the 
image. For instance, if the image is in .tif you need to add the information. Moreover, you need as well 
to have the separation of column right (Figure 7). Be careful, to convert your coordinates into 
coordinates accepted by Metashape. 

Then, when your file imported is ok, you must go to File>Import>Reference (Figure 6) 

 

Figure 7 : coordinates of your images, taking from your .txt file  

Figure 6 : Import coordinates and information of IMU (yaw,pitch and Roll) 
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2.2. Observe metadata  
Right click > Show infos 

What do you see ? Que voyez-vous ? (Figure 8) 
……………………………………………………………………………………………………………………………………………………………
……………………………………………………………………………………………………………………………………………………… 

 

File>Import> Import Reference > GCP (check that your columns are correctly placed) 

Before continuing, go into reference Settings and put the good coordinate system for camera and 
marker reference.  

Figure 8 : metadata image 

Figure 9 : Import ground points coordinates 
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The GCPs allow you to convert your model in the desired coordinate system and/or adjust the 
altitude.  

 

2.3. Update coordinate system preferences 
Now, you have to update coordinate preferences for project, camera and references (Figure 10). 

Choose the coordinates system in the panel. If you use one with a geoid applied you maybe will need 
to import a geoid in Metashape Pro folders. Go at this link to get geoid file adapted for Metashape: 
https://www.agisoft.com/downloads/geoids/ . To know the process to do follow this link : 
https://agisoft.freshdesk.com/support/solutions/articles/31000148332-how-to-use-height-above-
geoid-for-the-coordinate-system . 

2.4. Image quality control 
 

The aim of this step is to eliminate any blurred, out-of-focus or unwanted photos from your photoset. 
These images may obscure some of the features needed to match overlapping imagers and may 
decrease the accuracy of the final product. 

If a photo appears blurred or a major portion of a photo appears blurred, remove it.  

 

On the bottom screen “Photos” right click on it > Estimate Image Quality>All images (Figure 11). If your 
image quality is below 0.7 you should remove it. You can choose the threshold you would prefer 
according to the quality of data you have. 

Figure 10 : Update coordinate system preferences 

https://www.agisoft.com/downloads/geoids/
https://agisoft.freshdesk.com/support/solutions/articles/31000148332-how-to-use-height-above-geoid-for-the-coordinate-system
https://agisoft.freshdesk.com/support/solutions/articles/31000148332-how-to-use-height-above-geoid-for-the-coordinate-system
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What do you see ? Que voyez-vous ? Figure 8 (Figure 11) 
……………………………………………………………………………………………………………………………………………………………
……………………………………………………………………………………………………………………………………………………… 

 

2.5. Align images 
The first step in the model generation process is to align the photos (Figure 12). This process results in 
a sparse point cloud, representing the ties points found between overlapping images, and the initial 
camera locations; both are found using the SIFT (Scale-Invariant Feature Transform) algorithm to find 
matching point between overlapping images. 

Go to Workflow > Align Photos (the virgule means thousand).  

Figure 11 : Estimate Image Quality 
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 Several parameters are required in the Align photos dialog, which 
are explained below (Figure 12). 

Accuracy: Highest – High – [Medium] – Low - Lowest (the photos will not be down sampled - this 

helps with later steps. lower accuracy setting can be used to get the rough camera positions in the 
shorter time)  

Generic preselection: Disabled – [Enabled]. If disabled, processing is faster. Enable the option if you 
have issues aligning some photos. 

Reference preselection: Disabled – [Enabled]. If your photos are geotagged, this will use the GPS 
positions to speed up camera alignment. 

Key point limit: [40,000] is default. Lower number of key points can speed up processing, but increases 
the risks of lacking points for correct alignment.  

Tie point limit: 4000 is default but [10000] is usually used. Sets the minimum number of ties needed 
to match images.  

be set to 0 if images not aligning, but at the expense of lower accuracy. 

Constrain features by mask: [Disabled] (Enabled in case any area has been masked prior to 

processing). 

You can change the size of the region of interest in going into Resize region  

Figure 12 : Align Photos tools 
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Through this, you will get in the view the photos aligned and you will get the tie points found. 

 

2.6. Clean tie points 
Tie points created, you can now clean them by hands in removing points which seem wrong, like the 
very low and high ones (Figure 14).  

How is your tie points cloud ? Comment est votre nuage de points homologues ? Figure 8 
……………………………………………………………………………………………………………………………………………………………
……………………………………………………………………………………………………………………………………………………… 

2.7. Create two chunks (projects) 
You copy your project. Now, you have one named without GCPs and one with GCPs. 

 

 

 

 

Figure 13 : Tool to select in the main panel  
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3. Create models with or without GCPs 

3.1. Without GCPs 

3.1.1. Optimized camera alignment  
Click on Optimized camera alignment on reference bar (Figure 14).  

The depth map will be removed. 

This function takes into account: 

(1) Internal parameters (camera intrinsics): 
Focal length. 
Principal point offset (cx, cy). 
Lens distortion coefficients (e.g., radial and tangential distortion). 

(2) External parameters (camera extrinsics): 
Camera position (X, Y, Z). 
Camera orientation (yaw, pitch, roll or rotation matrix) 

 

Figure 14 : Optimized camera alignment 
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3.1.2. Build dense cloud 
In order to build the dense cloud, you need to have a depth map. After the step of Optimized 
Camera, you lose the depth map. That’s why when you launch the tool Build dense cloud, the 
software builds automatically a depth map and then the dense cloud.   

 

Figure 15 :  Filter Photos by Marker 

Once at least three markers are set, the software can estimate the location of all the remaining GCPs. 
Click the Update Transform button in the Reference pane (Figure 17). 

Figure 16 : Tool to refresh your model in the main panel 
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3.1.3. Create dense cloud 
Based on the estimated camera positions, the program calculates depth information for each camera 
to be combined into a single dense point cloud. The dense point cloud operation fills in all the blank or 
empty areas in the sparse cloud and assigns colors values based on these photos. Dense point cloud 
generation is based on depth maps calculated using dense stereo matching. Go to Workflow > Build 
Dense Cloud. (Figure 19). 

Set the following recommended values for the parameters in the Build Dense Cloud dialog: 

 

Quality: Ultra high – [High] – Medium – Low - Lowest: Uses original photos. Requires a large amount 
of memory, so recommended only for specific hardware setups. If small number of photos and/or high 
quality required, select Ultra high. Otherwise, High usually achieves good quality results or Medium if 
your computer is not adapted for heavy treatments.  

• High: Photos are downsampled by a factor of 4. Recommended for smaller photosets.  
• Medium: Photos are downsampled by an additional factor of 4. Recommended for larger 

photosets. 
• Low: Photos are downsampled by an additional factor of 4. Not recommended.  

Depth filtering: Disabled – Mild – Moderate – [Aggressive]: (if the geometry of the scene to be 
reconstructed is complex with numerous small details or untextured surfaces, like roofs, it is 
recommended to set Mild depth filtering mode, for important features not to be sorted out. If mild 
and aggressive options do not seem optimal for your data, select Moderate).  

Reuse depth maps: disable  

Calculate point confidence: = important to clic here to clean dense cloud then. Metashape assigns a 
confidence score to each point in the dense point cloud, based on various criteria such as the 
redundancy of a point's observations (how many photos it has been seen by). 

After this step, a dense point cloud will appear. 

 

Figure 17 : Build Dense Cloud 
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3.1.4. Clean dense cloud 
(1) Filter your points cloud by confidence  

Before starting the cleaning, click on the button Show Markers and deselect the markers (Figure 20). 

Confidence value can be used to perform additional filtering of low confidence points. For every point 
in a point cloud the number of contributing combined depth maps is recorded and stored as a 
confidence value.(2) 

You can now, filter by confidence and remove the points with the lowest confidence. 

Go into Tools>Dense Cloud>Filter by Confidence (Figure 21). 

You have to increase the minimum value of confidence you want and test what is the better in your 
case. The idea is to remove the points with less confidence. 

Then do the same process but between 0 and the minimum value of confidence. Now, all points with 
confidence you don’t want are selected.  

Delete them. 

Tool>Dense Cloud>Reset Filter 

Save project. 

 

Figure 18 : Filter points by confidence 

Figure 19 : Button Show Markers 



17 
 

(2) Filter incoherence by hands 

When you look at your cloud points and if you still have points that are below sur surface or way 
above, you must remove them. 

To do this, go to the icon Free-from Selection (Figure 22) 

 

 

What does your dense point cloud look like? A quoi ressemble votre nuage de points dense ? Figure 8 
……………………………………………………………………………………………………………………………………………………………
…………………………………………………………………………………………………………………………………………………… 

  

Figure 20 : Select by hands points 
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3.1.5. Class ground points 
Tools>Dense cloud>Classifying ground points (Figure 23) 

 

From: you can choose what class of points 

 Max angle (deg) : Determines one of the conditions to be checked while testing a point as a ground 
one, i.e. sets limitation for an angle between terrain model and the line to connect the point in 
question with a point from a Editing ground class. For nearly flat terrain it is recommended to use 
default value of 15 deg for the parameter. It is reasonable to set a higher value, if the terrain contains 
steep slopes. 

Max distance (m) : Determines one of the conditions to be checked while testing a point as a ground 
one, i.e. sets limitation for a distance between the point in question and terrain model. In fact, this 
parameter determines the assumption for the maximum variation of the ground elevation at a time. 
 

Cell size (m) : Determines the size of the cells for point cloud to be divided into as a  preparatory step 
in ground points classification procedure. Cell size should be indicated with respect to the size of the 
largest area within the scene that does not contain any ground points, e. g.a building or a dense forest 
or a bridge. 

Erosion radius (m): Determines the indentation (in meters) from unclassified points to create an 
additional area from the object, it is useful when classifying houses and trees to exclude the remaining 
"stumps" when building DTM 

3.1.6. Build a DEM (here MNT) 
Digital elevation model = DEM 

With the points you classed you can build a DEM of ground or all points. 

Go to Workflow>Build DEM (Figure 24). A dialog box will appear. Specify the coordinate system, source 
data, interpolation, and point classes to include. The coordinate system can be modified when the 

Figure 21 : Classify ground points 
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DEM is exported. Be aware that DEM generation relies on sets of parameters that cannot be set in 
Metashape. For higher control on DEM creation parameters, it is advised to export model as Point 
Cloud and use other software (eg. ArcGIS, QGIS, Matlab, R, LASTools, CloudCompare, etc.).  

Set the following recommended values for the parameters in the Build DEM dialog: 

Projection type: [Geographic] – Planar – Cylindrical (if you used 
a projected or geographic coordinate system, you should select 
Geographic. Only use Planar if working in local coordinate 
system). 

Projection: default (projection set in the Reference Settings is 
used. The coordinate system must be the same as coordinate 
system of GCPs). 

Source data: Sparse cloud – [Dense cloud] 

Interpolation: [Enabled](default) – Extrapolated. 

Points classes: Use only « Ground » 

The resolution is automatically defined by the software. You will 
be able to change this when you export it. 

Think to export your DEM (MNT) 

 

 

3.1.7. Build Orthomosaic (optional for the project) 
 

You can build an orthomosaic with the DEM. However, you need a lot of rams Go (Figure 25). 

Workflow>Build Orthomosaic 

A dialog box will appear. A number of parameters may be set： 

Projection type: Same as DEM (see above). 

Projection: by default, the projection set in the Reference Settings is used. 

Figure 22 : Build DEM (en français MNT) 
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Surface: DEM: Best for aerial survey data and mesh + texture 
best for surfaces data as a building to have a smooth and 
detailed surface 

Blending mode: [Mosaic] – Average - Disabled (blends specific 
pixels from photo with best representation of feature with 
pixels from other images to avoid seams in the texture). 

Enable back-face culling: Enabled – [Disabled]. (Option mostly 
important for non-vertical images). 

Enable hole filling: [Enabled] –Disabled. 

Pixel size (m): it is advised to choose the same pixel size as the 
one chosen for DEM generation. If no DEM was build, follow 
the same rules as above when choosing resolution: aim for 
orthogonality while keeping highest resolution possible. 

Region: it is advised to choose the same boundaries as the 
ones picked for DEM building. If no DEM was built, select 
boundaries that are coherent with resolution and allow 
correct model orthogonality. 

Total size (pix): will adjust automatically with resolution and 
boundaries. 

Click OK button to start Orthomosaic generation. 

 

3.2. With GCPs 

3.2.1. Import GCPs 
 

GCPs should be surveyed prior to image acquisition using a dGNSS. These are necessary to 
georeferenced your model in a real-world coordinate system, especially if your photos are not 
geotagged. They can also be used to determine model accuracy, i.e. how confident you can be about 
the model. The number of GCPs required to generate accurate models depends on the camera used 
(distortion, resolution, etc.), local topography (high topography difference require more GCPs) and the 
purpose of the survey (e.g. detection of changes require high accuracy, hence a higher density of GCPs). 

Import coordinates of points taken by DGNSS and only select the ones that you want to keep for the 
process (Figure 9). Keep only the points: 8;6;5;1;4;12;9. The others will be used later. 

 

3.2.2. Georeferencing GCPs 
I advise you to import your GCPs coordinates into a GIS as QGIS. Then chose which points will be used 
as GCP among all points. The step allows to correct the coordinates of your model and adding the 
altitude geoid correction (if the GCPs altitude have been corrected). 

Figure 23 : Build orthomosaic 
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All points are represented by a white flag on images randomly, meaning that either the software or 
you have not placed the point.  

When the software has placed a point, the flag will be in blue. When you move manually a point the 
flag go from white or blue to green. Green flag means it has been verified by you. 

To associate the points with their locations manually click on each image and if you find the place of a 
GCP (Figure 15), you have to move the point into the center of your marker (red square for example). 

 

When a GCP is identified in at least two photographs, the software is able to automatically estimate 
the location of that GCP in all aligned photos (blue flag appears). Right-click on the marker in the 
Reference pane and choose Filter Photos by Marker (Figure 15) in the dropdown menu. Sort through 
these photos and place the marker accurately in each of them. If the GCP is not in the photo or 
inaccurately placed, right-click the flag that appears on the photo and choose Remove Marker from 
the dropdown menu that appears. 

You have to use the tool Optimized camera alignment, in order to used the GCPs for corrections of 
of your model. 

3.2.3. Repeat the steps from the part 3.1 
Now, you can repeat the steps from 3.1.2(Build dense cloud) to 3.1.6(Build a DEM (here MNT)) 

 

 

4. Export products 

4.1. Export DEM and orthomosaic 
 

Export DEM and Orthomosaic : File>Export>DEM and Orthomosaic (Figure 26). 

Figure 24 : Red target 
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4.2. Export the report of everything you did in Metashape  
Export the report of all your treatments in order to know what you have done in Metashape (Figure 
27). File>Export>Generate Report 

  

Figure 25 : DEM and Orthomosaic 

Figure 26 : Export the report of your workflow in Metashape 
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5. QGIS Calculate a volume from a DEM 
 

5.1. Import your DEM of the terrain you made in last steps 
Import your DEM (MNT) that you built in Metashape or another software. 

And import the points of control (all of them). 

What does your DEM (Surface and Soil) look like (visual quality)? A quoi ressemble votre MNS et 
MNT(qualité visuelle) ? Figure 8 
……………………………………………………………………………………………………………………………………………………………
…………………………………………………………………………………………………………………………………………………… 

 

5.2. Estimate difference of height between model and GNSS 
points GCP  

It exists many ways to compared your DEM model with GCP that have been used. 

In QGIS you can use Point Sampling Tool or “Prélever des valeurs rasters” in French . 

Now, you have a table with the altitude from the DEM and from the GCP. You are able to know the 
differences of altitude between them. 

Is there a significant difference between the altitudes of the DEM and the altitudes of the other 
points? Y a-t-il une différence significative entre les altitudes du MNT et les altitudes des autres points 
?……………………………………………………………………………………………………………………………………………………………
…………………………………………………………………………………………………………………………………………………… 

5.3. Cut you DEM by the limit of the sediment depot 
Import the polygon from your folder Varambon_study\input\borders_depot.shp 

Then cut you raster DEM by limits of the polygon. 

5.4. Import water level points format .shp  
Import the polygon from your folder Varambon_study\input\coordinates_GNSS\ water_level_.shp  If  

5.5. Create a raster from measured water level points with linear 
interpolation. 

Tools box(Boîte à outils) >Interpolation IDW (Inverse Distance Weighted): In the IDW interpolation 
method, the sample points are weighted during interpolation such that the influence of one point 
relative to another declines with distance from the unknown point you want to create (Figure 29). 

Take the same spatial resolution as the MNT and the the same coordinates system. 
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If the layer doesn’t work for the interpolation create a new point layer and fill the points with the 
altitude values (Figure 28).  

5.6. Cut the peace of your DEM that you are interested to know 
the volume 

Layer>Create a layer>New shapefile layer (edit your layer and draw the limits of your depot). In the 
folder input or output there is already a layer available of the limits.  

Figure 27 : Create a new point layer 

Figure 28 : Interpolation of your points layer to raster 
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Raster>Cut raster from a mask polygon (Figure 29) 

Figure 29 : Cut raster according to a mask 

5.7. Subtract MNT with raster 
Calculate Raster:  

MNT_cut – raster interpolated 

The new raster has only the difference of altitude. Pixels values will be small (between 0 and some 
meters). If the no-data are very big, no problem you will be able to precise in the next step. 

5.8. Calculate the volume of the sediment depot 
Tool>Raster Surface Volume 

Method: Above base level 
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